[SOLVED] FHEM kann nicht installiert werden

Max2Play Home 2016 (en) Forums Max2Play Add-ons [SOLVED] FHEM kann nicht installiert werden

Tagged: 

This topic contains 9 replies, has 4 voices, and was last updated by  jonastoto 1 year, 5 months ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • 25. Februar 2017 at 19:04 #27226

    Hallo,
    ich wollte darauf aufmerksam machen, dass debian.fhem.de wohl die Server umgestellt hat, wodurch sich die Installation über das Plugin momentan nicht durchführen lässt.
    Und zwar erfolgt der Zugriff nun über http:// anstatt über https://.
    Könntet ihr das anpassen?
    Vielen Dank schon mal im Voraus!

    MfG, Stefan

    1. März 2017 at 21:33 #27382

    Kriege den FHEM Server auch nicht Installiert.
    Sagt zwar das er Fertig ist, es ist aber nichts installiert

    2. März 2017 at 14:01 #27396

    Hallo Schnubby,

    um FHEM zu installieren gibt folgenden Code in die Kommandozeile ein:

    sudo apt-get -y install perl-base libdevice-serialport-perl libwww-perl libio-socket-ssl-perl libcgi-pm-perl libjson-perl sqlite3 libdbd-sqlite3-perl libtext-diff-perl libtimedate-perl libmail-imapclient-perl libgd-graph-perl libtext-csv-perl libxml-simple-perl liblist-moreutils-perl ttf-liberation libimage-librsvg-perl libgd-text-perl libsocket6-perl libio-socket-inet6-perl libmime-base64-perl libimage-info-perl libusb-1.0-0-dev libnet-server-perl && wget http://debian.fhem.de/fhem-5.8.deb && sudo dpkg -i fhem-5.8.deb && sudo useradd –system –home /opt/fhem –gid dialout –shell /bin/false fhem && sudo cp /opt/fhem/contrib/init-scripts/fhem.3 /etc/init.d/fhem && sudo chmod a+x /etc/init.d/fhem && sudo update-rc.d fhem defaults

    Dadurch wird FHEM installiert. Man hat dann zwar kein Plugin auf der Max2Play seite, aber FHEM lässt sich dann wie üblich über http://deine-ip:8083/fhem aufrufen.

    LG Stefan

    2. März 2017 at 14:32 #27401

    Hallo Stefan und Schnubby,
    Entschuldigt die späte Rückmeldung und danke an Stefan für den temporären Workaround. Wir werden dieses Problem so schnell wie möglich beseitigen.

    2. März 2017 at 18:08 #27413

    Hallo nochmal, wir haben die Bezugs-URL nun angepasst und die Installation sollte wieder reibungslos funktionieren. Über Feedback würden wir uns freuen.

    6. März 2017 at 22:04 #27477

    Installation läuft immer noch nicht.

    Meldung in dem gelben Feld:

    FHEM Installation gestarted
    Installation gestartet - Diese Meldung zeigt den aktuellen Status der Installation aller 3 Sekunden an. Wenn diese abgeschlossen ist verschwindet die Meldung und der Server läuft.
    Get:8 http://mirrordirector.raspbian.org jessie/rpi armhf Packages [1,356 B]
    Ign http://archive.raspberrypi.org jessie/main Translation-en_GB
    Ign http://archive.raspberrypi.org jessie/main Translation-en
    Ign http://mirrordirector.raspbian.org jessie/contrib Translation-en_GB
    Ign http://mirrordirector.raspbian.org jessie/contrib Translation-en
    Ign http://mirrordirector.raspbian.org jessie/main Translation-en_GB
    Ign http://archive.raspberrypi.org jessie/ui Translation-en_GB
    Ign http://mirrordirector.raspbian.org jessie/main Translation-en
    Ign http://mirrordirector.raspbian.org jessie/non-free Translation-en_GB
    Ign http://archive.raspberrypi.org jessie/ui Translation-en
    Ign http://mirrordirector.raspbian.org jessie/non-free Translation-en
    Ign http://mirrordirector.raspbian.org jessie/rpi Translation-en_GB
    Ign http://mirrordirector.raspbian.org jessie/rpi Translation-en
    Fetched 9,332 kB in 18s (492 kB/s)
    Reading package lists...
    Reading package lists...
    Building dependency tree...
    Reading state information...
    0 upgraded, 0 newly installed, 0 to remove and 103 not upgraded.
    Finished

    Das gelbe Feld verschwindet nicht wie oben angekündigt und der Server läuft auch nicht.

    • This reply was modified 1 year, 6 months ago by  Schnubby.
    6. März 2017 at 22:14 #27478

    Installation läuft immer noch nicht.

    Meldung in dem gelben Feld:

    FHEM Installation gestarted
    Installation gestartet - Diese Meldung zeigt den aktuellen Status der Installation aller 3 Sekunden an. Wenn diese abgeschlossen ist verschwindet die Meldung und der Server läuft.
    Get:8 http://mirrordirector.raspbian.org jessie/rpi armhf Packages [1,356 B]
    Ign http://archive.raspberrypi.org jessie/main Translation-en_GB
    Ign http://archive.raspberrypi.org jessie/main Translation-en
    Ign http://mirrordirector.raspbian.org jessie/contrib Translation-en_GB
    Ign http://mirrordirector.raspbian.org jessie/contrib Translation-en
    Ign http://mirrordirector.raspbian.org jessie/main Translation-en_GB
    Ign http://archive.raspberrypi.org jessie/ui Translation-en_GB
    Ign http://mirrordirector.raspbian.org jessie/main Translation-en
    Ign http://mirrordirector.raspbian.org jessie/non-free Translation-en_GB
    Ign http://archive.raspberrypi.org jessie/ui Translation-en
    Ign http://mirrordirector.raspbian.org jessie/non-free Translation-en
    Ign http://mirrordirector.raspbian.org jessie/rpi Translation-en_GB
    Ign http://mirrordirector.raspbian.org jessie/rpi Translation-en
    Fetched 9,332 kB in 18s (492 kB/s)
    Reading package lists...
    Reading package lists...
    Building dependency tree...
    Reading state information...
    0 upgraded, 0 newly installed, 0 to remove and 103 not upgraded.
    Finished

    Das gelbe Feld verschwindet nicht wie oben angekündigt und der Server läuft auch nicht.

    Leider bekomme ich auch bei dem Vorschlag von Stefan am ende einen Error und der Server läuft nicht.

    Habe mal die letzten Zeilen kopiert:

    Setting up libxml-parser-perl (2.41-3) ...
    Setting up libxml-sax-expat-perl (0.40-2) ...
    update-perl-sax-parsers: Registering Perl SAX parser XML::SAX::Expat with priority 50...
    update-perl-sax-parsers: Updating overall Perl SAX parser modules info file...
    Replacing config file /etc/perl/XML/SAX/ParserDetails.ini with new version
    Setting up libxml-simple-perl (2.20-1) ...
    Setting up libimage-info-perl (1.28-1) ...
    --2017-03-06 21:09:16--  http://debian.fhem.de/fhem-5.8.deb
    Resolving debian.fhem.de (debian.fhem.de)... 52.222.171.123, 52.222.171.197, 52.222.171.141, ...
    Connecting to debian.fhem.de (debian.fhem.de)|52.222.171.123|:80... connected.
    HTTP request sent, awaiting response... 404 Not Found
    2017-03-06 21:09:16 ERROR 404: Not Found.
    

    Wäre super wenn mir da wer bei meinem Problem helfen könnte

    • This reply was modified 1 year, 6 months ago by  Schnubby.
    7. März 2017 at 18:43 #27491

    Hallo Schnubby,
    Wir haben die Bezugsquelle erneut angepasst, diese scheint über das Wochenende erneut gewechselt worden zu sein. Bitte mache erneut ein Beta-Update und versuche es nochmal.

    7. März 2017 at 21:02 #27493

    Server läuft 🙂
    Danke für die schnelle Hilfe.

    15. April 2017 at 8:29 #28260

    Hallo,

    leider besteht das Problem (wieder?) noch.
    Auch der Tipp von Pitcher90 funktioniert nicht –Fehler 404–.

    Gruß

    jonastoto

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.

Register here