[FAIL] startpar: service(s) returned failure: rc.local… failed!

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI [FAIL] startpar: service(s) returned failure: rc.local… failed!

This topic contains 2 replies, has 2 voices, and was last updated by  asplundj premium 9 months, 2 weeks ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • 14. August 2016 at 20:46 #22264

    When I boot up max2play on my pi I get the following message:
    [FAIL] startpar: service(s) returned failure: rc.local… failed!

    What does this mean? should I care about it? How can I fix it?

    my /etc/rc.local contains this:

    #!/bin/sh -e
    #
    # rc.local
    #
    # This script is executed at the end of each multiuser runlevel.
    # Make sure that the script will “exit 0” on success or any other
    # value on error.
    #
    # In order to enable or disable this script just change the execution
    # bits.
    #
    # By default this script does nothing.

    # Print the IP address
    _IP=$(hostname -I) || true
    if [ “$_IP” ]; then
    printf “My IP address is %s\n” “$_IP”
    fi

    #Max2Play
    sudo -u pi -H -s /opt/max2play/autostart_xbmc.sh > /dev/null 2>&1 &

    #Network Check for Mountpoints
    COUNTER=0;while [ -z “$(/sbin/ifconfig eth0 | grep -i ‘inet ad’)” -a -z “$(/sbin/ifconfig wlan0 | grep -i ‘inet ad’)” -a “$COUNTER” -lt “5” ]; do echo “Waiting for network”;COUNTER=$((COUNTER+1));$

    #Max2Play Start Audioplayer
    sudo -u pi -H -s /opt/max2play/start_audioplayer.sh > /dev/null 2>&1 &

    ; fi
    exit 0

    16. August 2016 at 15:15 #22292

    Hi,

    something seems to have gone wrong while installing / deinstalling some services. Please use the following code for your rc.local:

    #!/bin/sh -e
    #
    # rc.local
    #
    # This script is executed at the end of each multiuser runlevel.
    # Make sure that the script will "exit 0" on success or any other
    # value on error.
    #
    # In order to enable or disable this script just change the execution
    # bits.
    #
    # By default this script does nothing.
    
    # Print the IP address
    _IP=$(hostname -I) || true
    if [ "$_IP" ]; then
      printf "My IP address is %s\n" "$_IP"
    fi
    
    #Max2Play
    sudo -u pi -H -s /opt/max2play/autostart_xbmc.sh > /dev/null 2>&1 &
    
    #Network Check for Mountpoints
    COUNTER=0;while [ -z "$(/sbin/ifconfig eth0 | grep -i 'inet ad')" -a -z "$(/sbin/ifconfig wlan0 | grep -i 'inet ad')" -a "$COUNTER" -lt "5" ]; do echo "Waiting for network";COUNTER=$((COUNTER+1));sleep 3;done;set +e;/bin/mount -a;set -e;
    
    #Max2Play Start Audioplayer
    sudo -u pi -H -s /opt/max2play/start_audioplayer.sh > /dev/null 2>&1 &
    
    if [ "$(LANG=C && /sbin/ifconfig eth0 | grep 'inet addr:' | wc -l)" -lt "1" ]; then sudo /opt/max2play/wps_config.sh; fi
    
    exit 0
    

    If you remember what you did before this happened, please tell us and we will fix the bug.

    Thx.

    16. August 2016 at 16:41 #22293

    That solves it. I don’t know when it started

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.

Register here