[SOLVED] External hard drive switches port on reboot

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI [SOLVED] External hard drive switches port on reboot

This topic contains 4 replies, has 2 voices, and was last updated by  Paden premium 2 months, 3 weeks ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • 16. March 2017 at 23:03 #27774

    Hey all
    My brother is running Squeezebox Server on a RPI, however following a reboot the connected media always appears on a different port, requiring locating where the media has moved to & then a rescan 🙁
    The drive is a Seagate Backup Plus Slim 2 TB USB 3.0 Portable 2.5 inch External Hard Drive.
    Here’s the config page, can anyone see anything wrong?
    Filesystem Mount

    Appreciate any help 🙂

    Cheers, Paul

    • This topic was modified 5 months ago by  Paden.
    • This topic was modified 2 months, 3 weeks ago by  Heiner.
    20. March 2017 at 12:28 #27801

    Hi Paden,

    From the screen shot that you sent, you just configured the mount point, but also you have to configure External Drives on Max2Play – mountpoints for USB-Storage.

    Please take a look on this information:

    Network Shares (e.g. shares on Synology Diskstation with SMB/CIFS) are mounted following the example:
    *Path (IP or hostname and Path): for type cifs: //IP-ADDRESS/PATH
    *Mountpoint on Max2Play (for usage in Squeezebox Server or XBMC): /mnt/mountdir/ Mountpoint must be a subdirectory in /mnt/ OR /media/ and will be generated, if it is not existing.
    *Type: mostly cifs (in special NFS setups nfs)
    *Options (user, password and other options for network share): e.g. user=name,password=pass,sec=ntlm,iocharset=utf8
    *important: always add to the options sec=ntlm!
    *Note on NFS-Shares: you must use another Path and no user credentials in options! Example: IP-ADDRESS:PATH or *:PATH

    Under External Drives on Max2Play – mountpoints for USB-Storage
    there is a list that shows all external storages and their mountpoints. You may access the devices by their path in Squeezeboxserver or XBMC/Kodi. Important: the maximum partition size is 2TB. If using larger disks you need to divide the disk space into partitions smaller than 2TB.

    Best Regards,
    Mohamamd Mbydeen

    22. March 2017 at 22:16 #27833

    Hi Mohamamd, thanks for the reply, although I’m unclear as to what hasn’t been configured.
    I’ve mounted the drives under:
    External Drives on Max2Play – mountpoints for USB-Storage
    Which in turn automatically populated:
    Filesystem – mount network paths (Samba or NFS)
    The “type” automatically detected is vfat, could it be that the drive is not formatted in the correct format?
    Like I said all works fine until a reboot.

    Cheers, Paul

    27. March 2017 at 14:46 #27871

    Hi Paden

    It could be the filesystem format is causing the problem, please try to change the file system form vFAT to CIFS or NFS.

    Best Regards,
    Mohammad Mbydeen

    24. May 2017 at 21:04 #29060

    Thanks for your help Mohammad , reformatting the drive has solved the issue 🙂

    Cheers, Paul

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.

Register here