Expand File System script does not work on Rpi 3 Beta version

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Expand File System script does not work on Rpi 3 Beta version

This topic contains 7 replies, has 5 voices, and was last updated by  flysurfer premium 8 months, 3 weeks ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • 10. March 2016 at 7:16 #19183

    Hi there.

    I’ve been trying to install the Beta version on Rpi3 (the one available for download Jessie 2.28) and I have realized that after I do a file system expansion, I am left with a terrible mess.
    The script runs without error messages in the web GUI BUT :

    –> The second partition is not actually extended !!

    New partition 3 is created nonetheless
    Worst of all, I am left with a double entry in my mounts to / which is NOT cool at all ! (one in mtab, one in fstab).? Ihaven’t been able to correct this.

    I have a complete mess inside my /etc/mtab see below :

    /dev/root / ext4 rw,noatime,data=ordered 0 0
    devtmpfs /dev devtmpfs rw,relatime,size=437228k,nr_inodes=109307,mode=755 0 0
    sysfs /sys sysfs rw,nosuid,nodev,noexec,relatime 0 0
    proc /proc proc rw,relatime 0 0
    tmpfs /dev/shm tmpfs rw,nosuid,nodev 0 0
    devpts /dev/pts devpts rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000 0 0
    tmpfs /run tmpfs rw,nosuid,nodev,mode=755 0 0
    tmpfs /run/lock tmpfs rw,nosuid,nodev,noexec,relatime,size=5120k 0 0
    tmpfs /sys/fs/cgroup tmpfs ro,nosuid,nodev,noexec,mode=755 0 0
    cgroup /sys/fs/cgroup/systemd cgroup rw,nosuid,nodev,noexec,relatime,xattr,release_agent=/lib/systemd/systemd-cgroups-agent,name=systemd 0 0
    cgroup /sys/fs/cgroup/cpuset cgroup rw,nosuid,nodev,noexec,relatime,cpuset 0 0
    cgroup /sys/fs/cgroup/cpu,cpuacct cgroup rw,nosuid,nodev,noexec,relatime,cpu,cpuacct 0 0
    cgroup /sys/fs/cgroup/blkio cgroup rw,nosuid,nodev,noexec,relatime,blkio 0 0
    cgroup /sys/fs/cgroup/devices cgroup rw,nosuid,nodev,noexec,relatime,devices 0 0
    cgroup /sys/fs/cgroup/freezer cgroup rw,nosuid,nodev,noexec,relatime,freezer 0 0
    cgroup /sys/fs/cgroup/net_cls cgroup rw,nosuid,nodev,noexec,relatime,net_cls 0 0
    systemd-1 /proc/sys/fs/binfmt_misc autofs rw,relatime,fd=22,pgrp=1,timeout=300,minproto=5,maxproto=5,direct 0 0
    debugfs /sys/kernel/debug debugfs rw,relatime 0 0
    mqueue /dev/mqueue mqueue rw,relatime 0 0
    configfs /sys/kernel/config configfs rw,relatime 0 0
    fusectl /sys/fs/fuse/connections fusectl rw,relatime 0 0
    /dev/mmcblk0p1 /boot vfat rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=ascii,shortname=mixed,errors=remount-ro 0 0
    tmpfs /run/user/0 tmpfs rw,nosuid,nodev,relatime,size=88312k,mode=700 0 0

    While my fstab is clean and neat with only what I want.

    proc /proc proc defaults 0 0
    /dev/mmcblk0p1 /boot vfat defaults 0 2
    /dev/mmcblk0p2 / ext4 defaults,noatime 0 1
    # a swapfile is not a swap partition, no line here
    # use dphys-swapfile swap[on|off] for that

    ##USERMOUNT

    Obviously, I am stuck at this point as trying to purge mtab (/proc/mounts) seems a daunting task to say the least.

    I’ve tried twice to reinstall and do fs extension on very first access to the GUI but same result both times so I believe that the script has a serious problem.
    So far I manually extend the second partiton on my main computer with gparted as a countermeasure.

    Help would be appreciated to correct the file system extension script !

    10. March 2016 at 14:51 #19192

    Is this a general issue with this image or does it work on rpi2?

    12. March 2016 at 0:49 #19221

    I haven’t tested the Jessie Beta on Rpi2 yet. I will try to reproduce it on Rpi2.

    After some intensive research it seems that :
    The mtab content found above is more or less normal.
    It should however release the temporary binds created at startup, in particular the one to the root file system.
    The problem seems thus related to the OS, in particular to the init scripts which create, then release the temporary mounts. I should end up with a unique mount to the root file system after boot, which is NOT the case. This may explain why the expansion script does not proceed successfully. Unfortunately my current knowledge of the init procedure stops me from correcting this issue.

    Let’s hope that new releases will be more polished. This is only a Beta…

    12. March 2016 at 9:11 #19223

    I tried the jessie image out on my rpi2 an an experiencing a problem that I think is related to this. The partition extends properly, I think. However I have troubles mounting my usb-drive. I’ve added it correctly to fstab to mount at /storage (just like I’ve done successfully with the previous image). However it’s also an entry for it in mtab that’s not released. in order to access the drive I have to sudo umount /storage followed by sudu mount /storage after each reboot.

    I’m also having problems with the samba server. I’m using the same smb.conf, to share /storage, as before but I can’t access it.

    Another problem is that kodi won’t autostart at reboot.

    13. March 2016 at 22:58 #19241

    Ok I’ve tested another route.
    I’ve installed a fresh Raspian Jessie complete, expanded the FS from command line, and then ran the max2play install script from GitHub.
    Apart from a few quirks due to the fact that the install script must be moved one directory up, and the unzip directory must be renamed to max2play, it ran completely. It just misses the install of ffmpeg which is not available from standard repo and it tries to install hd-idle_1.05_armhf.deb which should be inside the git package but is not.
    After all this, I get exactly the same stupid mounts from mtab/fstab so I believe it is related to Jessie.
    Still the expand script does not work out of the box in the Beta version so something must be done.

    14. March 2016 at 14:36 #19262

    Hi Lefuneste,

    thank you for your input. In our tests the filesystem expansion worked flawlessly, so it is hard for us to reproduce the issue. However, I strongly recommend you to check for updates on your Beta-Version.

    Roman from Max2Play

    16. March 2016 at 17:38 #19316

    what is the command line option for manually expanding the file system? Expanding via the Max2Play GUI doesn’t work on my image either

    18. March 2016 at 15:07 #19358

    You can expand the Filesystem with the Max2Play Webinterface and the Beta of Debian Jessie by:
    – Update the Webinterface to the latest BETA (on settings page) -> this fixes the bug that is still in the SD-Card image that you downloaded
    – make sure that you don’t have any external drives / usb-sticks connected when you expand the filesystem

    As the downloadable Beta version of the Jessie SD-Card-Image did not change until now, always make sure you update to the latest beta in the web interface if something doesn’t work as expected. I usually just put bugfixes in the Beta-update and once everything seems fine I will create a new SD-Card image that already contains the fixes.

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.

Register here