Ethernet and IP problems. Cannot set up Max2Play on Raspberry Pi 4

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Ethernet and IP problems. Cannot set up Max2Play on Raspberry Pi 4

This topic contains 6 replies, has 2 voices, and was last updated by  Quebrantahuesos premium 3 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • 3. Februar 2022 at 14:19 #52020

    I’m trying to set up three Raspberry Pi (RPi) to test Max2Play for multiroom audio. The two RPi 3 B+ with HifiBerry Amp2 HATs and using Max2Play’s Buster version 253 worked, whether I try them as a server or a player. However, when I try to use the RPi 4 B I have not been able to connect it. The green and yellow ethernet LEDs light up on the Pi but the router does not assign it an IP, although it does sometimes give it a name: PC-176 which I can see in the DHCP settings. I have tried rebooting the router, reinstalling SD cards, turning all manner of things on and off.

    I have tried installing Raspberry Pi OS on the SD card (I have tried several SD cards) and the router does give the RPi 4 B an IP address. However, I am running the Pi headless because I do not have an HDMI cable (coming from Amazon on Saturday!) and I have tried to use SSH to connect using the Ubuntu program Remmina, but all I get is „Could not start SSH session. Connection refused.”

    Is the (new) RPi 4 B malfunctioning? Is there something I can do to test it (without a monitor for the time being)? Is it a Max2Play problem?

    3. Februar 2022 at 16:56 #52028

    Hi Quebrantahuesos,

    At first I thought it might be because you weren’t using the Buster image for the Pi 4, but an older one, but then I read up again and you are already using the Buster image for your 3Bs. In this case, I could really imagine that the Pi 4 is defective.
    The best way to find out is indeed to connect a display and see the output of the boot sequence. However, I would rule out a Max2Play problem, as our test devices all work with the images. You could still test our new Buster Beta image (with Max2Play 2.55), but that shouldn’t really make any difference.

    10. Februar 2022 at 18:20 #52032

    Hello again, I’ve had a chance to test the RPi 4 with Raspberry Pi OS with a monitor, and both the ethernet and Wifi have successfully connected to the router with an IP and MAC address. I then tested it headless (with the wifi SSID and password already set up on RPi OS), and it worked again.
    Then I tested again with Max2Play, the only difference being the OS, and the ethernet did not connect. The wifi obviously didn’t connect because I hadn’t entered the SSID or password).
    So, it seems to be Max2Play (Buster) that’s causing the problem.
    On screen it says „boot: mode USB-MSD 4 order f41 retry 0/128 restart 53/-1“, „SD card detected“, „net:down“, „start4.elf: is not compatible“, „This board requires newer software“, and plenty of other things
    If you let me know what information you might need I’ll try my best to supply it.
    Thanks.

    10. Februar 2022 at 19:54 #52034

    I’ve just tried it with the Beta Max2Play (v255) and it works! The OS loads and I have LAN connection with router-assigned IP address.

    10. Februar 2022 at 20:25 #52035

    However, I’d rather not use the Beta because I don’t want anything unstable. Can you see a reason why it shouldn’t work with Buster v253?

    14. Februar 2022 at 12:24 #52044

    It’s nice that at least the new 2.55 image works. But I can’t explain why version 2.53 doesn’t work for you. Our test devices have no problems with it. And we haven’t heard anything like that from other users either.
    If 2.55 works for you, it’s best to stick with it. It should not have any disadvantages compared to the older 2.53 version. It’s still a beta image in theory, but that’s only because we haven’t fully completed testing with our plugins. The common, important Max2Play plugins all work with the new image. We are only still testing the more „exotic“ ones.

    14. Februar 2022 at 12:32 #52047

    Thanks Mario, I’ve since had the same problem on a RPi 3+ and also resolved it by using v255.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.

Register here