enabling LIRC disables sound output via IQaudio DAC+

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI enabling LIRC disables sound output via IQaudio DAC+

This topic contains 3 replies, has 2 voices, and was last updated by  Heiner Moderator 1 month, 1 week ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • 8. October 2017 at 15:59 #31786

    I’ve got an RPI3 with IQaudioDAC+, offical 7 inch touchscreen and MSI digital power switch. If I enable LIRC support I lose audio outpu through the IQaudio DAC+. If I disable it and reboot it comes back. The IR sensor is connected properly as I can create a LIRC config file. Should be possible to run all of these things together as I had it all running on raspbian jessie earlier in the year – just wanted something that was easier to tweeak which is why I’ve got max2play.

    Has anyone else run into similar problems and any hints on how to sort it?

    Thanks in advance.

    10. October 2017 at 9:17 #31837

    Hi mcp,

    Have you enabled hw volume control on Squeezelite and disabled the built-in audio card yet?

    Optimizing Squeezelite’s Volume Control

    10. October 2017 at 13:16 #31847

    Thanks for the reply.

    I’ve checked the menus and yes I have unfortunately. Because of what you suggested I’ve tried with both the hw volume control and built-in audio enabled and disabled. enabling LIRC disables the audio through the soundcard either way.

    11. October 2017 at 11:34 #31860

    Hi mcp,

    Your GPIO pins probably overlap with the ones the Pi-DAC uses. Here is an overview of which ones you can use: https://pinout.xyz/pinout/pi_dac

    You can change this selection in our Raspberry Settings.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Register here