edimax ac600 wlan stick on rp1b+ not working

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI edimax ac600 wlan stick on rp1b+ not working

This topic contains 1 reply, has 2 voices, and was last updated by  Heiner Moderator 3 years, 3 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • 6. März 2018 at 21:59 #34245

    Hello supportteam,

    i need help getting my edimax ac600 wlan stick to work on a raspberry pi B+.
    After activating the Load WiFi Interface in the WiFi & Network configuration tab i get the folowing message

    Debug: Saving WPA-Supplicant (Successfully initialized wpa_supplicant Could not read interface wlan0 flags: No such device WEXT: Could not set interface ‚wlan0‘ UP wlan0: Failed to initialize driver interface )
    Data saved
    Status: WiFi USB adapter status is not active. WiFi connection status is not active
    (Only WPA/WPA2-Encryption possible)

    I assumed WLAN is a premium feature so i bought the 5-years-licence and activated it.
    But after rebooting i get the same error message. There is no wlan0 device, which is surprising as max2play sells a edimax wlan dongle in the shop and guaranties it to work. I understand it is not the same device but the wlan chip ist commonly used with the rasppberry pi and should be supported.
    Here are some infos from my setup

    [email protected]:/home/pi# uname -a
    Linux max2play1-rp1 4.9.39+ #1020 Sat Jul 22 14:08:01 BST 2017 armv6l GNU/Linux

    [email protected]:/home/pi# lsusb
    Bus 001 Device 004: ID 7392:a812 Edimax Technology Co., Ltd
    Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
    Bus 001 Device 002: ID 0424:9512 Standard Microsystems Corp. LAN9500 Ethernet 10/100 Adapter / SMSC9512/9514 Hub
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    [email protected]:/home/pi#

    [email protected]:/home/pi# dmesg |grep usb
    [ 0.259869] usbcore: registered new interface driver usbfs
    [ 0.260039] usbcore: registered new interface driver hub
    [ 0.260290] usbcore: registered new device driver usb
    [ 0.471668] usbcore: registered new interface driver smsc95xx
    [ 0.951394] dwc_otg 20980000.usb: DWC OTG Controller
    [ 0.954093] dwc_otg 20980000.usb: new USB bus registered, assigned bus number 1
    [ 0.956881] dwc_otg 20980000.usb: irq 56, io mem 0x00000000
    [ 0.965032] usb usb1: New USB device found, idVendor=1d6b, idProduct=0002
    [ 0.967655] usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
    [ 0.970267] usb usb1: Product: DWC OTG Controller
    [ 0.972894] usb usb1: Manufacturer: Linux 4.9.39+ dwc_otg_hcd
    [ 0.975487] usb usb1: SerialNumber: 20980000.usb
    [ 0.985772] usbcore: registered new interface driver usb-storage
    [ 1.017830] usbcore: registered new interface driver usbhid
    [ 1.020607] usbhid: USB HID core driver
    [ 2.251272] usb 1-1: new high-speed USB device number 2 using dwc_otg
    [ 2.492122] usb 1-1: New USB device found, idVendor=0424, idProduct=9512
    [ 2.502274] usb 1-1: New USB device strings: Mfr=0, Product=0, SerialNumber=0
    [ 2.851285] usb 1-1.1: new high-speed USB device number 3 using dwc_otg
    [ 2.992296] usb 1-1.1: New USB device found, idVendor=0424, idProduct=ec00
    [ 3.002570] usb 1-1.1: New USB device strings: Mfr=0, Product=0, SerialNumber=0
    [ 3.151905] smsc95xx 1-1.1:1.0 eth0: register ’smsc95xx‘ at usb-20980000.usb-1.1, smsc95xx USB 2.0 Ethernet, b8:27:eb:fd:38:bb
    [ 3.281389] usb 1-1.2: new high-speed USB device number 4 using dwc_otg
    [ 3.422613] usb 1-1.2: New USB device found, idVendor=7392, idProduct=a812
    [ 3.432736] usb 1-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
    [ 3.443092] usb 1-1.2: Product: Edimax AC600 USB
    [ 3.450758] usb 1-1.2: Manufacturer: Realtek
    [ 3.457974] usb 1-1.2: SerialNumber: 00e04c000001

    Please help me getting wlan to work. Preferably by providing a plugin or a package file.

    7. März 2018 at 13:44 #34260

    Hi martini2,

    The issue can occur with insufficient power. If you have a power supply with less than 2.5A, please make sure no other periphery is connected (the other USB devices suck power as well) and try using one with 2.5A if possible.

    Also to make sure the RPi3 WiFi setting is not impeding on your B+’s recognition, please make a tick at the disable build-in WiFi option in the Raspberry Settings.

    I tested the stick and it was immediately recognized here.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.

Register here