Digitus USB WLAN Adapter Problem

This topic contains 18 replies, has 3 voices, and was last updated by  albundi premium 6 months, 2 weeks ago.

Viewing 19 posts - 1 through 19 (of 19 total)
  • 3. Februar 2021 at 21:55 #50729

    Moin,

    ich habe meinen Audimax WLAN Adapter, nur 2.4 GHz, mit dem Digitus 2.4/5 GHz Adapter ablösen wollen.
    Der neue Adapter wird nicht erkannt.
    Im WLAN Menue von M2P 2.53 kann man einen Treiber (TP-LINK oder so) nachladen, aber auch das hilft nicht.
    Eine SSH liefert:
    lsusb : einen Realtek RT8811AU, der Device Code ist noch nicht definiert.
    apt-cache search rtl88 liefert frimware-realtek,
    sudo apt-get install firmware-realtek installiert,
    lsmod zeigt aber kein Device und das WLAN geht auch nicht.

    Hat Jemand eine Idee?

    Danke Winnie.

    3. Februar 2021 at 22:18 #50730

    Moin,

    auf einer beigelegten CD ist ein rtl8821 Linux Treiber im GZ Format. Aber wie kann ich den an den RPi bringen?

    Danke Winnie.

    4. Februar 2021 at 14:20 #50732

    Hallo Winnie,

    aktuell unterstützen wir noch keine WLAN-Treiber, die nicht bereits im Raspbian OS enthalten sind. Wir arbeiten aber zur Zeit an einer Lösung dafür. Bis dahin, versuche den Stick bitte wie folgt zu installieren:

    1. Stick und LAN Kabel an Pi anschließen, Hochfahren
    2. Kernel Update unten auf Seite „Raspberry Einstellungen“ durchführen
    3. Wenn keine Fehlermeldung kommt, Reboot
    4. Remote Control Plugin installieren
    5. Im Remote Control Plugin „ShellInABox“ installieren
    6. „Open Console Fullscreen“ klicken
    7. Login: pi; Passwort: max2play
    8. Folgende Befehle in dieser Reihenfolge ausführen:
    — 1. sudo wget http://downloads.fars-robotics.net/wifi-drivers/install-wifi -O /usr/bin/install-wifi
    — 2. sudo chmod +x /usr/bin/install-wifi
    — 3. sudo install-wifi -u rpi-update (bei unserem neuen Image diese Zeile durch sudo /usr/bin/install-wifi ersetzen)
    — 4. sudo reboot
    9. Nach dem Reboot das integrierte WLAN in den Raspberry Einstellungen deaktivieren (dann erneut Reboot)
    10. WLAN einrichten und WLAN Interface aktivieren
    11. Oben bei WLAN sollte zweimal „aktiv“ stehen sowie eine IP Adresse
    12. Pi herunterfahren, LAN-Kabel abziehen und neustarten
    13. Pi sollte sich per WLAN mit Router verbinden

    4. Februar 2021 at 17:19 #50740

    Moin Mario,

    danke für die schnelle Hilfe. Jetzt geht es. Klasse.

    Liebe Grüße Winnie.

    26. Februar 2021 at 14:36 #50839

    Hallo,
    zuerst vielen Dank für den Workaround!
    Hoffe ich darf mich an den Tread anhängen,
    Bei mir wird folgendes angezeigt:

    Status: WLAN Adapter status ist aktiv. WLAN Verbindungsstatus ist aktiv (IP: KEINE IP! Keine Verbindung!)
    (Nur WPA/WPA2-Verschlüsselung möglich)

    Die Befehle wurden ohne Fehlermeldung ausgeführt.
    Würde mich über eure Hilfe freuen!
    Beste Grüße
    Thomas

    26. Februar 2021 at 15:38 #50840

    Moin Thomas,
    kurze ganz dumme Frage:
    Hast du dich u.U. bei der Anmeldung (Password) vertippt?
    Einfach noch mal probieren.
    Melde dich dann ruhig nochmal. Also so lange bis es geht!
    Liebe Grüße Winnie.

    26. Februar 2021 at 20:25 #50841

    Hi Winnie,
    vielen Dank für die schnelle Rückmeldung, habe das Passwort noch einmal eingegeben, leider ohne Erfolg.
    Das ist zum Mäuse melken, versuche den USB WLAN Stick jetzt seit acht Tagen zum laufen zu bringen.
    Aufgrund des Einbau in ein Metallgehäuse, hat die WLAN Reichweite des Raspi enorm Mein PI DACabgenommen.
    Weis nicht mehr weiter, habe schon dreimal das Image neu aufgespielt.

    Schönen Abend
    Thomas

    26. Februar 2021 at 20:46 #50842

    Moin Thoma,

    schickes Teil. Ich habe auch Metallbüchsen, deshalb….

    Darf ich dir was empfeheln? Hoffe ja.

    Mach doch mal eine neue SD Karte mit einem M2P fertig, dort den USB Stick nach dem Booten reinstecken,
    das WLAN0 ausschalten, und erst nach einem Reboot jetzt erst
    das script starten, also jetzt erst den Treiber installieren.
    Schaut man auf die vergebenen IPs, setzt dies auf immer gleich zuweisen, dann sieht man ein neues WLAN Interface.
    Probiere doch mal.
    Ist eine Stunde, ich vermute das Script hat einige Voraussetzungen, Beispiel der Stick mit dem Chipsatz XYZ ist verhanden, und macht dann erst alles richtig.
    Nur so eine Idee.
    Liebe Grüße Winnie.

    27. Februar 2021 at 0:15 #50843

    Hi Winnie,

    Danke für die Blumen 😉
    Das probiere ich gleich morgen, hört sich gut an!
    Melde mich dann.

    Wünsche dir einen schönen Abend
    Thomas

    27. Februar 2021 at 12:10 #50844

    Danke! Danke! Danke!
    Super, es funktioniert!
    Endlich einen Schritt weiter!
    Da wäre ich nie darauf gekommen, den Wlan Stick vor dem Einrichten der Soundkarte zu laden.
    Jetzt möchte ich nicht unverschämt klingen, aber wie auf meinem Bild zu sehen ist auf der rechten Seite ein TSOP 4838 verbaut den ich gerne mit einer Justboom Fernbedienung bedienen würde.
    Leider gelinkt mir das nicht, wenn ich das Hardware Plugin installiere und die Gpio setzte, Starten nur vier Zeilen und durch druck auf die Fernbedienung läuft das Script zu einem gewissen Punkt, aber starten tut M2P nicht.
    Kannst Du mir hierbei auch helfen?

    Beste Grüße
    Thomas

    27. Februar 2021 at 12:39 #50845

    Moin Thomas,

    freut mich, das es geklappt hat. Scripte sind oft leider nicht ganz wasserdicht hinzukriegen. Man kann einfach nicht alle Fälle richtig handlen. Da ist dann der Ansatz zu verändern, das hast du erfolgreich gemacht.

    Ich habe bei mir drei Remotes im Einsatz:
    1. Das Handteil der Squeezebox Duett, für Titelwahl und Lautstärke und
    2. Eine Remote von HiFiBerry, damit geht nur Volume und
    3. Eine Andriod App Squeezer, zur Titelwahl.

    Wie du siehst, ist das alles nicht gold was glänzt. Egal, ich kann damit leben. Ich habe halt das So genommen, wie es mir angeboten wird.

    Ist bei dir aber ein anderer Ansatz.

    Um über dein Problem nachdenken zu können:
    1. Welche Hardware, und wozu. Da gehören auch Wünsche rein.
    2. Ich habe probiert, mit den folgenden Ergebnissen, mir fehlt jetzt noch.
    3. Versucht habe ich auch das folgende und
    4. Es gäbe da noch folgende Lösungen…

    Manchmal fndet man selbst die Lösung, wenn man sich das runterspricht. Das Forum hilft dac sicher. Evtl. gibt es ja auch andere Wege.

    Weiter so! Liebe Grüße Winnie.

    27. Februar 2021 at 13:18 #50846

    Hallo Winnie,
    Innenleben
    Meine Konfig. ist Raspi 4, Hifiberry DAC2 HD, Festplatte, Ziel ist für mich das ich in Jivelite die Musik von Festplatte per Fernbedienung steuern kann. Z.B. laut/leise, nächster Titel.
    Probiert habe ich in dem Hardwersteuerung Plugin die IR Controll einzurichten. Den IR Sensor habe ich auf dem Board des Hifiberry(durchgeschleifte GPIO) angeschlossen. Leider startet M2P dann nicht mehr. Wie schon geschrieben tauchen vier Zeilen auf dem Display auf und durch druck auf die Fernbedienung kommen mehr Zeilen, aber starten tut es nicht.
    Boah bin ich ein Noob, kann es leider nicht besser erklären.;-))

    Beste Grüße
    Thomas

    28. Februar 2021 at 2:07 #50847

    Moin Thomas,

    hat leider etwas gedauert. Ich lege mal los.

    1. Es gibt Soundkarten, die mögen nicht alles auf der GPIO Leiste. Ich weis nicht wie deine da ist.
    2. In M2P muss man da auch noch was machen, einen Haken oder zwei.

    Berichte mal, was über die GPIO Pins und deiner Soundkarte gesagt wird.

    Ich würde mal die Soundkarte rausnehmen, in M2P die Einstellungen machen und schauen, was passiert.
    Sollte sich das Fehlerbild ändern, so könnte ein Wechsel nötig sein.

    Ach so, noch einen wichtigen Tip: M2P setzt öfters mal seine „defaults“ ein, wenn man in den Einstellungen fummelt. Da muss man immer auf alles achten, wenn man probiert. Mag bei einer schnellen Einrichtung sinnig sein, aber wenn man alles ableuchtet, knn das ein Stolperstein sein.

    Es ist genau wie bei mir, immer passt was nicht so recht zusammen. Derzeit habe ich DREI verschiedene Betriebssystem am Start: Max2Play, HiFiBerry und piCoreOS. In einem geht Bluetooth besserr ud das WLAN extern, im anderen ist der LMS besser oder der neue DAC2 HD mit dem DSP am Laufen. Genau wie ich es NIE wollte. Aber das ist meine Baustelle.

    Hoffe du kommst weiter. Liebe Grüße Winnie.

    28. Februar 2021 at 11:55 #50848

    Guten morgen Winnie,
    vielen dank für deine Ausführung!!
    Ich zerlege heute mal mein System und starte ohne Hifiberry Soundkarte.
    Bin mal gespannt!!
    Melde mich wieder!

    Schönen Sonntag
    Thomas

    28. Februar 2021 at 12:46 #50849

    Hallo Winnie,

    ohne Soundkarte fährt das System hoch, Wlan-Stick funktioniert(nochmals vielen Dank), IR Diode TSOP 4838 ist angeschlossen,
    Lirc ist in den Raspi Einstellungen mit dem GPIO 18 aktiviert, aber in dem Plugin Hardwarecontrol wird folgendes angezeigt:

    Currently installed IR-Mode: jivelite
    IR Software NOT Running!

    Bin schon froh das das System beim Hochfahren nicht hängt, aber IR funktioniert leider nicht.
    Beste Grüße
    Thomas

    28. Februar 2021 at 15:06 #50850

    Moin Thomas,

    immerhin fährt das System jetzt hoch! Es ist also nicht egal ob mit oder ohne Soundkarte!

    Meint, da ist auch noch nachzuschauen. Wenn dieses Interface mit deiner Soundkarte laufen soll, dann kann ja immer noch ein Dreher passiert sein. Alles ist offen.

    Was ist denn bei der jevel Oberfláche bzgl. IR zu lesen?

    U.U. wird das (dein) IR-Interface nicht, oder nicht richtig, unterstützt. Hier mess man lesen, da kann ich nichts zu sagen.

    Bald bekommen wir Haue, das hat nichts mehr mit WLAN usw. zu tun.

    Viel Erfolg wünscht Winnie.

    28. Februar 2021 at 15:40 #50851

    Hi Winnie,
    oh, möchte niemand den Tread stehlen.;-))
    Wenn diese Art der Kommunikation hier nicht erwünscht ist, bitte ich um Entschuldigung und stelle sie ein.
    Aber Zuhause mit langem Geseicht rumlaufen weil das Hobby nicht funktioniert ist denke ich schlimmer.
    Sorry aber der Satz „Was ist denn bei der jevel Oberfláche bzgl. IR zu lesen?“ verstehe ich nicht.
    Wo kann ich in Jivelite die IR auslesen?

    Beste Grüße
    Thomas

    28. Februar 2021 at 17:11 #50852

    Moin Thomas,

    nicht gleich Leberwurst machen. Es gibt immer noch andere Wege. Mein Name ist winfried altmann und ich bin bei
    gmx.de

    Mein Vorname ist drch einen . vom Namen getrennt.

    Alles klar?

    Wo du jetzt mal Lesestunde machen musst, ist was will jevel wie haben, oder wie wird es gebraucht
    Ebenso ist noch unklar, warum es mit oder ohne Soundkarte anders ist.

    LG Winnie.

    28. Februar 2021 at 18:01 #50853

    Hi Winnie,

    aus dem Leberwurst Alter bin ich raus. ;-))
    Bin ja froh das Du mir hilfst!
    Ich werde mich bei Jivelight mal richtig einlesen, und dann schaun wir mal.
    Alles weiter gerne per mail.

    Schönen Sonntag
    Thomas

Viewing 19 posts - 1 through 19 (of 19 total)

You must be logged in to reply to this topic.

Register here