Desktop shortcut is not working.

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Desktop shortcut is not working.

This topic contains 3 replies, has 3 voices, and was last updated by  RadioKlempner premium 1 year, 4 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • 5. Juni 2018 at 13:22 #36086

    hello,
    i have made couple of shortcuts, „[Desktop Entry]“, to my scripts in /home/pi.
    if i run them from a pi terminal, scripts run fine and do their job.
    but when i click on the desktop shortcut, i see it being selected but
    it does not run.

    here’s the desktop shorcut:
    [Desktop Entry]
    Name=Mount myVault
    Icon=/home/pi/m2p_desktop.jpg
    Exec=lxterminal -t „Mounting myVault“ –working-directory=/home/pi/ -e ./mount-vault.sh
    Encoding=UTF-8
    Type=Application
    Terminal=false
    Categories=None;

    anything wrong here?
    thanks for any help…

    7. Juni 2018 at 11:16 #36106

    Hi gchip,

    The Max2Play desktop is really only intended for Jivelite and Kodi and not for actual mouse or keyboard control. Your shortcut is probably not allowed to be executed as user pi. Perhaps with sudo su, it might work. But generally we would recommend using HTTP requests or the like.

    20. Mai 2019 at 10:27 #45463

    Hello!
    I experienced the same problems. I created an Desktop file to open an application, but with left click it don´t works.
    The File ist executable and works, I´m sure. Even if i create an Desktop-Link with rightclick on an application in the start menue, it is shown immediately on the desktop, but it don´t works with leftclick or enter.
    The joke is, if you rightclick on the desktop icons an choose „Open“ the it works. Something is wrong with the leftclick action. It is not a matter of double click timing, i tried it already.
    Please help! Thanks…

    20. Mai 2019 at 10:50 #45464

    Is it possible that it hangs together with the settings in /etc/xdg/openbox/rc.xml?
    I am not shure about the difference between „press“ and „click“ as action for a mousebind?

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Register here