Delay when using Wavein plugin

This topic contains 1 reply, has 2 voices, and was last updated by  Heiner Moderator 3 weeks, 4 days ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • 19. September 2018 at 23:02 #37908

    Hi,

    I’m currently using the WaveIn plugin to play incoming audio (echo dot) from a USB stick. I’ve adjusted the buffer Threshold of the wavein plugin to 20kbyte and it works pretty fine at first, however the longer the wavein plugin works, the longer the delay of the output audio gets. All the way to an 8 second delay, whereas at first it is below a second.
    Now, I’m looking for any information on how to fix or debug this issue.
    I’m using arecord | aplay to pipe the USB output with small buffer-time’s to the pcm that I then read via the wavein plugin, so I don’t think that’s the issue.

    I’m running max2play on an rpi3.

    Any help is appreciated!

    20. September 2018 at 12:38 #37941

    Hi mhooo,

    We are not very experienced with the WaveInput Plugin.

    Your best bet would be the slimdevices discussion thread on the plugin itself.
    However, you can check the Health Checker in Settings/Reboot during playback to see if the Pi’s load is affected by WaveInput and it might be a hardware issue.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.

Register here