debmatic makes m2p webpage unreachable

Max2Play Home 2016 (en) Forums Max2Play Development (Ideas, Wishes) debmatic makes m2p webpage unreachable

This topic contains 1 reply, has 2 voices, and was last updated by  flysurfer Moderator 1 year, 1 month ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • 29. September 2019 at 12:37 #47191

    Hello,
    I use m2p with fhem and zigbee2mqtt without any issues.
    To extend my home automation I added a homematic RF interface with debmatic software.
    The debmatic Web ui (using nodejs) kicks out the m2p webUI even if I change the port from debmatic I get only the apache2 default landing page anymore.
    Do you have any hints to get it work?
    Many thanks

    16. Oktober 2019 at 15:27 #47355

    Hi red,

    it seems like the nodejs installer modifies some apache config files to exclusively get the port 80. After you change the port of debmatic you might have a look at the max2play apache config file in /etc/apache2/sites_enabled/max2play.conf

    The file should look like this: https://github.com/max2play/webinterface/blob/master/CONFIG_SYSTEM/apache2/sites-enabled/max2play.conf

    When you restart apache with „/etc/init.d/apache2 restart“ it should reload the config and if all is OK, it should give you the webinterface on the default port in your browser.

    Cheers,
    Stefan

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.

Register here