Connection via wifi failed

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Connection via wifi failed

Tagged: 

This topic contains 6 replies, has 4 voices, and was last updated by  MarioM Moderator 1 month, 2 weeks ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • 6. April 2019 at 18:03 #44972

    Hello,

    I installed the actual 2.47 m2p version on a rasp pi3/ hifi berry dac+ setup. I followed the instructions but like several others I can not connect to the local wifi. As we are using a hidden SSID I entered both SSID an password into the named fields.

    I receive the followig error description:

    WLAN Adapter status ist aktiv. WLAN Verbindungsstatus ist aktiv (IP: KEINE IP! Keine Verbindung!)
    (Nur WPA/WPA2-Verschlüsselung möglich)

    How can I fix the problem?

    8. April 2019 at 13:10 #44980

    Hello Mimi,

    In this page under 3. Access you can find detailed guides on all our connection methods.

    Could you link me to the other unsolved connection issue so I can check whether this has been resolved otherwise? Thank you in advance.

    8. April 2019 at 21:33 #44991

    Hello Heiner,

    I’m not sure if I can follow your instructions. Is it possible to switch to German?

    Wie gesagt benutzen wir ein verstecktes Wlan (versteckte SSID). Deshalb habe ich, nachdem ich das Gerät per Kabel an den Router und an den Strom gebracht habe, die SSID und das Passwort von Hand eingegeben. Ergbnis ist die oben gepostete Fehlermeldung: WLAN Adapter status ist aktiv. WLAN Verbindungsstatus ist aktiv (IP: KEINE IP! Keine Verbindung!).

    Die Markierung in „WLan interface laden“ habe ich gesetzt. Müsste mein WLan nach Angabe von Passwort und SSID und anschließendem Scan in der Liste der verfügbaren Netzwerke auftauchen?

    Ich habe gerade auch die Access Point Variante ausprobiert. Das WLan wird aufgebaut, wie beschrieben und ich kann die m2p Seite aufrufen. Kann ich über diesen Weg überhaupt mein Netzwerk finden, wenn dies versteckt ist? In der Scanliste taucht es nicht auf. Sollte es am versteckten Netzwerk liegen, bitte melden. Dann muss mein Mitbewohner dieses eben vorübergehend sichtbar machen.

    Fehlermeldung an dieser Stelle:
    Setup WiFi Started

    2019-04-08 21:10:04|
    Disable Accesspoint
    Killed old client process
    Internet Systems Consortium DHCP Client 4.3.5
    Copyright 2004-2016 Internet Systems Consortium.
    All rights reserved.
    For info, please visit https://www.isc.org/software/dhcp/

    Listening on LPF/wlan0/b8:27:eb:c1:47:a6
    Sending on LPF/wlan0/b8:27:eb:c1:47:a6
    Sending on Socket/fallback
    1
    OK
    OK
    OK
    OK
    OK
    OK
    No IP-Address could be received – WiFi NOT working correctly. Please check Network-ID and Passphrase!
    ifdown: waiting for lock on /run/network/ifstate.wlan0
    ifdown: ignoring unknown interface wlan0=wlan0
    OK
    OK
    WiFi detected
    Restarting hostapd (via systemctl): hostapd.service.
    Restarting dnsmasq (via systemctl): dnsmasq.service.

    9. April 2019 at 14:37 #44996

    Hallo Mimi,

    Die verlinkten Anleitungen gibt es alle auch auf Deutsch.
    Nutzt dein Netzwerk eine WPA2-Verschlüsselung? Prüfe außerdem ob dein WLAN Channel 12 oder 13 nutzt, diese bringen manchmal Probleme mit Raspberry Pis.

    10. April 2019 at 20:28 #45014

    Hallo Heiner,

    wir haben eine aktive WPA2 Verschlüsselung. Wir schauen einmal, dass wir das Netz vorübergehend öffnen und prüfen auch die benutzten Kanäle.

    Danke dir

    26. August 2020 at 22:26 #49575

    Moin Heiner,

    gibt es irgendwelche Infos darüber wieso der Raspberry Pi 3 probleme hat sich mit den Kanälen 12 und 13 zu verbinden? Ich hab das gerade mit einer ganz neuen frischen max2play Version versucht und wenn mein WLAN auf einen der beiden Kanäle ist geht es einfach nicht, er findet das WLAN nicht. Wenn ich dann den Kanal wechsle und den Pi verbinde kann ich auch auf den Kanal 12 oder 13 gehen. Bei einem Neustart verbindet er sich dann aber wieder nicht mit dem WiFi…. Das nervt so ungemein….

    Edit:
    Ich habe nun durch sudo raspi-config den wifi Ländercode auf DE gestellt. Danach geht es zwar immer noch nicht aber es ist zum Teil besser geworde. Wenn der Raspi nun neustartet verbindet er sich zwar immer noch nicht mit dem WLAN aber ich kann es auf der Web Oberfläche von Max2Play sofort finden, ich muss also eigentlich nur die vorherigen Einstellungen wieder speichern, er startet WiFi von neuen und kann sich sofort verbinden. Auch aufgefallen ist mir, das er beim booten bei dem Punkt starting hostname service hängenbleibt und dann einfach ohne weiteres in den Desktop übergeht wenn das WLAN auf Kanal 12 o. 13 eingestellt ist. Wenn das WLAN auf einen anderen Kanal steht durchläuft er diesen Punkt ganz normal und startet auch noch weitere Services.

    Grüße Jonas

    • This reply was modified 1 month, 3 weeks ago by  daemmi.
    2. September 2020 at 11:39 #49594

    Hallo Jonas,

    die Kanäle 12 und 13 scheinen von Hause aus beim Raspberry Pi deaktiviert zu sein. Ich gebe das an unseren Entwickler weiter, eventuell kann er das Image in der Beta entsprechend anpassen.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.

Register here