[SOLVED] Connect to raspi/squeezeserver from smartphone via wifi without a router

Max2Play Home 2016 (en) Forums Max2Play as Squeezebox (Player / Server) [SOLVED] Connect to raspi/squeezeserver from smartphone via wifi without a router

This topic contains 4 replies, has 2 voices, and was last updated by  TaW premium 2 months, 1 week ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • 6. Juli 2018 at 15:27 #36473

    Title basically says it all:

    I want to connect to the squeezserver via wifi without having access to my internet router.

    Carrying the raspi and a usb drive along with some power source is simple.

    The idea is to have full access to my music using e.g. squeezer on my phone even when I’m away from home.

    Can I configure max2play to serve as a wifi source, if that’s what I need?

    tia, Thomas

    10. Juli 2018 at 16:51 #36516

    Hi Thomas,

    Yes, you can use our Access Point Setup Plugin. After installing the LMS (internet required), you can set up the Pi as an active access point that you can connect to on the go from your smartphone. Here’s an Instructable we made on the topic.

    13. Juli 2018 at 14:35 #36570

    Thanks. The link says that I need a WiFi Stick to make it work. The page is 3 years old. Is that still so or can I use the LAN cable (preferred) or raspi’s Wifi port as well?

    • This reply was modified 2 months, 1 week ago by  TaW.
    13. Juli 2018 at 16:32 #36580

    If you have a 3B or 3B+ (built-in WiFi), you do not need a WiFi stick. The other Pi’s need a dongle for WiFi.

    13. Juli 2018 at 17:29 #36582

    Thanks again. It seems to be installed and I can see it from my Smartphone (Moto 5G) with the SSID I had entered. But when I try to connect with Squeezer the connection is being established but after 2-3 seconds it goes into a re-connect cycle..

    Edit: I have now changed the accesspoint settings to
    – WiFi Driver nl80211
    – Mode Standalone

    Now I can establish a stable connection (with a warning about the (obviously) missing internet connection.

    Unfortunately now squeezer can’t connect..

    EDIT:

    I think I got it to work now, that is the access point can be seen and logged onto from squeezer.

    I set the access point to ‚Standalone‘ and disconnected the LAN cable.
    Squeezer is set up to expect DHCP and no proxy.

    The connection is not very stable though and I need to reconnect after every few minutes.

    • This reply was modified 2 months, 1 week ago by  TaW.
    • This reply was modified 2 months, 1 week ago by  TaW.
    • This reply was modified 2 months ago by  TaW.
    • This reply was modified 2 months ago by  TaW.
    • This reply was modified 2 months ago by  TaW.
Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.

Register here