Compatibility with Raspberry PI 3

This topic contains 13 replies, has 5 voices, and was last updated by  lneill_max2play premium 8 months, 2 weeks ago.

Viewing 14 posts - 1 through 14 (of 14 total)
  • 29. February 2016 at 22:28 #18877

    Can you please advise if OR when the current max2play software will be compatible with the new Raspberry PI 3 so that it is optimized for the faster architecture. I use PI as a server for Squeeze. When I ran this on my QNAP hardware it would transcode high bitrate FLACs to play on standard 16bit 44.1KHz hardware such as my Boombox. Currently with the PI 2 it doesn’t transcode anything above 44.1KHz sample frequencies. I am hoping that the new hardware will have the grunt to do that again.

    1. March 2016 at 17:11 #18945

    Hi lneill,
    We have a new BETA image for the Raspberry Pi 3 out on our download page: https://www.max2play.com/en/max2play-image/

    The coming version version 2.28 of Max2Play will also natively support the Raspberry Pi 3.

    However, we cannot guarantee that the transcoding issues will be solved by this new setup.

    • This reply was modified 9 months, 1 week ago by  Heiner.
    3. March 2016 at 12:40 #19048

    Hi lneill,

    how are your RPi 3 and QNAP connected with each other? For HDMI audio output, there is an 192 KHz option in “Raspberry Settings”.

    Maximilian from Max2Play

    3. March 2016 at 21:46 #19104

    Hi Maximilian,

    The PI isn’t connected to the QNAP. I was just explaining that the QNAP was able to trans-code Hi Resolution FLAC files (192Khz) down to standard 44.1Khz FLAC on the fly. This is needed if you have Hi Res FLAC’s + the original LMS Hardware Boombox, Squeezebox ect. (This software appears to have been dumped by QNAP i believe due to security concerns and because it is old.) This was most probably because the QNAP has plenty of power to handle this process and it appears to be coded into the LMS software. However with my max2play RP2 it looks like it is doing it (i.e. the sang name and play time comes up) but nothing comes out of the device as sound. So I was wondering if this would now work given the higher power offered with the RP3. This is a slightly mute point I will find out soon enough. My RP3 is on it’s way to me and the BETA Max2play software is available so I will let the forum know if there is yet another reason to love the PI and max2play!!

    5. March 2016 at 17:13 #19128

    Hi
    max2play installs – I used the script on a latest Raspbian ( Rpi 3 Require that) but some components have problems
    Tried 2 so far
    I tried to install both JivelIte and Kodi( Just curious not fan of Kodi)
    Jive installs but cannot start – see another post about this and for Kodi I just tried 5 min ago
    Start Kodi – unsuccessful with no details visible.
    SO I Tried to install it – Unsuccessful too
    Installationspaket: http://cdn.max2play.com/kodi-15.1-wheezy.tar.gz
    Installation startet – This Messages refreshes every 3 seconds to show current status of installation. If finished this message disappears.
    By not providing “Findkodi.cmake” in CMAKE_MODULE_PATH this project has
    asked CMake to find a package configuration file provided by “kodi”, but
    CMake did not find one.

    Could not find a package configuration file provided by “kodi” with any of
    the following names:

    kodiConfig.cmake
    kodi-config.cmake

    Add the installation prefix of “kodi” to CMAKE_PREFIX_PATH or set
    “kodi_DIR” to a directory containing one of the above files. If “kodi”
    provides a separate development package or SDK, be sure it has been
    installed.

    — Configuring incomplete, errors occurred!
    See also “/opt/kodi-platform/CMakeFiles/CMakeOutput.log”.
    sed: can’t read /opt/kodi-platform/CMakeFiles/kodiplatform.dir/link.txt: No such file or directory
    make: *** No targets specified and no makefile found. Stop.
    Reset Compiler to first version
    There is only one alternative in link group gcc (providing /usr/bin/gcc): /usr/bin/gcc-4.7
    Nothing to configure.
    Click here to reload Page
    finished

    Installation abgeschlossen!

    I can post the CMakeOutput log if anybody wants it

    5. March 2016 at 17:41 #19129

    Just Tried the Rpi Camera ( never tried before)
    I have an “official” Pi NoIR camera
    Plugged it in
    Added the extension on Max2Play
    Installed the Rpi Camera
    Except that /etc/pache2/conf.d error ( file does not exist) no other errors
    Installation Successful
    I had a look
    Actually the folder conf.d does NOt exist
    here the content on
    cd /etc/apache2/
    [email protected]:/etc/apache2 $ ls -l
    total 80
    -rw-r–r– 1 root root 7116 Mar 4 22:10 apache2.conf
    drwxr-xr-x 2 root root 4096 Mar 4 22:08 conf-available
    drwxr-xr-x 2 root root 4096 Mar 4 22:08 conf-enabled
    -rw-r–r– 1 root root 1782 Oct 24 04:37 envvars
    -rw-r–r– 1 root root 31063 Oct 24 04:37 magic
    drwxr-xr-x 2 root root 12288 Mar 4 22:09 mods-available
    drwxr-xr-x 2 root root 4096 Mar 4 22:10 mods-enabled
    -rw-r–r– 1 root root 330 Mar 5 10:24 ports.conf
    drwxr-xr-x 2 root root 4096 Mar 4 22:08 sites-available
    drwxr-xr-x 2 root root 4096 Mar 5 10:24 sites-enabled

    Rpi Camera cannot start
    —–
    RPi-Camera Addon Installer

    Trying to launch … NOT successful Click here to show detailed information
    This account is currently not available.
    This account is currently not available.
    —-

    5. March 2016 at 17:56 #19130

    Downloading Beta image
    Let you know how it works

    5. March 2016 at 19:33 #19131

    Max2Play beta image loaded
    Installed lightdm since I need the pi to open in GUI
    Tried JiveLite – it works
    However I’m having a problem with how it work s- probably nothing to do with beta or RPi3
    If Desktop Boot option auto log in as pi is selected in raspi-config and auto start JiveLite ion Max2play Jivelite settings
    neither desktop or JiveLite shows on the screen
    Jivelite is running – I checked but no Desktop on main
    However switching desktops it does show – 2 of them!
    Closed one of them ( taskbar visible) then switched back and forth between deskptops
    quit Jivelite – none running
    Tried to restart from web interface from another computer
    Trying to launch … NOT successful Click here to show detailed information
    JiveLite 0.1.0
    Invalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 key20160305 17:18:56.121 INFO jivelite – JiveMain.lua:267 JiveLite version 0.1.0
    20160305 17:18:56.131 ERROR jivelite.ui.draw – jiveL_initSDL:204 SDL_Init(V|T|A): Unable to open a console terminal
    

    – Removed in raspi-config autostart as pi in Desktop
    left autostart on Jivelite and reboot
    JiveLite starts and display on current desktop
    Quit from Jivelite menu button still not working
    Quit from taskbar x works leaving the desktop up but
    Quitting ( Stop JiveLite) form web gui quits the desktop
    I cannot win!!! ­čÖü
    What i need is JiveLiet on the screen with NO taskbar, quitable from his own Quit button or sending a command to another program, bringing that program in foreground and show back up when the ‘other ‘ program is done
    Example
    I have camera with Motion detector or Door bell Ring event( some event detected by a background program) which triggers the Video image to show on the screen.
    I really lie JiveLite/LMS combo an don’t feel like looking for alternative
    Can it been done? – maybe I s’d post all this part in a separate one ­čśë

    Checking camera and kodi next

    5. March 2016 at 19:47 #19132

    Kodi – wow! very snappy
    ( I didn’t try it since a while ago on Rpi B – unusable then)
    ha! I see a Kodi start in JiveLite – cool Blocks JL until Kodi exits – similar with what i need
    Works with NO issues from Rpi 3 and from Web max2play Control
    Super

    5. March 2016 at 20:05 #19133

    Hi

    I have just upgraded from raspberry pi original to model 3, and tried out the new beta version
    I can’t get the samba shares to work at all, I managed it OK on the old version.
    I can browse as far as \\max2play\
    And I can see the samba shares i created, but I cannot access them. I tried from a Windows 8.1 PC and a Windows 10 PC but no success.
    Anyone else had a success or failure with samba?

    Thanks

    5. March 2016 at 20:14 #19134

    I loaded it up the beta software this morning. Couldn’t get the Slimserver SW to work. I think it probably best to wait for the team at max2play to sort out the wrinkles and upload the ‘final’ version. They do state that Beta is just that not stable. Plus I would imagine they got their hands on the RP3 at exactly the same time as us.

    5. March 2016 at 20:21 #19135

    Enabled and installed Rpi camera
    Similar errors as I mentioned above using latest Raspbian download and max2play install script

    Setting up zip (3.0-8) …
    Processing triggers for libc-bin (2.19-18+deb8u3) …
    Processing triggers for systemd (215-17+deb8u3) …
    grep: ./config.txt: No such file or directory
    cp: cannot create regular file ‘/etc/apache2/conf.d/other-vhosts-access-log’: No such file or directory
    chmod: cannot access ‘/etc/apache2/conf.d/other-vhosts-access-log’: No such file or directory

    However Now camera works and I get the video streaming on port 90
    Cool!

    21. March 2016 at 20:55 #19398

    Time is passing, when will an official max2play image be available for the RP3. The Beta version has many issues. Any idea when the V1.0 will be available to download?

    24. March 2016 at 22:45 #19456

    Update: 24th March 2016

    On The Fly TRANSCODING WORKS!!!

    Latest Image downloaded from MAX2PLAY Raspberry PI3 this is the message from squeeze

    Save to Favorites
    Comment: Interpr├Ętes : Coldplay, Main Artist
    Label : Parlophone UK – Warner
    Track Number: 11/11
    File Format: FLAC
    Duration: 6:45
    Bitrate: 4960kbps VBR (Converted to 705kbps FLAC) <<<<<this is the magic BIT!!
    Sample Rate: 192.0 kHz
    Sample Size: 24Bits
    File Length: 251,550,962
    URL: tmp:///media/usb/Music_Files/C/Coldplay/Coldplay-A_Head_Full_Of_Dreams_192kHz_24bit/01-11-Coldplay-Up_Up-SMRP.flac

    So what you have then is a 192KHz version of Coldplay A Head Full Of Dreams (192kHz/24bit) (2015)
    4960kbps VBR, flc playing through a Boombox where the extra GRUNT available in P3 is transcoding the 192Kz stream to 705Kbps which the older Boombox hardware can handle – I haven’t tested it on Squeezebox but there is no reason why it wouldn’t work too

    Note: The Transcoding DOESN’T work on RP2 because there isn’t enough processing power to do it – that restriction is now lifted with the RP3

    Great News – Nice Job MAX2PLAY Team thank you
    Yet another reason to LOVE Raspberry PI

Viewing 14 posts - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.

Register here