Cirrus Audio Card does not work with image 2.44?

Max2Play Home 2016 (en) Forums General Questions on Hardware and Max2Play Versions Cirrus Audio Card does not work with image 2.44?

This topic contains 2 replies, has 2 voices, and was last updated by  Mike premium 1 month ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • 11. September 2017 at 13:08 #31257

    I installed the current image 2.44 on my SD card and it boots up fine, but I cannot get the Cirrus Audio card working any more.
    It had worked before with the Jessie kernel from an older image (2.3x).
    What I just tried:
    – install older image 2.26 from archive (Wheezy): Cirrus works.
    – update max2play via web interface to version 2.44: Cirrus still works.

    I hope, anybody can give me some hints on how to get this solved.

    Thanks!
    Mike

    Update:
    I just tried the image for Iqaudio 2.34 with Jessie kernel and changed settings to Cirrus Audio: Works!
    So I guess that there is something wrong with the 2.44 image. Hope you guys can fix it!

    11. September 2017 at 17:11 #31271

    Hi Mike,

    Thanks for the heads-up, we will look into it.

    12. September 2017 at 8:20 #31283

    Thanks, Heiner!
    Here’s some more info from the debug messages:

    # Enable audio (loads snd_bcm2835)
    dtparam=audio=on
    gpu_mem=128
    dtoverlay=rpi-cirrus-wm5102-overlay`

    When I try to set “Lineout”, I get:

    amixer: Control hw:sndrpiwsp open error: No such device

    I don’t know enough about Linux to debug it further.
    Mike

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.

Register here