[SOLVED] Change the volume on USB out on RPi running on Max2Play and LMS

Max2Play Home 2016 (en) Forums Max2Play as Squeezebox (Player / Server) [SOLVED] Change the volume on USB out on RPi running on Max2Play and LMS

This topic contains 3 replies, has 3 voices, and was last updated by  Nickelig 10 months, 4 weeks ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • 17. Dezember 2017 at 15:49 #32996

    Hi,
    It took me a long search to change the volume on the USB output towards my DAC. The default value was very low in volume compared to the other sources of my DAC. To help others in this change, here is what I’m running and how it was changed.
    This is a non expert description, enough experts around here to comment and tweak.

    System:
    Max2Play; Squeezebox Server; Squeezelight Audioplayer; external DAC on USB

    Settings in the M2P web access:
    – under Raspberry Settings – detected Raspberry PI 2 – select soundcard [USB Soundcards (Northstar Essentio, Hiface and others) – Disable Build in Audio – [Save]
    – under Audioplayer – Mediaplayer Squeezelite & Airplay – Edit Advanced Options [find a working one]

    The working one might have a low volume, turn the external volume up to have some sound.

    Get the complete system running. In my setup every usb output of the RPi starts sending output to the DAC. When you discover a low volume output next receipt might help.
    >> no guaranties
    >> put the external volume low 😉

    Start a terminal that is connected to the Rpi at the network adress:

    name: pi password: raspberry

    Search for the number from your card by giving a aplay command
    $ aplay -l („l“ is a small L)

    for mine it was 1 (one) as it is in the next commandline
    $ amixer -c 1 set PCM 100%

    And finally the volume was on 100%

    ??? Is this a one time change that stays after a fresh startup???
    It seams that a command like 100% may be also given like 0dB.

    When you want to start experiencing with up-sampling you need a lower volume to prevent clipping of the signal at steep sound increases. Reduce the volume then to 95% or -3dB.

    To the M2P people: great product.
    Would be nice to have some basic volume setting in the audioplayer setup, I did not find it in version 2.44

    Nice to have an answer if the volume command is now in the defaults or how that can be done.

    Edwin

    19. Dezember 2017 at 12:46 #33043

    Hi Edwin,

    Thanks for the detailed report. I am sure, a lot of users might benefit from your experience. On your question, check out Squeezelite’s command line options for custom parameters you can save for after each reboot: https://www.max2play.com/en/wiki/command-line-options-for-squeezelite/

    We have focused our attention on HAT sound cards for the RPi and thus have not put as much work into the implementation of USB DAC’s. For them we added the default USB sound card driver by RPi in our Raspberry Settings. Currently, only sound card plugins offer web interface volume sliders.

    11. Juni 2020 at 0:11 #48986

    Hi

    Is there any solution to have following command on startup?:

    amixer -c 1 set PCM 100% (with 1 being my usb dac / headphone amp)

    Currently I have to log in to the RPi after every darn restart and set it manually.

    I understand USB DACs are no priority but in the last years those things have become so much better and I even use my max2play as a headphone amp now.

    But with the default being 50% and not 100%, the USB does not get enough power to drive my Sennheiser HD 650 to acceptables volumes.

    Any help would be welcome 🙂

    • This reply was modified 11 months ago by  Nickelig.
    11. Juni 2020 at 20:23 #48989

    nvm, found a solution 😉

    • This reply was modified 10 months, 4 weeks ago by  Nickelig.
Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Register here