[SOLVED] Change Direction of Rotary Encoder

Max2Play Home 2016 (en) Forums General Questions on Hardware and Max2Play Versions [SOLVED] Change Direction of Rotary Encoder

This topic contains 2 replies, has 2 voices, and was last updated by  Lowrider614 premium 6 months, 2 weeks ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • 29. January 2017 at 20:46 #26392

    Hi,
    I’m using the rotary encoder with a JustBoom Amp HAT and a Raspberry Pi 3 Model B, set it up using Max2Play’s setup guide and it works fine including the button.
    One thing is odd though, when I turn the encoder clockwise, volume is decreasing, when turning it counterclockwise volume increases. On all other devices I have (my livingroom amp for example) it is the other way round.
    Can I change the behaviour of the encoder? I want the volume to increase when turning clockwise and when turning counterclockwise it shall decrease.

    Tim

    30. January 2017 at 11:43 #26399

    Hey Tim,
    please try to swap the Pins of the Rotary Encoder.
    This can also be done in the JustBoom Plugin by changing the command line parameter “–gpiorot=23,24” to “–gpiorot=24,23”.

    30. January 2017 at 20:51 #26437

    Hey Kolja,

    thanks for the tip! Changing the command line options did the trick. Now it works the way I want it to work.

    Tim

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.

Register here