CEC issue

Tagged: ,

This topic contains 8 replies, has 3 voices, and was last updated by  titobustillo 1 year, 1 month ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • 23. October 2015 at 20:44 #16545

    Hi. I have a Raspberry 2 and upgraded max2play and kodi from webui. With kodi 15.1, my TV remote is not recognized, but with 14 works fine.
    I have tried reinstalling old image to sd card and update again, but no luck.
    Thanks in advance.
    Edited: Tried with a fresh install of Hifiberry image and it has the same issue. In Kodi, under System settings, Peripherals option is greyed out.

    • This topic was modified 1 year, 1 month ago by  titobustillo.
    26. October 2015 at 14:18 #16551

    Hi tito,
    Please try turning of your TV completely (disconnect power supply) and reboot your Raspi and then see if the peripherals are still greyed out. This could be the issue with some TVs.

    29. October 2015 at 22:42 #16614

    I have tried it. No luck. I don’t understand why it happens.

    30. October 2015 at 17:29 #16650

    We are looking into it, it might be a problem with the Kodi version itself on M2P. If so, we will fix this in an update and inform you. In the meantime, if you are missing the CEC support, we recommend temporarily reverting back to Kodi 14.

    30. October 2015 at 17:37 #16653

    Hi titobustillo,

    seems like something in the CEC libraries changed for Kodi version 15. You may try to log in into the console (via SSH, user “pi” password “raspberry”) and run following

    sudo /opt/kodi-15/install_cec3

    This may fix the problem. If it works for you, we will add this fix to the installer.

    • This reply was modified 1 year, 1 month ago by  flysurfer.
    31. October 2015 at 17:12 #16665

    I’ll try it and I’ll report if its works. Thanks!!

    1. November 2015 at 17:51 #16672

    Tested. Your solution solves the CEC issue (sometimes seems like remote freezes for a couple of seconds). Anyway, with this version media playback stops suddenly and raspberry hangs. I will revert back to 14. Thanks for your efforts!

    2. November 2015 at 15:32 #16679

    Hi titobustillo,

    thanks for reporting back! I also tested the fix now and did not encounter any problems with playback. Maybe there is an other problem with your hardware / software? Did you play any special videos? I tested different YouTube and 1080p videos. The CEC-fix should not change anything else that breaks kodi functionality.

    • This reply was modified 1 year, 1 month ago by  flysurfer.
    3. November 2015 at 23:50 #16757

    Yes, I suppose that CEC fix is not related with media playback. But since I updated to new kodi version, movies from HDD or Pendrive (different bitrates) stops or freezes the raspberry. Same happens with online content.

    • This reply was modified 1 year, 1 month ago by  titobustillo.
Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.

Register here