car media player ( accesspoint / Kodi question)

Max2Play Home 2016 (en) Forums Max2Play Add-ons car media player ( accesspoint / Kodi question)

This topic contains 12 replies, has 2 voices, and was last updated by  alex premium 1 week, 1 day ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • 9. Juni 2018 at 13:18 #36130

    Hi, I used to have a standalone M2P in my car using the accesspoint module and Squeezer to play the tracks.
    I did an update, this was sometime ago and it never worked reliably again.Which I do understand why, I think.
    So I decided that I would like to try again using the built in Kodi M2P has.

    Bottom line is I put it in the car after setting things up, and hey it worked via my android, via the Kode app.

    So off I went in my car to the shop. I got back in the car tried to connect and there was no way it was going to connect, then the penny dropped. Had this been picking up my home wifi and somehow controlling Kodi that way.
    So I drove home, pulled up on the drive and yes, that is what was happening.
    My question is now, can this actually work as a true standalone system…
    Maybe I should buy a travel router and try and set it up with that.Any help at all would be very very much appreciated by me and I’m sure many others, cheers

    • This topic was modified 2 weeks, 1 day ago by  alex.
    11. Juni 2018 at 14:16 #36158

    Hi alex,

    You need to install the Access Point Setup plugin and activate standalone mode there.

    11. Juni 2018 at 14:48 #36159

    Hi, thanks for the swift reply.
    Really sorry, I should have mentioned that, so sorry I did do that with both pi’s and still the same, hence why I burned another image and tried again.
    I’m just stumped .
    Hope you might be able to suggest other things for me to try.

    11. Juni 2018 at 20:09 #36160

    Hi Heiner,
    I have just exchanged PSU and made a new image.
    What happens now is as soon as M2P boots up on the GUI page, I get

    „Device is started in Automatic Accesspoint Mode. For security, only WiFi configuration is possible to connect Max2Play to your local network“.
    I have just shut it down and fired it up again with another new image and now I can see it on my phones wifi page.
    Please note it did ask me to update the image, this time I didnt..And it loaded the Accesspoint
    However, it keeps trying to get the ip address and can’t so it goes back to the saved state, where then keeps trying, then back to the saved state etc etc.
    The debug on the AP is this below, which, I’m no expert, but looks ok !…

    #### DNSMASQ Installed ####
    Status: install ok installed

    #### HOSTAPD Installed ####
    Status: install ok installed

    #### WiFi Interface Installed ####
    2

    #### DNSMASQ Running ####

    #### HOSTAPD Running ####
    5 S 0 455 1 0 80 0 – 1543 – ? 00:00:00 hostapd

    please note the above is using the same pi.

    BUT
    So far I have used different PI’s
    Different power supplies
    Different SD cards
    Both driver options on the AP page.
    I have updated M2P when I have burned the image and also not updated, and burned the imaged and updated, seems the not updated option works the best. It actually loads up the accesspoint.
    So I’m now well and truely stuck. Hope someone can help…

    12. Juni 2018 at 10:15 #36163

    Hi alex,

    I am not entirely sure what you want to achieve and what your current issue is exactly. Please elaborate what you want the device to achieve in access point standalone mode, how you set it up for it and how it fails to do what it should.

    12. Juni 2018 at 14:41 #36169

    Hi Heiner

    It was your topic on this which I’m trying to emulate.
    http://www.instructables.com/id/Raspberry-Pi-Mobile-Media-Center-with-Smartphone-C/
    (How I read this is the M2P player is working without a router, a true standalone system you can take anywhere)

    But I’m having a couple of problems
    1. getting accesspoint to load up onto M2P
    2. When I have it says its obtaining an ip address and then fails, just drops out, then trys again.

    I have tried various SD cards, PSU’s, new images, and Pi’s and none seem to work properly. Even if I connect to my network via a cable, I can’t see the player in my file manager otherwise the other option would be to use a router in my car with the player, however I can access M2P using the ip address web page.

    The other thing I should mention is squeezbox server is on the images I have made but I never have loaded and run it because it says Kodi turns Kodi off. So I thought it doesnt need to be loaded.

    My home M2P works like a dream and I’m running 4 remote players with this.
    Hope this makes sense .

    A
    EDIT: I tried again this morning and now have managed to load my music via the web page using a cable connected to my router. But I still can’t see the media player on my network using windows explorer or standalone on my control/wifi panel on my android phone. I have also changed the driver for the accesspoint. I have also done a ping and that showing connected

    • This reply was modified 1 week, 4 days ago by  alex.
    • This reply was modified 1 week, 4 days ago by  alex.
    • This reply was modified 1 week, 4 days ago by  alex.
    • This reply was modified 1 week, 4 days ago by  alex.
    • This reply was modified 1 week, 4 days ago by  alex.
    • This reply was modified 1 week, 4 days ago by  alex.
    13. Juni 2018 at 16:59 #36186

    Hi alex,
    1.
    I have tried various SD cards, PSU’s, new images, and Pi’s and none seem to work properly. Even if I connect to my network via a cable, I can’t see the player in my file manager otherwise the other option would be to use a router in my car with the player, however I can access M2P using the ip address web page.
    If you connect to your network via cable, the access point cannot be established in standalone as it is connected to a network.
    What file manager do you mean? You should be connected to the AP with your phone or tablet, then you can use the web interface via browser or any other app for playback with Squeezelite, Shairport, etc.
    2.
    This might be an issue with your smartphone. See if there’s an option to connect to networks with internet connection or „stay connected“ or something like that.

    13. Juni 2018 at 20:58 #36192

    Hi Heiner,
    Sorry I did realise that I should not have my network cable connected I ment to say I tried both options connected and disconnected, yes I understand that, but thanks for pointing that out.

    With iphone and ipads, its not giving me this option this time, but it used to several updates ago. Thing is it might not be doing this because of the fault I’m experiancing. And I dont use my iphone and ipads now, I am using an MOTO G5 which is not giving me that option either. So the problem is common to both.

    However What happenes now, to clarify a bit more is when I look for the accesspoint on my Control/wifi screen, I can see it and it is shown as secure, which is great.
    I tap it to connect then it says
    1. Authenticating
    2. then goes to obtaining i/p address and stays there for a while 2-3 mins
    3. when it decides it can’t connect, it changes status from obtaining the i/p address to saved

    But I did go to my control/developer settings in my android and toggled on Enable wifi verbose logging. Now when I try and hook up to the accesspoint with my android I can see it bit more info and its saying while searching for the ip address „Network selection disabled DHCP failure“. Does this help point to a cure I wonder ?
    A

    • This reply was modified 1 week, 4 days ago by  alex.
    14. Juni 2018 at 8:29 #36195

    Update.
    I have obtained another pi3 and a 8Gb sd card so I reburned the image,fired it up and this time updated the pi.

    Sadly, Accesspoint has excactly the same problem as my last post.

    I also tried altering the wifi driver and that has’nt helped, which was just like before. And I tried to connect this to an Iphone, two ipads and two MOTO smartphones,all were the same, they could’nt connect. So very frustrating.

    15. Juni 2018 at 9:30 #36203

    Hi Heiner

    I have just had a thought.
    Since trying to set up my standalone system using accesspoint and Kodi, all I have done after burning a new image is to load and set up the accesspoint module then go to the Kodi module and set that up to find the music on my hard drive which is connected to my pi.

    Thats all…

    What I have not done is to mount the hardrive through M2P because Kodi sees the hard drive where my music files are without doing that, so I just thought there was no need to install it. But maybe I have to as it also might also install Samba ?
    And if samba is not in stalled I guess I would not see M2P on my network as a drive, which I can’t, and maybe thats why I might not be able to access this using the accesspoint too.

    And I’m not near my pi so I can’t try it, so I was hoping you might read this before I get home tonight and let me know if indeed this could be the problem, I just hope it is this that I have overlooked ?
    Thanks
    A

    15. Juni 2018 at 19:33 #36207

    Hi Heiner,
    I managed to get back home before your reply and I thought I would try to burn another image (m2p_rpi_default_241_wps_autoexpand) which I downloaded in January/Feb.

    I burned the image and started it.
    I did’nt expand the file system, nor did I update M2P nor anything else at this stage.

    I went to the settings/reboot and looked for the accesspoint on the listings. It was’nt in the list this time but has been on all the other occasions while trying to get this working.

    So I loaded and installed AP module.

    After the AP was installed it came back with quite a long script, maybe 2-3 times longer than I have been having on previous AP installations.

    So I booted it upand it worked as it should….However, after testing it several times and all was ok, I thought I would now put it in the car.
    Thats where I noticed it was’nt working again, it just would not connect with my phone like before so I took it back inside and tried again.
    Sure enough it started to work again although I disconnected the ethernet cable from the M2P and my M2P was connected to my phone via the accesspoint anyhow.
    Would you have any idea whats going on because I can’t see the link between my home network, my phone and M2P thats making this happen.But there is one, How very very odd.

    It seems that its somehow going through my home wifi, could this be in part the issue with the ip address it can’t find as its hooked into my network in some weird way ?
    hope this is clear.

    16. Juni 2018 at 10:23 #36208

    Hi, again
    Ive just been out and bought another 8gb SD card and tried that.
    The install went well but I still can’t connect to it when in accesspoint mode with my ipad, iphone and moto g5.
    Is ANYONE currently having the same problems, even if you’re not it would be good to know the image is working (and I can’t believe its not).
    Any help or input from anyone (as I don’t know what to do next) would be very much appreciated.
    Thanks A

    16. Juni 2018 at 17:46 #36212

    Solved, well kind of;;;
    Hi anyone who might have been following this…

    Make sure your Kode app is’nt running..
    Then fire up your m2p.
    In your Android go to control/wifi and find your m2p accesspoint signal and choose it.
    Another screen (m2p main page) will pop up. Locate the 2 dots top left and hit them. Choose „use network as is“
    No go back to your control/wifi screen and locate your m2p signal.
    When you have DONT tap and choose it, hold your finger on it until it comes up with 3 options.
    The one you want is Modify this network.
    Pick that, when you have, the next screen will ask you for a password, enter it here. This is the password used in your accesspoint setup.

    From there go to Kode app. fire it up. If this is a first install follow the instructions. If this is not your first install you need to locate the media server tab at the top of the kode „control“ panel. and delete whatever media player is there and when you have, you then get Kode to search for another media player. It should find the m2p player, your accesspoint and thats it.

    Thing is, I just can’t seem to boot up my m2p, then Kodi and it all works without all this messing around.
    Yes its very clunkey BUT IT WORKS!!!!, well it does for me.

    I hope if anyone else is having issues they can use this and it may help them too.
    However, please post any other way of doing it, or ideas which might help me as I’m sure its not supposed to be a clunkey as this.
    I have NOT tested it fully, I’ve just been playing about with it in the local supermarket car park. So there may be bugs that have not yet come to the surface,please note…

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.

Register here