Can't stream aac files

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Can't stream aac files

This topic contains 3 replies, has 2 voices, and was last updated by  Heiner Moderator 1 year, 6 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • 17. März 2019 at 11:12 #44784

    Hi.
    I’m running max2play on a Raspberry pi to provide a squeezebox server. This is streaming synchronized to two further RPis both running Moode in squeezelite client mode. MP3s play without problem, but whenever the the server comes across an aac-encoded file it plays silently on the two clients. I assume that this is a problem with the squeezebox server as Moode can normally play aac files without problem.

    I looked at the convert-conf file but found it somewhat baffling as it seemed to have multiple entries for conversion of aac files.
    Can anyone help?

    Thanks
    Andy

    18. März 2019 at 13:12 #44790

    Hi Andy,

    Head to the Squeezebox Server webinterface -> Settings -> Advanced -> Filetypes to see what AAC is streamed as and change it to your preferences.

    18. März 2019 at 20:33 #44799

    The Filetypes preference is set to stream AAC files as Native, which should be OK for my players. I tried disabling the Native setting and also the FLAC transcode so it should stream AAC as MP3, but still no sound.

    Also, weirdly, when Squeezebox finishes playing an AAC files it replays the same song instead of moving onto the next song in the queue. Is there something wrong with my AAC files? In another player they are classified as AAC (MP4a, CBR).

    Thanks
    Andy

    19. März 2019 at 15:35 #44801

    Hi Andy,

    Only thing I can imagine would be specific rights or restrictions on the files or folders. The LMS might have an issue parsing certain right sets.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Register here