Cant see max2play

This topic contains 13 replies, has 2 voices, and was last updated by  alex premium 4 months, 3 weeks ago.

Viewing 14 posts - 1 through 14 (of 14 total)
  • 2. May 2016 at 20:42 #20021

    Hi all
    I sorted my M2P with an accesspoint which I now use in my car/caravan late last year and now I’m wanting to replace my SqueezePlug with M2P.
    I have built it and all it works…
    At the moment I use iPeng and LMS to play my music, it is even connecting to another M2P in the kitchen.

    My problem is my windows PC I can’t see Max2play at all, but it’s there ortherwise none of the above will work.
    In my Windows file manager (computer-shortcut) I can see my squeezebox touch and a few other media devices, I can also see my telly and my router and iphone, but not M2P.

    Needless to say this creates all sorts of problems. The obvious one is that I have to take my hard-drive off the M2P and plug it into my windows PC and dump any new files on it that way, but I know this is’nt right. All I have installed is the standard package. I am sure I have missed something

    If anyone can help I’d really appreciate it

    • This topic was modified 5 months, 4 weeks ago by  alex.
    • This topic was modified 5 months, 4 weeks ago by  alex.
    4. May 2016 at 15:19 #20044

    Hi alex,
    You can create a Samba Share on your M2P device under “Filesystem/Mount”. This folder on your Pi’s SD card is then shared in your local network and accessible for all other devices. You can follow the guidelines and example parameters to configure your preferred share.

    4. May 2016 at 15:39 #20046

    Hi Heiner
    Thanks for your reply.
    Thats what I though but I tried that and it did’nt work. I also watched the youtube clip and still not sucsess.
    If this is suppose to work,its me thats a fault.And that is’nt suprising because I really don’t know how fill the boxes, or should I say what path to see the HD attached to Pi.
    I really would appreciate some help if possible Heiner. Do I also have to use a User name for Samba access and password, should’nt my router deal with this.
    Do I need this bit ?

    Thanks in advance

    4. May 2016 at 16:20 #20047

    You can use the example 1 since you probably want to write on the share as well as read:
    Name: usbshare
    Path: /media/usb
    writeable: yes
    Create Mode: 0777

    Except if you want to use a share on the SD card and not a constantly connected usb drive to be your share, you need to use another folder. You can use home/pi/downloads. Now, just click save and the share is created. If you have not yet, also create a password to enter from your windows pc, you can leave root as the user name.
    Now, if you go to your PC’s explorer, under network you should find the element \\MAX2PLAY. If you click it, it will ask for your user name and password, type those in and you can access the share, add files, delete them or copy them to your PC.

    5. May 2016 at 8:22 #20054

    Hi Heiner

    This is really very kind of you. I really appreciate it.

    Because of work commitments I’m not going to be able to try this until tomorrow, but I will and I’ll let you know what happens.
    But all this is great and I can’t wait to try it, it will make life so much easier

    Thanks again

    9. May 2016 at 11:33 #20075

    Hi Heiner

    I have been trying to get my head around this and unfortunately I still can’t see it whatever I do

    I did as you said which was to go to Samabshare and fill in the boxes as you put in your reply

    I also tried other alternative paths thinking I could find another way and sadly it’s still not working

    What I can see is the LMS under the media devices when I look under network

    But I don’t see M2P listed, which is odd because I can get to its homepage.

    I feel this is something simple, but I just can’t see it, really frustrating
    Is there anything else you might be able to suggest Heiner.
    Thanks alex

    11. May 2016 at 15:44 #20086

    Hi alex,
    Does the Max2Play web interface show you the successfully added Samba Share? Also, have you tried typing \\max2play into your Windows Explorer bar?

    12. May 2016 at 0:22 #20093

    Hi Heiner

    Yes I can see it in samba when I open the page, just as you asked me to do it
    As I mentioned before Heiner, under my network path in MY computer under network media devices, I can see “logitech server (max2play)” and “max2play”. I also can see my “Squeezebox touch” and my PC that I am working on now.

    If I enter \\max2play using firefox I get nothing


    12. May 2016 at 12:09 #20095

    Not your browser, but your Windows Explorer bar where you can see the path you are currently on in your computer’s folders. With Windows it should read something like C:\User\etc.
    Just type in the name of your Samba Share (in this case \\max2play) there.

    12. May 2016 at 20:05 #20106

    Hi Heiner

    Thanks for the reply

    I did what you asked and, still nothing

    In my router however I get this. M2P is not listed as being there although its connected by a cable ?
    Firewall issues maybe ?

    2.4 GHz Wireless: SqueezeboxTouch 00:04:20:22:c2:ca
    5 GHz Wireless: iPhone
    Ethernet: Alex-PC
    USB: No devices detected

    However if I just type max2play in my explorer browser I get another window opening called
    “choose media streaming opyions for computers and devices”

    On this page I can see max2play but it’s only a square icon along with other things I think I can recognise

    I have a BT home hub router do you think maybe this is the problem.

    23. May 2016 at 14:42 #20219

    Hi Alex,
    We have not had any experience with a BT home hub router, but it should not be a problem. Have you tried burning a fresh image? Because it seems there are several issues that usually do not come up in the Max2Play web interface.

    3. June 2016 at 10:41 #20469

    Hi Heiner
    I have burned another image and still I can’t see my files using windows explorer or windows files manager.

    Could it be anything to do with this ??

    Under filesysystem, samba shares I have
    Name: max2play-usb
    Comment: blank
    Writeable: yes
    Create mode: 0777

    I have also noticed Sambashare Accsess (do I need to set this up, if so how)
    The password is pre typed in the box as : root
    So I picked a password and entered it and saved it
    The followed the instructions but in the instructions it says right click and connect to network drive.
    I only see, Map to network drive or disconnect network drive
    However if I continue and choose Map to network drive I get a box with a drive letter, this case it’s Z and under it there’s a place I can either write the path of my drive, which I put in //MAX2PLAY/max2play-usb
    This says its not recognised.
    Also should I fix the LAN address, I have done both and it makes no differance ?
    And after all this the system works, I just can’t see my HD using windows, I really hope you can suggest a few more ideas, Thanks again Alex

    3. June 2016 at 14:06 #20490

    Hi alex,
    The “root” is the user, you should indeed enter a password, leave root as your username and click save. I just tested it again with our newest build and it worked fine. You should see “MAX2PLAY” as a network device in your Windows Explorer, right below your computer’s hard drives.

    3. June 2016 at 14:58 #20499

    Hi Heiner
    Thanks again for this
    I will get a new “untouched” memory card and give this another try over the weekend, really appreciate your help

Viewing 14 posts - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.

Register here