Cant make airplay work

This topic contains 2 replies, has 2 voices, and was last updated by  Heiner Moderator 1 year, 1 month ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • 18. August 2017 at 22:02 #30692

    I have one pi 3 with hifiberry DAC+ running the squeezebox server and squeezelite, and one pi B+ running squeezelite syncronised to the pi3. I am just using the headphones port for audio out of that one.
    Both players work fine, except for airplay.
    Both of them show up on my ios devices, and are able to be connected to. They look like they are playing but there is no audio coming out.
    Is it something to do with my soundcard setttings?
    I have made the shairport soundcard the same as the squeezelite soundcard in both instances. Is this correct?
    For the pi3 I am using sysdefault – snd_rpi_hifiberry_dacplus and for the B+ I am using hw – bcm2835 ALSA, bcm 2835 ALSA

    18. August 2017 at 22:05 #30693

    Also, I disabled the shairport within the squeezebox server, I thought that might be clashing with the max2play shairport.

    How does the squeezebox shairport actually work, are there any docs? I’m not really sure how it is used

    21. August 2017 at 13:19 #30718

    Hi ryan,

    If you use the same output for both players, you need to utilize the feature listed in shairport’s advanced options: Shairport/Squeezelite automatic Audio-Switch

    The instructions next to the feature tell you how it works and how to use it.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.

Register here