Can't get the 2.8" Touchscreen to work.

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Can't get the 2.8" Touchscreen to work.

This topic contains 10 replies, has 2 voices, and was last updated by  Phanegem 1 year, 2 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • 22. September 2015 at 19:39 #15773

    Just got a Raspberry Pi 2 Model B and the Adafruit 320X240 TFT + Resistive Touchscreen. Installed the Java lite and rebooted a lot and the screen just lights up. It will flash on a reboot that’s about it.

    Hooked up the HDMI and the boot text comes up and it stops but the web page works. I think it stops switch to the touchscreen but I get no image on it.

    Any one know what could be wrong?

    22. September 2015 at 21:55 #15775

    Just been working on this a lot. I guess the 2.8″ Touchscreen is bad. Nothing I do gets it to display.

    Just order the kit from here. So should be all set. Love to have like a squeezebox touch that cost a lot more then this and looks like they don’t make them any more.

    23. September 2015 at 0:48 #15776

    I got it to work by downloading 2015-05-05-raspbian-wheezy-pitft28r.img put it on a SD card and it booted and showed the text on the small 2.8 Touchscreen.

    But just can’t get it to work with Max2Play.

    Is there any thing that says how or a step-by-step say?

    23. September 2015 at 1:01 #15777

    The Touchscreen I have is at this link.

    Can it work with Max2play? If so how?

    23. September 2015 at 9:17 #15778

    Downloaded the image from here. https://learn.adafruit.com/adafruit-pitft-28-inch-resistive-touchscreen-display-raspberry-pi/easy-install

    There is a big green icon that says “Download PiTFT 2.4″ and 2.8″ Resistive Image for Pi 1 and Pi 2 (September 9, 2015)”

    Unzip it and I used Rufus to put it on a SD card.

    Then go to get a “install_max2play.sh” script I clicked Raw and copy and paste it. So log in with putty with user pi and password raspberry and type “nano” and enter and paste it in there. It takes a little time but the hole text will show up. I chmod it 777 so “chmod 777 install_max2play.sh” then backup a folder with “..” and typed /root/install_max2play.sh

    Go to http://max2play and it will have a update. I expanded the file system 1ST.

    Reboot and update Max2play from 1.0 to 2.21 as of today.

    Reboot it.

    Put in your e-mail and location. Then go the the plug in and install Jivelite. That takes a little time. Set it to Autostart and save. Got to start it too the 1st time.

    Then it can see it on the little screen. It lets you pick a size but all are in HD. I have not found a 320×240 yet for it. I guess there is some way to set that.

    Don’t download the “Raspberry Pi Touch Display: Easy Install & Setup of Touch Displays 2,8″ and 3.2″ I did and it will make the screen just be wight with no image again.

    Then in the Jivelite tab click “Install Choosen Skin” there is only one the “Port for 2.8″ 320×240 Adafruit LCD (QVGATouchSkin by bogdandumitru)”

    Then on the screen can see it. The top of the desktop is still there. But it works. I guess that’s the best can do with this PiTFT Touch screen.

    • This reply was modified 1 year, 2 months ago by  Raymond Day.
    • This reply was modified 1 year, 2 months ago by  Raymond Day.
    • This reply was modified 1 year, 2 months ago by  Raymond Day.
    23. September 2015 at 9:55 #15782

    One other thing can’t start Squeezelite have to “Edit Advanced Options” It’s on:

    “default – bcm2835 ALSA, bcm2835 ALSA – Default Audio Device, CARD=ALSA”

    Change it to:

    “Sysdefault – bcm2835 ALSA, bcm2835 ALSA – Default Audio Device, CARD=ALSA”

    Not sure why they look the same. But now Squeezelite will start when you pick the “Sysdefault”

    Can get full screen too! Under the “jivelite” tab click the box to “Autohide Panel (taskbar) and set Jivelite to Fullscreen:” stop and start Jivelite and now have full screen!

    • This reply was modified 1 year, 2 months ago by  Raymond Day.
    25. September 2015 at 14:32 #15824

    Seen in the /boot/config.txt this one line for the display I have.

    # --- added by adafruit-pitft-helper Wed Sep  9 21:44:12 UTC 2015 ---
    [pi1]
    device_tree=bcm2708-rpi-b-plus.dtb

    Put my other SD card in were I was trying to set up Max2Play with this display and never got it working.

    Put that line in the /boot/config.txt file and rebooted. At lest this time the display did not stay wight it turn black but nothing on it.

    So I looked up that line and came to adafruit web page.

    Just had to type in 4 commands they showed like this:

    curl -SLs https://apt.adafruit.com/add-pin | sudo bash
    apt-get install raspberrypi-bootloader
    apt-get install adafruit-pitft-helper
    adafruit-pitft-helper -t 28r

    Rebooted and now it works with this adafruit PiTFT 320×240 2.8″ Resistive touch screen. http://adafru.it/2298 that’s the display I have. I thought it was the same they 2.8 one they had here. But I was wrong.

    • This reply was modified 1 year, 2 months ago by  Raymond Day.
    30. September 2015 at 22:33 #15908

    Hi Raymond,

    I’m keep getting this error:

    /root/install_max2play.sh: Permission denied

    After i do this part:

    It takes a little time but the hole text will show up. I chmod it 777 so “chmod 777 install_max2play.sh” then backup a folder with “..” and typed /root/install_max2play.sh

    When i type chmod 777 it doesnt gice me an error so i supose that’s is going good.

    Thks

    1. October 2015 at 10:25 #15909

    Yes to run it you have to do this:

    chmod 777 install_max2play.sh
    ./install_max2play.sh

    In the install it say run it like this:

    ./install_max2play.sh 2>&1 | tee install_max2play.log

    You get a install_max2play.log file then.

    The script has a error it don’t show the “./” before the command you have to do what you did back up a folder and run it or use this ./ command. If you back up a folder it will do a little error at the end saying it can’t find the install_max2play.sh to delete it.

    All so a better way to install it just do a wget like this:

    wget https://raw.githubusercontent.com/max2play/webinterface/master/install_max2play.sh

    2. October 2015 at 8:23 #15936

    I tried it with the wget and it worked, thks

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.

Register here