Can't get MAX2Play on Raspberry Pi 0/W with HifiBerry Amp 2 to work

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Can't get MAX2Play on Raspberry Pi 0/W with HifiBerry Amp 2 to work

Tagged: 

This topic contains 9 replies, has 2 voices, and was last updated by  Heiner Moderator 11 months, 3 weeks ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • 11. Dezember 2019 at 21:00 #47754

    I have a Raspberry Pi 0/W which I have been using with Raspbian fine. I downloaded the MAX2PLAY image today put it on a 16GB SD card, activated WPS on the router (I have to do it in software as I have a Velop whole home wifi system) and booted the Pi.

    I get 2 error messages during boot
    FAILED Failed to start dhcpcd on all interfaces
    and a few lines later
    FAILED failed to start LSB:start hd-idle deamon

    The last line of the boot sequence is
    Starting Load/Save RF kill switch status

    I cannot then connect to it using http://Max2play/ or http://Max2Play.local/ or is there a network created than I can see on my laptop or phone.

    I powered off and put the original SD card in and it boots fine and I can access the network and the HiFiBerry and play music fine.

    Can you point me in the direction of what I am doing wrong please

    Regards

    Barry

    13. Dezember 2019 at 13:53 #47764

    Hi Barry,

    If you connect successsfully, you should have a positive feedback indication in your router’s web interface. Then, you should be able to see the max2play in your router’s device list and it’s assigned IP. You can try using this IP to connect to the Pi as well.

    To make sure the connection did not fail, you can also connect it via ethernet cable and set up the wifi manually.

    13. Dezember 2019 at 14:01 #47765

    That’s just the point, I cannot see it in my web interface of my Wifi system. It has not connected successfully. If it had connected and if I could see an IP address I would have tried that.

    Can you explain what the error messages mean and why it doesn’t seem to want to connect.

    I would have to buy a LAN adaptor and not sure why I would need to as it should connect via WIFI and if the WPS was not working it should have created an automatic access point (which it did not).

    Its not the hardware as that works fine with Raspian.

    Regards
    Barry

    13. Dezember 2019 at 14:25 #47766

    Both error messages are inconsequential. The first occurs on all boot sequences and is due to the fact these interfaces aren’t loaded yet within the sequence of events and the second is about the HDD idle time for connected HDDs.

    I should mention that we do not recommend using a device like the AMP2 with a RPi zero. Please have an eye on the Health Checker in Settings/Reboot when using it. If you have a 5V PSU, please try booting the Pi without the AMP2 and letting it set up the automatic access point. Then follow the instructions to set up your WiFi credentials while in access point mode.

    15. Dezember 2019 at 17:49 #47779

    I finally managed to get it to work, by tracking down a USB Network converter. Which on the seconds attempt (The first time it got stuck in the same place) finally went all the way through. I was then able to connect, tell it to use wifi and give it a static IP address which is what I wanted.

    It is worth pointing out that your comment ‘Please have an eye on the Health Checker in Settings/Reboot when using it.’ Was a bit odd as it has to be fully booted for this to be seen and my problem was it would not boot via wifi !
    As I see it there is an issue with Max2Play trying a 1st time boot using wifi with our without wps since it doesn’t bring up an access point either. Once booted 1st time on LAN its then OK every time on wireless and the power is marked as “Power Supply OK” on the settings/reboot menu.

    Also, on the HiFi Berry AMP 2 page it states “The Amp2 integrated voltage converter is powerful enough to power even the new Raspberry Pi 4.” So, I am surprised about your power comments and clearly that wasn’t it.

    I am left with 2 questions
    1. If you “do not recommend using a device like the AMP2 with a RPi zero” please can you tell me why and what you do recommend as I would like to have a good setup
    2. Is there any way to run a Terminal rather than GUI screen to save on CPU as I will not have anything connected to the HDMI under normal circumstances?

    Thanks
    Regards
    Barry

    16. Dezember 2019 at 17:32 #47788

    Hi Barry,

    Glad to hear you got it working.

    The issue is actually not undervoltage but inexperience with such high levels of voltage on the zero. Other issues are the lower computing power, which can get problematic mostly with Squeezebox Server installed, and the dimensions of the Pi. The AMP2 was designed and developed with the standard HAT dimensions of the main Pi’s in mind. Those are Pi 2B, 3B, 3B+ or 4B. All these are the primary devices for use with Max2Play and the ones we are testing it on continually. The Zero Wireless is a nifty smaller option for smaller setups e.g. just running Squeezelite. There are also specific sound cards for the zero Pi’s like MiniAmp or DAC+ Zero.

    16. Dezember 2019 at 17:50 #47792

    Thanks for this but you missed my second question

    Is there any way to run a Terminal rather than GUI screen to save on CPU as I will not have anything connected to the HDMI under normal circumstances?

    Regards
    Barry

    17. Dezember 2019 at 16:58 #47802

    Hi Barry,

    I don’t understand. The web interface is the way to control Max2Play. You can use a terminal. There’s a plugin called remote control that let’s you run a simple SSH through the web interface. You can also always access the device via terminal with software like putty.

    17. Dezember 2019 at 17:39 #47803

    On the actual screen attached to the Raspberry PI via an HDMI connection, MAX2PLAY runs a GUI, This is the one I was hoping I could make a command line, especially as under normal circumstances I will not have a monitor connected to the HDMI port as, as you say, you configure most things via the web interface.

    I hope the question is clearer now

    Regards
    Barry

    18. Dezember 2019 at 12:13 #47809

    Okay, so you want to suppress the normal desktop startup of the underlying debian and have the terminal output instead. There is no default option for this in Max2Play. However, you can manually remove the functionality with one of the many guides for Raspbian. Max2Play is based on the Raspbian and the same steps should apply. Here’s one for Raspbian Stretch with even further tips to reduce power usage

    You can check the version of your Max2Play in Settings/Reboot’s debug info window and use the remote control plugin to apply these commands.

    If I may ask, what is the reason for this if you don’t intend to have a screen connected? If the Pi does not recognize a screen on boot, it has nothing to launch the desktop on and will not do so.

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.

Register here