Can't get any USB drive to mount

Max2Play Home 2016 (en) Forums Max2Play on ODROID U3/C1 Can't get any USB drive to mount

This topic contains 0 replies, has 1 voice, and was last updated by  Teetertank 1 month, 4 weeks ago.

Viewing 1 post (of 1 total)
  • 6. October 2016 at 3:28 #23284

    I’ve been having problems to get reliable mount for USB drives. I’m currently using Odroid XU4 and when I saw a new image for Ubuntu 16.04 I thought that may solve the issue, but now I can’t get any USB drive to mount at all.

    When trying to connect a USB drive it is often recognised but get the message <name of drive>” drive in not mounted” on the File System Mount tab of Max2play

    I’ve tried many things, including:
    – Connecting USB drive direct to USB3 port and tried USB2 port
    – Connecting USB drive using high powered (6A) USB hub
    – Re-downloading fresh image, burning to eMMC and re-installing Max2play
    – Connecting USB drive while Max2play is running
    – Connecting USB drive while Odroid is not powered
    – Tried two different USB drives (Western Digital) both 2.5″
    – Tried two different USB hubs
    – Tried a few different USB pen drives rather than hard drive
    – Installing Android on SD card then re-imaging eMMC module to “repair” it
    – Tied powering Odroid from normal power supply and also USB hub simultaneously while drive directly connected to Odroid

    Nothing I try seems to get the drive mounted. I’m worried I’m wearing out the USB ports and eMMC connector from all the drive and card swapping. I’ve spent hours trying to get various drives connected but only get the “not mounted” message.

    Has anyone successfully mounted a drive on the latest Ubuntu 16.04 based image?

    Would be great to get this working as without a hard drive connected my Odroids are useless as music server.

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.

Register here