Can't activate Max2Play License on v2.50

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Can't activate Max2Play License on v2.50

This topic contains 9 replies, has 2 voices, and was last updated by  Heiner Moderator 1 year, 4 months ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • 13. Juli 2019 at 18:33 #46303

    Hi there

    I was successfully running LMS via Max2PLay v2.47 on a Raspberry 3B+, with an activated license.

    After updating to v2.50 I can no longer activate the license through email or key.
    I’ve also done the following: Set a fixed IP, switched from WiFi to Ethernet, de-activated a number of plugins incl. the Hifiberry plugin.
    The Pi was running as squeezelite + LMS and is a LMS now only.

    Which of the above things might have broken the license mechanism?
    How to troubleshoot?

    15. Juli 2019 at 15:26 #46309

    Hi Hurwitz,

    I checked your license and it activated our tester.
    None of the things you mentioned should have any bearing on our license server and its authentication process.
    The only thing you can check is that the automatic access point in WiFi/LAN does not block the internet access.

    Please try the following:
    Make sure your Max2Play device is connected to the internet.
    Delete the license in the Max2Play interface and click „save“ with a blank field.
    Click on „Settings/Reboot“ again, reenter your license and click „save“.
    Check if the green „Activated“ field appears. If not, contact us again for further help.

    15. Juli 2019 at 16:20 #46318

    I did further troubleshooting:

    Changing from eth0 to wlan0 did nothing to solve the issue.

    I then checked DNS requests in pi-hole and it seems a successful (DNS) request is made after clicking the „Save“ button on the Settings tab.

    
    Time	Type	Domain	Client	Status	Reply	Action
    2019-07-15 15:12:46	A	www.max2play.com	192.168.XXX.XXX	OK (cached)	IP (0.2ms)	 Blacklist
    2019-07-15 15:12:46	AAAA	www.max2play.com	192.168.XXX.XXX	OK (cached)	IP (0.2ms)	 Blacklist
    

    Based on that I can only guess that either, low-level networking is borked in some way (which should be easy to troubleshoot), or, the license activation function somehow fails.

    15. Juli 2019 at 16:21 #46319

    Off-topic: I edited and submitted a post earlier, but I can’t see it now?

    15. Juli 2019 at 18:42 #46322

    I hope this is helpful:

    
    Warning: file_get_contents(): SSL operation failed with code 1. OpenSSL Error messages: error:14090086:SSL routines:ssl3_get_server_certificate:certificate verify failed in /var/www/max2play/application/model/CheckLicense.php on line 28
    
    Warning: file_get_contents(): Failed to enable crypto in /var/www/max2play/application/model/CheckLicense.php on line 28
    
    Warning: file_get_contents(https://XXX.com/XXX?email=XXX): failed to open stream: operation failed in /var/www/max2play/application/model/CheckLicense.php on line 28
    
    15. Juli 2019 at 18:54 #46323

    Okay I guess I should add that running Philippe’s ShairTunes2 plugin requires a certain openSSL version if I remember correctly. That could be a factor here.

    15. Juli 2019 at 22:58 #46326

    Solution:

    While I first thought ShairTunes2 LMS plugin might have played a role, my understanding now is that Php comes with its own version of openSSL.

    Stack Overflow reveals that the error in many cases is triggered by a missing certificate.
    While trying to download the recommended certificate I encountered something strange:

    
    $ wget https://curl.haxx.se/ca/cacert.pem
    --2019-07-15 22:35:35--  https://curl.haxx.se/ca/cacert.pem
    Resolving curl.haxx.se (curl.haxx.se)... 151.101.130.49, 151.101.194.49, 151.101.2.49, ...
    Connecting to curl.haxx.se (curl.haxx.se)|151.101.130.49|:443... connected.
    ERROR: The certificate of ‘curl.haxx.se’ is not trusted.
    ERROR: The certificate of ‘curl.haxx.se’ hasn't got a known issuer.
    

    Turns out, the certificate store (here /etc/ssl/certs) was empty.
    Luckily on Debian the solution is trivial:
    sudo apt-get install ca-certificates

    Source: https://stackoverflow.com/questions/9224298/how-do-i-fix-certificate-errors-when-running-wget-on-an-https-url-in-cygwin

    I can’t exclude the possibility that something else cleared the certificate store (couldn’t say what did), however, I strongly suggest to check your upgrade scripts.

    18. Juli 2019 at 10:45 #46358

    Hi Hurwitz,

    Thank you for the detailed update. We will have a look into this.

    18. Juli 2019 at 10:45 #46359

    Hi Hurwitz,

    Thank you for the detailed update. We will have a look into this.

    18. Juli 2019 at 10:45 #46360

    Hi Hurwitz,

    Thank you for the detailed update. We will have a look into this.

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.

Register here