[SOLVED] Cannot start Squeezebox Server

Max2Play Home 2016 (en) Forums Max2Play as Squeezebox (Player / Server) [SOLVED] Cannot start Squeezebox Server

This topic contains 6 replies, has 2 voices, and was last updated by  willytom premium 1 year, 3 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • 23. Juni 2019 at 7:22 #45896

    I got this error when I try to start the Squeezebox Server.

    Trying to launch … NOT successful Click here to show detailed information
    We trust you have received the usual lecture from the local System
Administrator.
    It usually boils down to these three things:
    #1) Respect the privacy of others.
    #2) Think before you type.
    #3) With great power comes great responsibility.

sudo: no tty present and no askpass program specified

    This is my hardware RPI 3B+ with HiFi Berry DAC+ Pro and 7” touchscreen and Max2Play v247.

    I am new to Max2play thanks for your help.

    24. Juni 2019 at 13:50 #45907

    Hi willytom,

    Do you have any open ports in your local network?

    Does your Max2Play Image have a Stretch-based kernel (check in Settings/Reboot debug info text, should say stretch instead of jessie)?

    25. Juni 2019 at 4:26 #45914

    The Max2play is behind the router, so all the ports should be already opened.

    Is a stretch version.

    #### KERNEL ####
    Linux max2play 4.14.76-v7+ #1150 SMP Mon Oct 15 15:19:23 BST 2018 armv7l GNU/Linux

    #### LINUX-VERSION ####
    Distributor ID: Raspbian
    Description: Raspbian GNU/Linux 9.9 (stretch)
    Release: 9.9
    Codename: stretch

    25. Juni 2019 at 10:17 #45918

    Sorry, I mean open to the outside. This is an issue for the LMS and we recommend closing any open ports to the internet when operating a Squeezebox Server.

    Does your Health Checker in Settings/Reboot indicate any red parameters?

    25. Juni 2019 at 13:53 #45919

    What are the ports needed to open for LMS? The health checker is all green.

    Thanks

    25. Juni 2019 at 15:28 #45925

    Okay, so there are different kinds of ports. For the Pi in the local network, the LMS usually uses port 9000.

    However, open ports, for example for VPNs and the like, are a danger for the LMS. If you have not worked with anything to route a connection outside your local network, you do not need to concern yourself with this.

    It might be, your installation was just somehow faulty. You can try installing anew and keeping the installation running uninterrupted for at least 15 minutes. Try selecting the version 7.9.1.

    26. Juni 2019 at 0:27 #45941

    Thanks I got it to work.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.

Register here