[SOLVED] Cannot play Deezer across multiple Squeezebox player

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI [SOLVED] Cannot play Deezer across multiple Squeezebox player

This topic contains 4 replies, has 2 voices, and was last updated by  j_cuddihy premium 9 months, 3 weeks ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • 31. December 2016 at 13:19 #25328

    Hi,

    Up to now, I have been running SqueezePlug sucessfully on a Pi Model B. Due to constant buffering on radio streams, I reckoned that the Pi’s memory wasn’t sufficient so I upgraded to a Pi2.

    On to this Pi2, I installed Max2Play and successfully set up the LMS – 7.8. Everything on it works perfectly including Deezer.
    When I sync 2 or more players ( I’m running 2 duets, 2 classics and 2 SB boom) together, Deezer will not play.

    I get this in the log:
    [16-12-30 18:24:15.6575] Slim::Formats::RemoteStream::open (106) Can’t open socket to [e-cdnt-proxy-7.deezer.com:80]: 113: No route to host
    [16-12-30 18:24:15.6597] Slim::Player::Song::open (471) Warning: stream failed to open [deezer://95001964.mp3].

    When the players are running unsychronized, it plays perfectly. Obviously I was able to run Deezer, with multi players sync’d, on the Pi 1 with SqueezePlug. It’s also worth noting that upgrading to the Pi2 resolved the radio buffering issue.

    Am I missing something in my set-up?

    Thanks,

    j_Cuddihy

    31. December 2016 at 14:58 #25330

    On further investigation, when I switch a player’s MP3 streaming method to Direct Streaming, Deezer works fine. When I switch a player to Proxied Streaming, even when it’s not sync’d to another player, Deezer stops. Obviously the players kick into Proxied mode when they are sync’d together to the LMS server is not streaming Deezer. Is this just a case of having to purchase a Premium license to get this working? If so, great, I’m happy to do that. I don’t really want to jump in and do that if it won’t solve my problem, but if it will, I’ll be happy to do so.

    Thanks,

    J_Cuddihy

    2. January 2017 at 14:37 #25356

    I have now purchased a premium licence but nothing has changed – Direct streaming works on Deezer but proxied streaming (required for multi player playback) does not.

    Any thoughts?

    Thanks,

    J_cuddihy

    2. January 2017 at 15:08 #25359

    Hello,

    I have been troubleshooting the same error during the last days. I got it solved by modifying the netmask settings, see also

    [SOLVED] Network issues with Squeezebox plugins related to netmask

    BR

    2. January 2017 at 16:38 #25366

    Thank you so much! That sorted the problem for me straight away.

    All up and running now.

    Thanks again,

    J_cuddihy

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.

Register here