Cannot Get Squeezebox Server: No Available Versions, "LMS-Version Does Not Exist

Max2Play Home Forums Max2Play on Raspberry PI Cannot Get Squeezebox Server: No Available Versions, "LMS-Version Does Not Exist

Viewing 5 posts - 1 through 5 (of 5 total)
  • 10. November 2021 at 22:05 #51781

    Hello. I am running a Raspberry Pi 3B since 2018. Recently, it started to fail to shuffle disks, then failed to find my music files, all intermittently. Putting a cloned copy of my SD card into the pi did not change the behavior. Rewriting the image onto the SD card from 2018 did not lead to a working player. Reloading my SD card with a fresh download from led me to the same problem. On the m2p interface, „Squeezebox Server“ selection, the drop-down box „Show Available Versions“ is empty, and clicking on „Squeezebox Server Start Installation“ gets the error message „LMS-Version Does Not Exist.“ I do have Audioplayer on my list of active plug-ins; that should include the Squeezebox Server, in my understanding. I have tried to figure out what to type into the window, „Alternative source from Slimdevices (package must be .deb): “ but have failed. How do I make my music player function again?

    11. November 2021 at 14:22 #51782

    Hi Joe,

    Please perform a Max2Play update. Afterwards, the available LMS versions should be visible and installable again. You can find the update button in the „Settings/Reboot“ tab.

    6. Januar 2024 at 15:27 #53027


    I had to perform a clean max2plat install after years of trouble free max2play usage. I have successfully flashed a new image and have max2play working, configured with my IQAudiO hat.

    I am unable to install LMS and repeatedly get an error message saying the LMS version is not available. I’ve tried lots of things, including updating to the beta max2play, using alternative locations for LMS, trying all three main LMS versions available in max2play, terminal installation, different browsers, using different SD cards. The error is always the same.

    Please can someone help. I have sent an email about this as well as I can’t find a solution in the forum.

    Thank you.

    6. Januar 2024 at 19:23 #53028

    I see that this message is in a string that I initiated. And I think I understand that it is me who titled this ‚No Available Versions, „LMS-Version Does Not Exist“‚ But I will reply from my notes, which somewhat disagree.

    In my notes, my problem was an error message saying „cannot locate server.“

    And my solution was to set my Raspberry Pi address to (the port was set to 9000 without interaction on my part) and then enter that address into my remote control program, Orange Squeeze.

    For Max2Play, in the m2p interface, WiFi/LAN tab, find “Fixed LAN-IP Setup” to set this address.

    The rest of this message may or may not be of value….

    On the Raspberry Pi, if a reboot is required, disconnecting and reconnecting power does not reset the state as desired, because much of the state information is on the SD card, which is nonvolatile. I had max2play require a reboot after its first two years of operation and again three years later. This is pretty good performance, except that rebooting is so terribly hard. (By contrast, when I used piCorePlayer instead of Max2Play, rebooting was required 4 times in a 7 month period.) My solution is to make a clone of the SD card containing Max2Play after I have the system running. The next time a reboot is required, I clone the clone for backup and install the cloned SD card.

    6. Januar 2024 at 20:08 #53029


    Thanks for the feedback. Yes, it’s a learning experience. I had a similar issue with the IP.

    Fingers crossed I’ll get LMS installed soon and cloning the SD card is definitely something to do in the future.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.

Register here