Cannot get Spotify to work in Logitech Media Server

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Cannot get Spotify to work in Logitech Media Server

This topic contains 11 replies, has 5 voices, and was last updated by  Heiner Moderator 5 months, 2 weeks ago.

Viewing 12 posts - 1 through 12 (of 12 total)
  • 24. February 2016 at 2:06 #18685

    I have just lost all evening search all sorts of posts for an answer to the following which works. So far no luck. I cannot get Spotify to play on my Squeezebox touch. My music library works fine with m2p. I tried Triode 3rd party app both with and without the LMS Spotify app. Rebooting with each new setting.

    Basically it will not connect to Spotify. I get the following message when trying to find artists:

    Error reading headers: Server closed connection without sending any data back at /usr/share/squeezeboxserver/CPAN/Net/HTTP/Methods.pm line 306.
    …propagated at /usr/share/squeezeboxserver/CPAN/Net/HTTP/NB.pm line 32.

    When I run the self test I get the following:

    Helper App Running: PASS
    Not Logged In: FAIL
    Failed To Receive Metadata:FAIL

    Can anyone please help???

    Thanks

    24. February 2016 at 13:34 #18698

    Hi Quentin,

    which version of LMS is installed on your Squeezebox?

    For the setup of Max2Play with Raspberry Pis and ODROIDs, Spotify works with the Triode plugin en- and the LMS plugin disabled and LMS 7.8.0, 7.8 Nightly and 7.9 Nightly. If this does not work on your Squeezebox Touch, I recommend to contact Logitech or related forums to learn more about this issue. It would be great, though, if you let us know the results here as well.

    Maximilian from Max2Play

    25. February 2016 at 12:05 #18734

    Hi Maximilian

    Thanks for your response. I don’t think the problem is that it won’t play on the touch. It simply won’t connect to my Spotify account. I keep wondering if I am doing something wrong?

    I set it up LMS 7.8.0. I tried it with the official spotify app installed and also uninstalled. I rebooted in between each change. The Triode 3rd party app simply will not connect to my Spotify account at all. When I enter my password and click “apply” the password disappears. When I run the test I get the following messages:

    Helper App Running: PASS
    Not Logged In: FAIL
    Failed To Receive Metadata:FAIL

    The official app connects to my premium spotify account fine but won’t play on the Touch (well documented I believe).

    I am a bit lost!
    Cheers
    Quentin

    • This reply was modified 1 year, 3 months ago by  Quentin Hulm.
    25. February 2016 at 16:42 #18757

    Hi Quentin,

    Thank you for your reply.

    Unfortunately, we cannot reproduce the issue lacking a Squeezebox Touch and cannot provide help. Therefore, to ask also experts in other SB Touch related forums makes sense to me.

    Using Spotify with your Squeezebox requires a Spotify Premium account. Do you have one?
    Do you have access to a Raspberry Pi 2 you could use with Max2Play? If yes, install Max2Play and the same version of LMS on this Pi and test the Spotify Triode plug-in with that configuration. We have just tested the Triode Plugin on a Raspberry Pi 2 with LMS 7.9 Nightly and a Spotify Premium Account and could login and play music successfully.

    Maximilian from Max2Play

    26. February 2016 at 12:36 #18775

    The official spotify app works fine on my SB touch and SB radio.

    If it doesn’t work for you try posting at http://forums.slimdevices.com/showthread.php?104436-Announce-We-re-updating-the-official-Spotify-app

    26. February 2016 at 15:44 #18780

    Hi

    Thank you both for your response. I remain unable to get the official App to work on my SB Touch. I really can’t think why. Thanks for the link asplundj.

    However! I am extremely embarrassed to admit that the reason I couldn’t get the Spotify App to work is because I was persistently trying an old password. Pure muppetry. Sorry for misleading you into spending your time Maximilian. I did consider this but convinced myself I had the correct password. It’s only when I logged out of Spotify and deleted the pre-filled password and re-entered it that it was obvious. Doh!.
    This isn’t the problem with the official app, however, as I know that is correctly logged in; it just won’t play. In the meantime, I am finally able to enjoy Spotify on my Touch!

    26. February 2016 at 16:49 #18786

    Did you add your spotify account at mysqueezebox.com?

    26. February 2016 at 16:55 #18787

    Yes I did, a long time ago. For good measure, however since you mention it, I have just uninstalled it and re-installed it. Something perhaps I should have tried a while ago. I will check it again when home. As a matter of interest though, is it worth it? Triode seems to be running very well now.

    Cheers

    26. February 2016 at 17:02 #18790

    As long as the triode one works I wouldn’t bother with the official one. The triode one is independent of mysqueezebox.com in case that one goes down. Triode use an Internal library while the official one uses your spotify library. As such, if you add an artist / album to your library on your phone / pc it will also show up on your squeezebox if using the official addon but not on triode. However, this could be a good thing of you want separate libraries.

    26. February 2016 at 17:04 #18791

    Ah! Ok, that’s interesting. OK I will play around with it. I have seen talk about the benefits of the Triode “top 10” for an artist and also the easy addition or removal of songs/albums to playlists/albums.
    Cheers
    Q

    25. December 2016 at 17:47 #25232

    The playlist of Spotify did not update anymore in M2P 2.38 and LMS 7.8, reason to go for a fresh image of M2P 2.39 and LMS 7.9

    When 3de party Spotify was installed and the original removed (+ reboot), Spotify did not show up in the menu lists of the players. With all checks in the connection list positive.
    For the Transporter I was able to add Spotify from he inactive menu list (in settings, Transporter, menus).
    But it still does not function. It supplies information about not being attached to the Squeezebox Server. What has this to do with Spotify??
    Account is recognized and there are no clickable entries.
    Also have not found a way to add Spotify as entry from the webpage service.

    I now made an older image on a microSD and switched in this way back to 2.12 and lms 7.8.
    No problem on this to get Spotify logged on and running. It also updates the playlists from my other systems.

    Sadly without recent software less entries in my music data system.
    Interested in a solution

    • This reply was modified 5 months, 4 weeks ago by  KeysAndSax.
    • This reply was modified 5 months, 4 weeks ago by  KeysAndSax. Reason: more info added
    • This reply was modified 5 months, 3 weeks ago by  KeysAndSax.
    5. January 2017 at 15:15 #25560

    Hi Keys,
    We recently successfully tested the plugin again with our newest software. You might also want to consult the Slimdevices forums wherein the plugin originated: http://forums.slimdevices.com/forum.php

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.

Register here