[SOLVED] Cannot get airplay on LMS

Max2Play Home 2016 (en) Forums Max2Play as Squeezebox (Player / Server) [SOLVED] Cannot get airplay on LMS

This topic contains 5 replies, has 2 voices, and was last updated by  Heiner Moderator 4 weeks, 1 day ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • 17. August 2018 at 22:59 #36990

    I am using max2play as a LMS server backend to my Logitech squeezeboxes, and I am having problems getting airplay to work. Once I install the Bugfix for Shairtunes2 and Enable plugin ShairTunes2(fork), the LMS becomes unreachable.

    Any ideas?

    —————————–

    Here is the long story of what I have done
    Burn image m2p_stretch_rpi_245.img unto SDcard using Etcher on Mac.
    Start Pi and goto 192.168.1.3
    Click „Skip this“ at choice of soundcard
    Click „Select this setup“ at Advanced
    Clicked at „To restart now just click here“
    Goto Settings/Reboot tab and click „Update Max2Play“
    Activated Max2Play with email adress
    At Squeezebox Server tab click Show available versions
    Choose LogitechMediaServer_v7.9.1
    Click Squeezebox Server start installation and wait for installation to complete
    Choose „Bugfix for Shairtunes2 on Max2Play“ and click Install choosen Plugin
    In the Settings/Reboot tab click „Reboot“ and wait for system to reboot.
    Even after several minutes I cannot access the webinterface. I can ping 192.168.1.3 with no packet loss.
    From terminal „ssh [email protected].1.3″, password „max2play“
    sudo /etc/init.d/apache2 start“
    Now I can access web interface again
    In Sqeezebox Server click „Open Squeezebox Server webadministration“
    Log into mysqueezebox.com Account
    Choose Local Music Folder
    Choose Playlist folder
    In Logitech Media Server webfront click Settings
    In Plugins tab check Enable under ShairTunes2(fork) and click „Apply“
    Click „restart now“ in the dialog popup box. Click OK in the „..Please wait a minute before …“ box
    The squeezebox server webinterface is now unavailable (This site can’t be reached)
    3 last lines in DEBUG information is
    „[18-08-17 20:55:33.3048] Slim::Utils::SQLiteHelper::postConnect (374) Optimizing DB because of missing or empty sqlite_stat1 table
    [18-08-17 20:55:33.3677] Slim::Schema::forceCommit (2149) Warning: Trying to commit transactions before DB is initialized!
    2018-08-17 20:55:39 Logitech Media Server died. Restarting.“
    Click „kill Squeezebox Server“ under Squeezebox server tab
    Click „restart Squeezebox Server“ under Squeezebox server tab
    Last 2 lines in DEBUG information is
    2018-08-17 20:59:25 squeezeboxserver_safe stopped.
    2018-08-17 20:59:26 squeezeboxserver_safe started.
    Squeezebox Server Webadministration still unavailable
    In Settings / Reboot click „Reboot“
    After reboot Squeezebox Server Webadministration still unavailable

    Full LMS DEBUG file here

    20. August 2018 at 13:54 #37008

    Hi drcoffee,

    The web interface access issue might be related to your router. Try renaming the Pi and rebooting.

    The lines from your debug info log do not indicate anything extraordinary, so the server should be running after the restart.

    20. August 2018 at 22:00 #37016

    Tried it with no luck.

    21. August 2018 at 12:46 #37057

    Please check that there are no other plugins named „shairtunes“ active in your LMS. Please also try making and apt-get update at the bottom of the Raspberry Settings an rebooting.

    21. August 2018 at 22:11 #37078

    I tried taking my SD card out of my Raspberry Pi, and booting another Raspberry Pi with the same SD card inserted. And then it all worked flawlessly. So max2play was apparently not to blame. Probably a hardware error.

    Thanks for the patient suggestions!

    22. August 2018 at 12:05 #37104

    Thanks for the follow-up, glad to hear it’s working now. 🙂

    I’ll mark the topic closed.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

Register here