Cannot connect via bluetooth

Max2Play Home 2016 (en) Forums Max2Play Add-ons Cannot connect via bluetooth

Tagged: 

This topic contains 11 replies, has 2 voices, and was last updated by  MarioM Moderator 1 year ago.

Viewing 12 posts - 1 through 12 (of 12 total)
  • 15. Oktober 2020 at 12:38 #49847

    Hello,

    I have a Raspi3 with HifiBerry running on max2play 2.52.
    I activated my license and installed bluetooth support. I was able to connect my cellphone (OnePlus 7 Pro, Android 10) once but I never was able to hear any music. When I disconnect and connect again, the connection is established but immediately dropped. Can you help me?

    Here is the Bluetooth DEBUG output:

    #### Bluetooth Installation ####

    #### Bluetooth Dongle ####
    hci0: Type: Primary Bus: UART
    BD Address: B8:27:EB:87:7F:72 ACL MTU: 1021:8 SCO MTU: 64:1
    UP RUNNING PSCAN
    RX bytes:5352 acl:57 sco:0 events:225 errors:0
    TX bytes:4859 acl:60 sco:0 commands:132 errors:0

    #### DEVICE OnePlus 7 Pro ####
    spawn /usr/bin/bluetoothctl
    Waiting to connect to bluetoothd…
    [0;94m[bluetooth][0m#

    [[0;92mNEW[0m] Controller B8:27:EB:87:7F:72 max2play2 [default]
    [0;94m[bluetooth][0m#

    [[0;92mNEW[0m] Device 98:09:CF:75:FC:31 OnePlus 7 Pro
    [0;94m[bluetooth][0m# info 98:09:CF:75:FC:31
    Device 98:09:CF:75:FC:31
    Name: OnePlus 7 Pro
    Alias: OnePlus 7 Pro
    Class: 0x5a020c
    Icon: phone
    Paired: yes
    Trusted: no
    Blocked: no
    Connected: no
    LegacyPairing: no
    quit
    UUID: Dialup Networking (00001103-0000-1000-8000-00805f9b34fb)
    UUID: OBEX Object Push (00001105-0000-1000-8000-00805f9b34fb)
    UUID: Audio Source (0000110a-0000-1000-8000-00805f9b34fb)
    UUID: A/V Remote Control Target (0000110c-0000-1000-8000-00805f9b34fb)
    UUID: A/V Remote Control (0000110e-0000-1000-8000-00805f9b34fb)
    UUID: Headset AG (00001112-0000-1000-8000-00805f9b34fb)
    UUID: PANU (00001115-0000-1000-8000-00805f9b34fb)
    UUID: NAP (00001116-0000-1000-8000-00805f9b34fb)
    UUID: Handsfree Audio Gateway (0000111f-0000-1000-8000-00805f9b34fb)
    UUID: SIM Access (0000112d-0000-1000-8000-00805f9b34fb)
    UUID: Phonebook Access Server (0000112f-0000-1000-8000-00805f9b34fb)
    UUID: Message Access Server (00001132-0000-1000-8000-00805f9b34fb)
    UUID: PnP Information (00001200-0000-1000-8000-00805f9b34fb)
    UUID: Generic Access Profile (00001800-0000-1000-8000-00805f9b34fb)
    UUID: Generic Attribute Profile (00001801-0000-1000-8000-00805f9b34fb)
    UUID: Vendor specific (deab91e4-670f-11e1-9ace-30bc4824019b)
    Modalias: bluetooth:v001Dp1200d1436
    [0;94m[bluetooth][0m# quit
    [0;94m[bluetooth][0m#

    [[0;91mDEL[0m] Controller B8:27:EB:87:7F:72 max2play2 [default]
    [0;94m[bluetooth][0m#

    Waiting to connect to bluetoothd…

    #### BLUEALSA RUNNING ####
    2

    Regards

    Clarenze

    16. Oktober 2020 at 14:41 #49850

    Hi Clarenze,

    Thank you for the debug info. In order to narrow down the problem, please answer the following questions: Have you enabled direct streaming to the sound card or installed streaming to the Squeezebox Server? Do you use a bluetooth dongle or the integrated bluetooth? Do you use our stretch image or buster?

    17. Oktober 2020 at 10:10 #49854

    Hi,

    It is configured to „direct streaming to the soundcard“.
    I intend to use the integrated bluetooth adapter.
    The Debian version is 9.4. It is the image provided by you (I bought a pre-installed max2play package).

    Regards

    Clarenze

    20. Oktober 2020 at 11:50 #49869

    Hi Clarenze,

    Please make sure you have followed the steps for direct Bluetooth streaming on our wiki: https://www.max2play.com/en/wiki/bluetooth-direct-stream/

    If the problem persists, please try to download a new stretch image from our download page and burn it to the SD card. Then try the Bluetooth connection again.

    28. Oktober 2020 at 10:32 #49944

    I tried that now, but it still does not work. I think the bluetooth feature never worked. I tried on a different device one year ago and had exactly the same problems. Also back then support was not willing to do anyhting beyond recommending to reinstall. This is a big disappointment. Every 50€ bluetooth speaker can do this.

    28. Oktober 2020 at 13:24 #49948

    Hi Clarenze,

    I tested bluetooth streaming again and could not reproduce the problem. So I am assuming that there is a configuration error. Can you connect your mobile phone to the Pi via the plugin? Can the Pi find any Bluetooth devices in the area?

    29. Oktober 2020 at 13:47 #49972

    It sometimes works when I click connect within the max2play frontend. Connecting from the phone never works. It connects and immediately disconnects again.
    Does a USB bluetooth dongle work better than the built-in one?

    3. November 2020 at 14:12 #49998

    Hi Clarenze,

    A Bluetooth dongle can help, but the Pi’s integrated Bluetooth should also work as long as nothing interferes with the signal. Did you install the Pi in a case and did you connect the Pi to the internet via WiFi? In this case the Bluetooth signal may be disturbed.

    29. Oktober 2021 at 19:04 #51761

    I started yet another attempt to get bluetooth streaming working on the max2play/rapsi3 device.
    I installed a bluetooth dongle now, as you suggested (1mii Bluetooth Adapter PC), but max2play still uses the built-in adapter.
    I tried activating the USB device by hand, but I get an error message:

    [email protected]:~# hciconfig -a
    hci1: Type: Primary Bus: UART
    BD Address: B8:27:EB:ED:96:81 ACL MTU: 1021:8 SCO MTU: 64:1
    UP RUNNING PSCAN
    RX bytes:745 acl:0 sco:0 events:46 errors:0
    TX bytes:1522 acl:0 sco:0 commands:46 errors:0
    Features: 0xbf 0xfe 0xcf 0xfe 0xdb 0xff 0x7b 0x87
    Packet type: DM1 DM3 DM5 DH1 DH3 DH5 HV1 HV2 HV3
    Link policy: RSWITCH SNIFF
    Link mode: SLAVE ACCEPT
    Name: ‚max2play‘
    Class: 0x0c0000
    Service Classes: Rendering, Capturing
    Device Class: Miscellaneous,
    HCI Version: 4.1 (0x7) Revision: 0x168
    LMP Version: 4.1 (0x7) Subversion: 0x2209
    Manufacturer: Broadcom Corporation (15)

    hci0: Type: Primary Bus: USB
    BD Address: 00:00:00:00:00:00 ACL MTU: 0:0 SCO MTU: 0:0
    DOWN
    RX bytes:581 acl:0 sco:0 events:82 errors:0
    TX bytes:20534 acl:0 sco:0 commands:83 errors:0
    Features: 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00
    Packet type: DM1 DH1 HV1
    Link policy:
    Link mode: SLAVE ACCEPT

    [email protected]:~# hciconfig hci1 down
    [email protected]:~# hciconfig hci0 up
    Can’t init device hci0: Cannot assign requested address (99)

    How can I activate hci0?

    1. November 2021 at 16:37 #51764

    Hi Clarenze,

    You can deactivate the built-in Wifi in the Raspberry settings. Your wifi dongle may still need a suitable driver. You can install it with the following commands, provided your dongle is connected and recognised by the system:

    sudo wget http://downloads.fars-robotics.net/wifi-drivers/install-wifi -O /usr/bin/install-wifi
    sudo chmod +x /usr/bin/install-wifi
    sudo install-wifi

    Restart your system afterwards.

    1. November 2021 at 18:21 #51766

    My question was regarding bluetooth, not wifi.

    4. November 2021 at 14:26 #51775

    I am very sorry. I do not know what I have read there.

    Nevertheless, the internal Bluetooth can be disabled via the Raspberry settings. Apart from that the BT dongle should be detected automatically. The error with hci up could be caused by an outdated kernel. Maybe a kernel update (also available via the Raspberry settings) will help.

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.

Register here