Cannot connect Samsung S7 with Pi 3 B+ via Buetooth

Max2Play Home 2016 (en) Forums Max2Play Add-ons Cannot connect Samsung S7 with Pi 3 B+ via Buetooth

This topic contains 10 replies, has 3 voices, and was last updated by  Heiner Moderator 1 year, 5 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • 24. März 2019 at 23:46 #44858

    I have a Pi3 B+ with a HifiBerry Amp2. I am connected to my home network via ethernet only.
    My WiFi adapter status is ACTIVE
    My WIFI connection status is INACTIVE. I’ve read in other posts that turning the ethernet off might help but I don’t know how to do that — not a programmer and new to the Pi universe.

    I’ve been able to play music from a USB drive mounted in the Pi using squeezebox server controlled by both my laptop and my Samsung S7.

    The bluetooth is apparently active on the Pi3, my phone can find and pair to it but just cannot connect. I’ve also tried to pair and connect a Fugoo BT speaker. Max2Play recognized both devices but connections always fail. Here’s what I got from the last time I tried to connect to my Samsung:

    Device C4:59:76:03:D8:54 Fugoo Speaker
    Device 50:9E:A7:7E:DF:90 Samsung Galaxy S7
    trust 50:9E:A7:7E:DF:90
    Changing 50:9E:A7:7E:DF:90 trust succeeded
    pair 50:9E:A7:7E:DF:90
    Attempting to pair with 50:9E:A7:7E:DF:90
    Failed to pair: org.bluez.Error.AlreadyExists
    connect 50:9E:A7:7E:DF:90
    Attempting to connect to 50:9E:A7:7E:DF:90
    Device 50:9E:A7:7E:DF:90 Connected: yes
    Failed to connect: org.bluez.Error.Failed
    quit
    Name: Samsung Galaxy S7
    Address: 50:9E:A7:7E:DF:90
    Icon: phone
    Class: 0x5a020c
    Paired: 1
    Connected: 1

    My phone is shown in green on the bluetooth page in Max2Play (note that it does not always come back green and sometimes instead of saying „Paired: 1“ and „Connected: 1“ it says „Paired: 1“ and „Connected: 0“. My phone is not connected even though bluetooth is on and it says „Your phone is currently visible to nearby devices“.

    I get a similar result for the BT speaker but it has always remained red on the M2P BT page. When M2P tries to connect with the speaker, my speaker says „Bluetooth connected“, then „Bluetooth disconnected“ and repeats this again, „Bluetooth connected, Bluetooth disconnected“.

    Any help will be greatly appreciated!

    Thanks,

    Andy

    25. März 2019 at 15:30 #44861

    Hi Andy,

    Thank you for the detailed report. We were able to recreate this issue here and are looking for a fix right now.

    Sorry about the inconvenience. We will keep you up to date in the main Bluetooth thread with our progress.

    25. März 2019 at 23:00 #44863

    Hello Heiner,

    Thanks very much for the quick reply. Is the „main Bluetooth thread“ this one: „[UPDATE] Bluetooth Addon BETA“? I am very eager to take advantage of the bluetooth connection; it greatly increases the flexibility of the system.

    Best regards,

    Andy

    26. März 2019 at 11:05 #44864

    Hi Andy,

    Yes it is. If you need want to use Bluetooth right now, you can install our legacy image based on Jessie which used the pulseaudio bluetooth solution. This still works but is not as great as the bluealsa. You can find the download in our legacy versions section.

    We hope to have a solution for the bluealsa bug ready by very soon, though.

    26. März 2019 at 16:24 #44874

    Thanks very much, Heiner,

    I’ll look over the Jessie image and decide whether or not I want to wait for a bluealsa solution.

    Best regards,

    Andy

    26. März 2019 at 16:37 #44875

    Hi Andy,

    If you have a second SD card or can easily back up your existing image, you can do it.

    However, we are currently working on this and hope to have a fix by the end of the week.

    27. März 2019 at 14:28 #44897

    Hi Andy,

    We just added the fix to our current beta. To get it working again, make a beta update, uninstall the Bluetooth plugin, install the Bluetooth plugin again and reboot.

    2. April 2019 at 23:02 #44953

    Hello,

    I have the same problem. I just have a Pi 3 (not a B+).
    I had this message :

    If you connected Bluetooth Speakers, make sure to set the soundcard of your audioplayers to bluetooth as audio output! You need to restart your Audioplayer if the Bluetooth Device changed.
    If you connected a Smartphone to stream to Squeezebox Server, NO further setting to your soundcard is needed (do NOT set your soundcard to bluealsa)!
    Device 84:CF:BF:8A:9F:7A Fairphone FP2
    trust 84:CF:BF:8A:9F:7A
    Changing 84:CF:BF:8A:9F:7A trust succeeded
    pair 84:CF:BF:8A:9F:7A
    Attempting to pair with 84:CF:BF:8A:9F:7A
    Failed to pair: org.bluez.Error.AlreadyExists
    connect 84:CF:BF:8A:9F:7A
    Attempting to connect to 84:CF:BF:8A:9F:7A
    Failed to connect: org.bluez.Error.Failed
    quit
    Name: Fairphone FP2
    Address: 84:CF:BF:8A:9F:7A
    Icon: phone
    Class: 0x5a020c
    Paired: 1
    Connected: 0 

    I made the Beta update and I still have the exact message and no connection with my phone (fairphone 2)

    Any idea what I can do to make it work?

    3. April 2019 at 11:16 #44956

    Hello gasuter,

    If possible please try burning a new image to rule out any dependencies from the previous install.

    Please follow these steps:

    – Burn new image
    – Activate license
    – Update to Beta
    – Install Bluetooth

    If the issue should persist, please post your debug info from bluetooth here.

    3. April 2019 at 16:19 #44961

    Hello,

    It’s working now, I have about 7 sec delay. Not good to watch a movie but for music it’s great.

    Thanks. =)))

    4. April 2019 at 10:03 #44963

    Seven seconds is tough, we usually experience about 1-3 seconds. You can try to improve your bluetooth signal by deactivating WiFi.

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.

Register here