Cannot change GPU memory setting

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Cannot change GPU memory setting

This topic contains 10 replies, has 4 voices, and was last updated by  Heiner Moderator 2 years, 9 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • 28. September 2017 at 18:41 #31599

    I have 3 Raspberry PI based systems. I can only change the GPU memory setting on one of them. On the others if I try to change the GPU memory then the only message displayed is reboot required, no message about changing settings, and indeed the setting does not change.

    The system on which it works was built using a v2.26 Max2Play image sourced from the HiFiBerry Installer app and updated to v2.44. The systems on which the setting does not work were built using a v2.44 image downloaded from Max2Play.

    In addition, on the Raspberry Settings page the CPU frequency setting has 2 drop down options on the box that works, and no options displayed on the other two boxes.

    What I did also notice in the DEBUG Information on the Raspberry Settings page is:

    For the system that works the final lines are
    =============================================================================================================================================
    # Additional overlays and parameters are documented /boot/overlays/README

    dtoverlay=hifiberry-digi
    gpu_mem=16
    =============================================================================================================================================

    And for the systems that do not work
    =============================================================================================================================================
    # Additional overlays and parameters are documented /boot/overlays/README

    # Enable audio (loads snd_bcm2835)
    dtparam=audio=on
    gpu_mem=128

    dtoverlay=hifiberry-digi
    =============================================================================================================================================

    Whether this has any bearing on the problem or not I do not know.

    29. September 2017 at 14:41 #31627

    Hi foz,

    I just tested the GPU setting on a new image and it worked right after reboot.

    What Raspberry Pi model do you use?

    The version 2.26 should still be based on Raspbian wheezy, another Debian source.

    However, my installation with 2.44 based on Raspbian Jessie lite saved the change to 16 right away after reboot.

    Could you share the complete debug info of your Raspberry Settings?

    29. September 2017 at 22:07 #31635

    Just reloaded from scratch on one of the boxes.

    Box is Raspberry PI 2 with HiFiBerry Digi+ connected via LAN

    1. Win32DiskImager to put m2p_rpi_default_244_wps_ap_expand.img to MicroSD card
    2. Insert card and reinsert power lead
    3. Login to http://max2play
    4. Select HiFiBerry from prompt window, driver installs
    5. Select Digi+ on HiFiBerry tab and save
    6. Switch to Raspberry Settings tab, no GPU memory size displayed, cannot see debug info
    7. Switch to Settings/Reboot tab
    8. Activate with email address
    9. Switch to Raspberry PI Settings tab, GPU memory reported as 128, DEBUG Information visible
    10. Change GPU ram setting from 128 to 16 and Save
    11. Reboot needed message displayed, but GPU ram setting reading 128 again
    12. Switch to Settings/Reboot tab
    13. Reboot
    14. GPU ram still set to 128

    DEBUG Information from Raspberry Settings
    =============================================================================================================================================
    #### BOOT CONFIG TXT ####
    # For more options and information see
    # http://rpf.io/configtxtreadme
    # Some settings may impact device functionality. See link above for details

    # uncomment if you get no picture on HDMI for a default „safe“ mode
    #hdmi_safe=1

    # uncomment this if your display has a black border of unused pixels visible
    # and your display can output without overscan
    #disable_overscan=1

    # uncomment the following to adjust overscan. Use positive numbers if console
    # goes off screen, and negative if there is too much border
    #overscan_left=16
    #overscan_right=16
    #overscan_top=16
    #overscan_bottom=16

    # uncomment to force a console size. By default it will be display’s size minus
    # overscan.
    #framebuffer_width=1280
    #framebuffer_height=720

    # uncomment if hdmi display is not detected and composite is being output
    #hdmi_force_hotplug=1

    # uncomment to force a specific HDMI mode (this will force VGA)
    #hdmi_group=1
    #hdmi_mode=1

    # uncomment to force a HDMI mode rather than DVI. This can make audio work in
    # DMT (computer monitor) modes
    #hdmi_drive=2

    # uncomment to increase signal to HDMI, if you have interference, blanking, or
    # no display
    #config_hdmi_boost=4

    # uncomment for composite PAL
    #sdtv_mode=2

    #uncomment to overclock the arm. 700 MHz is the default.
    #arm_freq=800

    # Uncomment some or all of these to enable the optional hardware interfaces
    #dtparam=i2c_arm=on
    #dtparam=i2s=on
    #dtparam=spi=on

    # Uncomment this to enable the lirc-rpi module
    #dtoverlay=lirc-rpi

    # Additional overlays and parameters are documented /boot/overlays/README

    # Enable audio (loads snd_bcm2835)
    dtparam=audio=on
    gpu_mem=128

    dtoverlay=hifiberry-digi

    =============================================================================================================================================

    30. September 2017 at 18:54 #31640

    Hi I have the same problem with the CPU frequency changes, won’t work…

    In the new beta version the GPU is changable and will be saved

    30. September 2017 at 18:55 #31641

    … in the beta version of max2play 🙂

    4. Oktober 2017 at 8:45 #31671

    Hi Song2,

    Thanks for notifying us, we will take a closer look.

    5. Oktober 2017 at 14:48 #31698

    Thanks for that Song2.

    Updated to Beta and GPU memory changed.

    23. November 2017 at 19:38 #32605

    Is this fixed yet in the current image download (rather than the beta)?

    28. November 2017 at 10:31 #32653

    Hi TJH,

    The fix will be included in the next version, 2.45, that will be released rather soon.

    For now, you can just make a beta update to change it.

    28. November 2017 at 14:38 #32674

    Thanks. I have done the beta update and the kernel has updated ok.

    Are kernel updates essential?

    29. November 2017 at 11:37 #32691

    Depends on the applications you want.

    Generally, Max2Play does not need manual kernel updates. If a change is necessary, it will usually be done with the setup you select (like when installing JustBoom sound cards).

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.

Register here