Cannot boot New RPI4B – "start4.elf is not compatible"

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Cannot boot New RPI4B – "start4.elf is not compatible"

This topic contains 1 reply, has 2 voices, and was last updated by  MarioM Moderator 2 weeks, 1 day ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • 11. Januar 2023 at 16:49 #52580

    Just got a new PI4B from Pimonori. 4GB. Firmware dated September 2nd 2020
    The bootloader version is dated 2022/04/26
    Boot from Max2play SD (Buster) fails with msg

    start4.elf is not compatible
    This board requires newer software
    Get the latest software from....

    I can boot ok from the supplied RPi software that came bundled.

    I tried the beta version 2.56 and it boots ok. Perhaps cut a new ‚production‘ version for new PI4 users?

    • This topic was modified 2 weeks, 2 days ago by  wilsodg.
    12. Januar 2023 at 14:30 #52583

    Hi wilsdog,

    Have you tested this with the 2.53 version from our download page? Because this version has an older kernel. The beta version 2.56 will soon fully replace the 2.53 so all current Pis should work with the image.
    When Pis are distributed that require newer firmware, we will again release a new version of the image that supports the latest kernels. However, it always takes a while until we can make sure that all Max2Play functions work with the newer kernel.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.

Register here