Brauche Hilfe ! Odroid XU4 Image auf emmc Installieren. Erledigt !

Max2Play Home 2016 (en) Forums Max2Play on ODROID U3/C1 Brauche Hilfe ! Odroid XU4 Image auf emmc Installieren. Erledigt !

Tagged: 

This topic contains 27 replies, has 5 voices, and was last updated by  Heiner Moderator 4 months, 4 weeks ago.

Viewing 28 posts - 1 through 28 (of 28 total)
  • 30. Dezember 2017 at 18:07 #33160

    Hallo,

    habe ein Problem und zwar bekomme ich keins eurer Images für den Odroid XU4 auf meiner eMMC zu laufen.
    Es kommt immer wieder beim starten „Freeing unused kernel memory: 420K“ und nichts weiter passiert. Habe das Problem auch schon beim Installieren von Ubuntu gehabt. Nachdem ich das flashen nicht mit Windows gemacht habe „hat nie geklappt weder mit Etcher noch mit Win32DiskImager-odroid-v1.3“ sonder mit Linux per:
    $ sudo dd if=<my/odroid/image.img> of=</dev/path/of/card> bs=1M conv=fsync
    $ sync
    hat es aber super geklappt nur das geht mit dem m2p Image auch nicht bekomme es einfach nicht zu laufen… wollte den Odroid XU4 als LMS Server laufen lassen und damit er meine anderen m2p geräte findet wollte ich auch euer Image installieren.

    Kann mir vieleicht jemand nen Tipp geben? Habe ja gelesen das es klappen soll ! Oder geht es nur auf eine SD Karte und nicht auf der eMMC ?

    Habe es auch mit einem emmc recovery versucht mit dem android sd2emmc. Android bootet Normal. Sobald ich jetzt eins der beiden m2p image rauf flash kommt wieder beim starten „Freeing unused kernel memory: 420K“.
    Sobald ich das Ordoid ubuntu-16.04.3-4.14-mate-odroid-xu4-20171212.img rauf flash geht es. Jetzt habe ich versucht Max2play über die Console zu installieren :
    wget https://raw.githubusercontent.com/max2play/webinterface/master/install_max2play.sh
    chmod 777 install_max2play.sh
    ./install_max2play.sh 2>&1 | tee install_max2play.log
    aber sobald ich per Web auf die IP Zugreife kommt nichts nur eine weiße Seite. Im Var/www/ Ordner ist alles wie in der Struktur hier:
    https://github.com/max2play/webinterface zu sehen vorhanden. Nur eine Index.html seite gibt es nicht. und die index.php im public Ordner gibt auch keine Seite wieder.

    Habs hin bekommen !
    Ich habe einfach das die Dateien vom Ordoid ubuntu-16.04.3-4.14-mate-odroid-xu4-20171212.img aus der Boot Patition genohmen und diese in die Boot Partition vom m2p-2.34-xu4-ubuntu-mate-16.img kopiert. Natürlich vorher die alten Dateien löschen !!
    Danach bootet das m2p Image bei mir ohne den Fehler „Freeing unused kernel memory: 420K“ !!
    Mal sehen ob alles Funktioniert !
    Für alle die nicht erst das Ordoid ubuntu-16.04.3-4.14-mate-odroid-xu4-20171212.img flashen wollen um an die Boot Dateien ran zu kommen habe ich Sie einmal Hochgeladen. Bitte Löschen falls nicht gewollt !
    http://www.share-online.biz/dl/B526JT1PG1

    • This topic was modified 7 months, 2 weeks ago by  Trax.
    • This topic was modified 7 months, 2 weeks ago by  Trax.
    • This topic was modified 7 months, 2 weeks ago by  Trax.
    5. Januar 2018 at 13:32 #33249

    Hi Trax,

    Entschuldige die späte Rückmeldung. Zwischen den Feiertagen sind einige Anfragen angefallen die ich leider noch nacharbeite.

    Ich freue mich, dass du selbst eine Lösung gefunde hast. Eigentlich sollte das M2P image auch automatisch auf einer EMMC booten. Wir werden das mal versuchen, nachzuvollziehen.

    5. Januar 2018 at 15:53 #33260

    Gleiches Problem bei mir: XU4 mit 64GB eMMC bootet nicht mit dem aktuellen m2p Image.
    Die Boot-Dateien von Trax lösen dieses Problem. Aber jetzt funktioniert der cifs-Mount auf das Musik-Verzeichnis meiner Diskstation (NAS) nicht mehr. NFS funktioniert auch nicht.
    Wie kann das gelöst werden?

    Danke & Gruß,

    5. Januar 2018 at 17:24 #33262

    Hi Trax,

    ich habe das gleiche Problem mit einer 64 GB eMMC. Mit Deiner Vorgehensweise kann ich booten und Max2Play läuft.
    Es gibt aber ein Problem mit dem Zugriff auf meine Musik auf dem NAS. Weder cifs noch nfs funktionieren. Der Logitech Media Server kann deshalb keine Musik finden.
    Da Du ja auch den LMS nutzen willst: Wie funktioniert es bei Dir? Falls Deine Musik auf dem ODROID lokal liegt, kannst Du bitte mal cifs ausprobieren?

    Danke & Gruß,

    8. Januar 2018 at 16:48 #33301

    Hi Metaman,

    Ich werde diese Woche mal ein neues Image auf eMMC versuchen zu booten um das Problem zu rekreieren.

    Beim Mounten musst du unbedingt Nutzer und Passwort beachten. Erstelle ggf. einen neuen Login für den Share den du mounten möchtest und versuche es damit einmal.

    8. Januar 2018 at 17:19 #33306

    Hallo Heiner,

    danke, dass Du Dich kümmerst.
    Mein m2p lief ja bereits problemlos von einer 32GB eMMC-Karte inkl. cifs auf mein NAS. D.h. user login und Kennwort haben funktioniert. NFS habe ich auch ausprobiert.
    Ich habe jetzt eine 64 GB eMMC gekauft, da der Logitech Media Server (LMS) „disk full“ gemeldet hat. Das bezieht sich nur auf die LMS-Datenbank, da meine Musik auf dem NAS liegt.
    Das Hauptproblem ist, wie Trax bereits festgestellt hat, dass das m2p Image nicht von der eMMC bootet. Die Boot-Dateien von Trax passen vermutlich nicht so richtig zum Rest des Betriebssystems, so dass cifs nicht mehr (richtig) funktioniert. Ich habe übrigens auch erfolglos die letzte Betaversion aus 2018 ausprobiert.

    Bitte stellt ein funktionierendes Image für XU4 zur Verfügung. Vielen Dank.

    11. Januar 2018 at 17:37 #33361

    Hallo Metaman,

    Bitte prüfe einmal, in welcher Formatierung die eMMC vorliegt. Dies ist ausschlaggebend, da zB eine Odroid U3 eMMC nicht ohne weiteres in einem XU4 läuft.

    11. Januar 2018 at 18:18 #33363

    Hallo Heiner,

    Wie prüfe ich die Formatierung?
    Ich habe Euer Image mit Etcher 1.21 unter macOS erstellt.

    12. Januar 2018 at 19:46 #33387

    Bootet immer noch nicht!

    Ich habe ein XU4 eMMC Bootloader Recovery durchgeführt; so wie beschrieben auf https://wiki.odroid.com/accessory/emmc/recovery_xu4
    Danach habe ich dann Euer m2p Image m2p-2.34-xu4-ubuntu-mate-16.img wieder mit Etcher aufgespielt. Das Festplattendienstprogramm zeigt mir dann 2 Partitionen an: eine mit ca. 130 MB (MBR) und eine mit dem Rest ca. 63 GB. Nach dem Einbau in den XU4 bootet dieser wieder nicht mit Eurem m2p Image.

    Die eMMC hat 64GB, ist eine orange Platine von Hardkernel und hat v0.4 und eMMC 5.1 Chipset von Samsung. Laut Hardkernel ist sie kompatibel mit dem XU4. Der Boot-Schalter steht auf eMMC. Mit meiner 32GB eMMC hatte das gleiche Image funktioniert: rote Platine von Hardkernel, v0.3, eMMC 5.0 Chipset von Sandisk.

    Könntet Ihr bitte etwas zügiger und ausführlicher antworten? Z.B. in der Art „bitte Format prüfen, wenn es A ist, dann tue bitte dies, wenn es B ist dann bitte auf Typ A umformatieren“ usw.. Also ein paar mehr Schritte angeben, sonst vergehen immer Tage, bis es weitergeht. Vielen Dank.

    15. Januar 2018 at 13:42 #33437

    Hallo Metaman,

    Entschuldige die Unannehmlichkeit. Ich hatte auch gehofft, das Thema früher schließen zu können 😉

    Da wir hier nur 8, 16 und 32 GB eMMC’s für unsere damalige Odroid-Entwicklung genutzt hatten, können wir leider auch nicht ausschließen dass das Problem mit der Größe zusammenhängt. Du kannst jedoch noch ein normales Ubuntu Image von Odroid brennen, um die eMMC selbst als Fehlerquelle noch auszuschließen.

    Falls noch nicht geschehen, könntest du außerdem den WinDiskImager von Odroid versuchen zu nutzen:
    http://com.odroid.com/sigong/blog/blog_list.php?bid=144

    15. Januar 2018 at 17:57 #33455

    Ich habe mit dem WinDiskImager das m2p image erstellt. Auch dann bootet m2p nicht. Wenn ich „nicht booten“ schreibe, meine ich immer, dass ich nicht auf m2p per Browser zugreifen kann und dass auch mein Router keine Verbindung (IP Adresse) anzeigt.
    Ich glaube nicht, dass die eMMC defekt ist, da das Schreiben und Lesen unter macOS möglich ist UND m2p auch bootet, wenn ich, wie Trax es beschrieben hat, die Boot-Dateien ersetze. Heute habe ich das selbe m2p Image nochmal auf die 32GB eMMC gebracht – das funktioniert.
    Ich denke, Ihr müsst das m2p Image aktualisieren (Oder bei den Systemanforderungen angeben, dass 64GB eMMC nicht funktionieren.)
    Könnt Ihr denn nicht Euer Image selber mit einer 64GB eMMC testen? Das wäre doch jetzt naheliegend.

    Aber vielleicht gibt es für mein ursrüngliches Probem (zu wenig Speicherplatz für die LMS Datenbank) mit der 32GB eMMC eine andere Lösung. Ehrlich gesagt, habe ich mich gewundert, dass die LMS-DB mehr als 32GB für die Metadaten benötigt. Gibt es eine Möglichkeit die Partitionen, die m2p anlegt, so aufzuteilen, dass der LMS den meisten Speicherplatz bekommt?

    • This reply was modified 7 months ago by  Metaman.
    • This reply was modified 7 months ago by  Metaman.
    16. Januar 2018 at 14:49 #33474

    Hi Metaman,

    Ein USB-Speicher oder Netzwerkspeicher für die LMS Dateien ist da wohl die idealste Lösung. Du kannst sogar dessen Datenbank-Pfad manuell in den LMS Einstellungen ändern 😉

    16. Januar 2018 at 15:21 #33478

    Hallo Heiner,

    danke für den Workaround-Tipp.
    Ich habe mich für Max2Play auf ODROID XU4 mit eMMC entschieden, weil ich einen schnellen LMS haben wollte, der eine zügige Navigation durch meine Musiksammlung erlaubt. Mit der 32GB eMMC war das auch der Fall. Wenn ich die LMS-DB (nicht die Musik) auf einen USB-Stick auslagere, habe ich die Befürchtung, dass es langsamer wird. Ausprobieren kann ich es zur Zeit nicht.

    Meine Fragen sind noch nicht beantwortet worden:
    1. Warum testet Ihr nicht selber die 64GB eMMC? Ihr verkauft sie doch, also „liegen sie bei Euch rum“ …
    2. Das m2P Image für Odroid muss verbessert werden (kein Booten bei Trax und mir). Wann passiert das?
    3. Wie kann ich das Partitionsschema auf der 32GB eMMC ändern, um mehr Platz für die LMS-DB zu bekommen?
    4. Mit dem Austausch der Boot-Dateien (gem. Trax, s.o.) funktioniert nfs und cifs nicht mehr. Gibt es dafür eine Lösung?

    Ich hoffe auf ausführliche Antworten.

    Danke & viele Grüße

    22. Januar 2018 at 14:02 #33586

    Hi Metaman,

    1. Wir haben vor über 3 Jahren eMMC-Karten mit unseren Images verkauft. Das war auch als Odroid-Images noch in unserer aktiven Entwicklung waren. Inzwischen sind wir wie bereits erwähnt komplett auf Raspberry Pi umgestiegen und bieten die Odroid Images weiterhin als Legacy-Versionen zum Download an.

    2. Alle Images für Odroid sind nicht mehr in der aktiven Entwicklung. Unser Fokus wechselte zu Raspberry vor einigen Jahren. Die Legacy Versionen sollten jedoch noch funktionieren. Hattest du versucht ein normales Ubuntu Image mit deiner eMMC zu testen, um ein Formatierungs- oder Hardwareproblem ausschließen zu können? Hardkernel’s eMMCs sind nicht alle kompatibel mit allen Odroid Boards.

    3. Ein normales Expandieren des Dateisystems sollte ausreichen.

    4. Vielleicht kann Trax dazu noch etwas sagen.

    22. Januar 2018 at 14:14 #33589

    Hallo Heiner,

    danke für die Antworten.

    1. Ich hatte bisher nicht mitbekommen, dass die Entwicklung von Max2Play für ODROID eingestellt worden ist. Schade. Der XU4 ist ja auch keine 3 Jahre alt und unter den normalen Downloads ist ODROID noch zu finden und eben nicht nur bei den Legacy-Versionen.

    2. Ja, Ubuntu funktioniert problemlos. Hardware-Revision der eMMC passt zum XU4. Leider kann ich die eMMC jetzt nicht mehr zurückgeben. Das ist ärgerlich.

    3. Das Expandieren hat nicht ausgereicht. Also ist die LMS-DB zu groß.

    4. Das war auch meine Hoffnung und ich hatte ihn ja weiter ober auch gefragt. Leider hat sich Trax nicht mehr gemeldet.

    Dann bleibt mir jetzt nur noch die Option die LMS-DB auf einen USB-Stick auszulagern. In ca. 2 Wochen kann ich das testen.

    22. Januar 2018 at 18:30 #33600

    Hallo Heiner,

    Du hattest geschrieben „Du kannst sogar dessen Datenbank-Pfad manuell in den LMS Einstellungen ändern“.
    Das würde ich gerne machen, finde aber hier im Forum und in den FAQ keinen Hinweis, wie das geht. Auch bei den SqueezeBox Einstellungen im Max2Play und im LMS selber finde ich sie nicht.

    Der Standard-Pfad für die Datenbabnk ist /var/lib/squeezeboxserver/cache/
    Wie lege ich den auf meinen USB-Stick (NO_LABEL in /mnt/extdrive (Device /dev/sda1 with UUID 6623-20DF)) ?

    Danke & Gruß

    25. Januar 2018 at 13:03 #33637

    Hallo Metaman,

    Das ist der Cache-Folder. Mein Bezug war auf Medien Folder. Dieser lässt sich direkt in den Basic Settings einstellen.

    25. Januar 2018 at 14:05 #33644

    Hallo Heiner,

    irdenwie reden wir hier aneinander vorbei. Ich fasse mein Problem nochmals zusammen.
    Die LMS-Datenbank ist zu groß für die eMMC 32GB-Karte. Dort liegen alle Metadaten zur Musik (Titel, Künstler, Länge, Cover, Genre, Codierung, usw.). Es geht nicht um meine Medien/Musik, die liegt wie bereits mehrfach geschrieben auf meinem NAS. Dein Lösungsvorschlag war, die Datenbank auf einen USB Stick auszulagern. Wo stelle ich das ein?

    In einer LMS-Installation unter Ubuntu liegt die LMS-DB standardmäßig auf diesem Pfad: /var/lib/squeezeboxserver/cache/. Falls das bei Max2Play anders ist, lass es mich bitte wissen.

    29. Januar 2018 at 10:19 #33713

    Entschuldige das Missverständis, ich dachte es läge an der Musikbibliothek. Den Pfad des Cache und der Preferences kannst du beide im Reiter Information in den LMS Einstellungen einsehen.

    29. Januar 2018 at 10:57 #33716

    Dein Lösungsvorschlag war, die Datenbank auf einen USB Stick auszulagern. Wo stelle ich das ein?

    30. Januar 2018 at 12:13 #33747

    Wie bereits erwähnt bezog ich mich auf eine andere Datenbank mit dem Tipp.

    Für LMS-spezifische Hilfe empfehle ich dir das slimdevices Forum.

    27. Februar 2018 at 13:23 #34095

    Hi Metaman

    Warum brauchst du M2P für dein LMS Server?
    Ich wollte auch ein schnelles LMS….deswegen habe ich einen einfachen Intel Nuc mit SSD genommen (Nuc ~100€ + SSD ~50€ + 2GB RAM). Ich habe Ubuntu 16LTS installiert und dazu LMS. Es funktioniert seit 3 Jahren, ich müsste nie wieder was machen….ist eine super lösung.
    Ich habe auch ein XU4 zuhause, die sind echt toll. Für LMS perfekt. Nimm doch das Ubuntu Image und installiere LMS.

    27. Februar 2018 at 14:05 #34096

    Hallo okenny,

    vielen Dank für Deinen Beitrag.
    Ich habe M2P genommen, weil ich keine Unix-/Linux-Kenntnisse habe. Ubuntu läuft auf XU4 mit 64GB eMMC, das habe ich probiert.
    Hast Du vielleicht eine Anleitung (einen Link) wie das ganze Setup des LMS unter Ubuntu funktioniert?

    Ich finde es echt ärgerlich, dass M2P die Version für Odroid nicht mehr weiterentwickelt und das auch noch verschweigt. Auch fehlt der Hinweis, dass 64 GB Speicherkarten nicht funktionieren.

    Viele Grüße

    27. Februar 2018 at 14:10 #34097

    hmmm…ich weiss nicht mwhr wie ich es installiert habe, ich schau mal im Netz. Ich glaube es war aber nicht so schwer.
    Noch eine Frage, du hast ein Synology – warum nicht auf dem NAS laufen lassen? Dafür gibts ein Plugin denke ich. (ich habe ein QNAP, damit würde es auch gehen).

    27. Februar 2018 at 14:36 #34098

    Ich habe ein Synology DS710+ mit LMS seit ca. 2010 im Einsatz. Mittlerweile ist es recht langsam geworden (die Musik wird ja auch nicht weniger). Ein vollständiger Scan der Musiksammlung dauert ca. 30 Stunden – auf dem Odroid waren es nur ca. 2,5 Stunden. Eine aktuelle Diskstation war mir zu teuer, deshalb hatte ich im August auf Odroid mit M2P gewechselt. Jetzt läuft der LMS wieder auf der Diskstation (Rescan ca. 45 Minuten).

    27. Februar 2018 at 14:43 #34099

    ok, ja, NAS sind teuer. Mein NAS hat ein i7 CPU, ich habe nur mit der Stromrechnung Probleme 😉

    Anleitung für Install auf Ubuntu/Debian ist hier: http://support.logitech.com/en_gb/article/17011#debian

    12. März 2018 at 20:39 #34358

    Hello user on UX4
    I’m having the same problems.
    I can’t install thanks to give me an installable version on emmc 32gb.
    I have an active license and purchased a special ux4 to dedicate a LMS server and I can’t install a max2play image.
    I’m not really satisfied with this unreported problem!
    thank you for giving me a solution

    19. März 2018 at 12:49 #34518

    Hi fourchtein,

    What exactly are you not able to install and which version of Max2Play are you using?

    Sorry about the late response. By writing in a topic where the creator already added „Erledigt!“ („solved“ in German), I was not able to recognize your new request quickly enough.

Viewing 28 posts - 1 through 28 (of 28 total)

You must be logged in to reply to this topic.

Register here