Bluetooth Receiver – Devices pair but do not connect

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Bluetooth Receiver – Devices pair but do not connect

Tagged: 

This topic contains 3 replies, has 3 voices, and was last updated by  Heiner Moderator 3 weeks, 4 days ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • 15. Oktober 2018 at 15:15 #38621

    I am having an issue connecting bluetooth devices to play audio through the HIFIBerry Dac. Here is my debug error.

    Hardware: Raspberry PI Zero W
    HiFiBerry

    #### Bluetooth Installation ####

    #### Bluetooth Dongle ####
    hci0: Type: Primary Bus: UART
    BD Address: B8:27:EB:74:4C:FF ACL MTU: 1021:8 SCO MTU: 64:1
    UP RUNNING
    RX bytes:731 acl:0 sco:0 events:44 errors:0
    TX bytes:1755 acl:0 sco:0 commands:44 errors:0

    #### BLUEALSA ERROR ####
    ● bluealsa.service – Start Bluealsa for Bluetooth on Alsa (not compatible with Pulseaudio)
    Loaded: loaded (/etc/systemd/system/bluealsa.service; enabled; vendor preset: enabled)
    Active: activating (auto-restart) (Result: signal) since Fri 2018-10-12 07:29:22 CEST; 2s ago
    Process: 6169 ExecStart=/usr/bin/bluealsa -p a2dp-sink -p a2dp-source (code=killed, signal=ILL)
    Process: 6168 ExecStartPre=/bin/sleep 2 (code=exited, status=0/SUCCESS)
    Main PID: 6169 (code=killed, signal=ILL)

    Oct 12 07:29:22 max2play systemd[1]: bluealsa.service: Failed with result ’signal‘.

    16. Oktober 2018 at 9:56 #38632

    Hi Tim,

    Do you have the Bluetooth plugin’s output selected for HiFiBerry DAC+?

    Do you have a new stretch image?

    Please make a update of all packages at the bottom of the Raspberry Settings.

    23. Oktober 2018 at 6:46 #38718

    I had the same error on Raspberry Pi 1 Mod. B with Raspbian Stretch and newest Kernel.

    I did the following:

    sudo apt-get update
    sudo apt-get install -y libasound2-dev dh-autoreconf libortp-dev bluez pi-bluetooth bluez-tools libbluetooth-dev libusb-dev libglib2.0-dev libudev-dev libical-dev libreadline-dev libsbc1 libsbc-dev
    git clone https://github.com/Arkq/bluez-alsa.git
    cd bluez-alsa
    autoreconf --install
    mkdir build && cd build
    ../configure --disable-hcitop --with-alsaplugindir=/usr/lib/arm-linux-gnueabihf/alsa-lib
    make && sudo make install

    After that bluealsa was running and i could establish the bluetooth connection to my bluetooth speaker.

    • This reply was modified 3 weeks, 4 days ago by  preslmayer.
    23. Oktober 2018 at 12:43 #38790

    Hi Preslmayer,

    A simple click on the apt-get button in our Raspberry Settings will also suffice.

    However, we will also launch a new version with the newest packages very soon to make sure nobody can be affected in the future.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Register here