Bluetooth-Plugin Lautsprecher kein Ton – Raspberry PI 4 2GB + Bose Soundbar 500

Max2Play Home 2016 (en) Forums Max2Play Add-ons Bluetooth-Plugin Lautsprecher kein Ton – Raspberry PI 4 2GB + Bose Soundbar 500

Tagged: 

This topic contains 8 replies, has 2 voices, and was last updated by  PaJo premium 1 month ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • 12. Dezember 2022 at 10:25 #52519

    Hallo liebes Max2Play Support Team,

    vielen Dank für all die hilfreichen Tipps und Antworten die ich bei euch im Forums schon gelesen habe.
    Allerdings komme ich bei diesem Problem nicht weiter und auch die Threads die ein ähnliches Problem beschreiben haben mir nicht weitergeholfen.

    Zu meinem Problem

    Ich habe ein LMS im Einsatz und bereits einen Raspberry PI 4 2GB mit AMP2. Da ich jetzt nach und nach mein Multiroom Setup umsetzen möchte, wäre als nächstes meine Bose Soundbar 500 dran. Diese möchte ich über einen zusätzlichen Raspberry 4 2GB mit M2P über Bluetooth verbinden.

    Wie beim anderen PI möchte ich Squeezelite als Player nutzen und den Neuen über LMS ansprechen können. Der Player taucht auch in der Liste auf.

    Wenn ich jetzt Audio abspiele dann läuft die Wiedergabe ab, nur ohne Ton. Ich habe die Lautstärken voll aufgedreht ohne einen einzigen Ton zu hören. Verbindungung zur Soundbar mit Telefon funktioniert ohne Probleme. Auch bei anderen Bluetooth Lautsprecher oder Headset das gleiche Problem.

    Audio kommt über die Klinkenbuchse aus dem PI wenn ich diesen auswähle (sysdefault – bcm2835 headset).

    Ich habe das Tutorial durchgeführt und kann auch wunderbar die Bluetooth-Geräte verbinden.
    Es läuft auch kein anderer Bluetooth Prozess (Stream 2 Max2Play oder Stream 2 Squeezebox)

    Max2Play habe ich bereits erneut installiert und auch das Bluetooth Plugin. Lizenz ist aktiviert

    Ich habe auch beide Images versucht und aktuell ist die Beta drauf. BETA version for all Raspberry Pi models including Pi Zero (Buster)

    Hier die Debug-Infos aus den Bluetooth Settings:

    [Grüne Box]
    Einstellungen & Hardware
    Bluetooth-Dongle: verfügbar
    Bluealsa Running: 1

    ———-
    #### Bluetooth Installation ####
    #### Bluetooth Dongle ####
    hci0: Type: Primary Bus: UART
    BD Address: E4:5F:01:EB:4A:5B ACL MTU: 1021:8 SCO MTU: 64:1
    UP RUNNING PSCAN
    RX bytes:57922 acl:490 sco:0 events:3823 errors:0
    TX bytes:1713209 acl:5770 sco:0 commands:461 errors:0

    #### DEVICE Wohnzimmer ####
    spawn /usr/bin/bluetoothctl
    Agent registered
    [0;94m[Wohnzimmer][0m# info C8:7B:23:6D:96:7B
    Device C8:7B:23:6D:96:7B (public)
    Name: Wohnzimmer
    Alias: Wohnzimmer
    Class: 0x002c0414
    Icon: audio-card
    Paired: yes
    Trusted: no
    Blocked: no
    Connected: yes
    LegacyPairing: no
    #### BLUEALSA RUNNING ####
    1
    ——-

    Hier die Debug-Infos von den Audioplayer Settings:

    #### SQUEEZELITE VERSION ####
    Squeezelite Max2Play v1.0.3 based on v1.8.7-999, Copyright 2012-2015 Adrian Smith, 2015-2017 Ralph Irving.
    #### SQUEEZELITE BUILDOPTIONS ####
    Build options: LINUX ALSA EVENTFD RESAMPLE FFMPEG VISEXPORT IR GPIO DSD CONTROLSBS ALSASYNC BLUETOOTHSYNC
    #### AUDIOPLAYER CONFIG ####
    ### Configuration of Audioplayers
    SQUEEZELITE_PARAMETER=-o plug:bluetooth -a 80:4:: -B
    SQUEEZESLAVE_PARAMETER=-n plugequal
    SHAIRPORT_PARAMETER=-d plug:bluetooth -B
    USE_USB_DAC=0
    USE_EQUALIZER=0
    SYSTEM_USER=pi
    BLUEALSA_PLAY_AUDIOCARD=hw:0,0
    GMEDIARENDERER_ALSA_DEVICE=plug:jack
    #### SQUEEZELITE -l ####
    Output devices:
    null – Discard all samples (playback) or generate zero samples (capture)
    jack – JACK Audio Connection Kit
    pulse – PulseAudio Sound Server
    equal
    plugequal – Equalizer for plughw:0,0
    bluetooth – Your Bluetooth device C8:7B:23:6D:96:7B
    default:CARD=Headphones – bcm2835 Headphones, bcm2835 Headphones – Default Audio Device
    sysdefault:CARD=Headphones – bcm2835 Headphones, bcm2835 Headphones – Default Audio Device
    dmix:CARD=Headphones,DEV=0 – bcm2835 Headphones, bcm2835 Headphones – Direct sample mixing device
    dsnoop:CARD=Headphones,DEV=0 – bcm2835 Headphones, bcm2835 Headphones – Direct sample snooping device
    hw:CARD=Headphones,DEV=0 – bcm2835 Headphones, bcm2835 Headphones – Direct hardware device without any conversions
    plughw:CARD=Headphones,DEV=0 – bcm2835 Headphones, bcm2835 Headphones – Hardware device with all software conversions
    usbstream:CARD=Headphones – bcm2835 Headphones – USB Stream Output

    #### SHAIRPORT (SYNC) VERSION ####
    3.3.1-OpenSSL-Avahi-ALSA-soxr-sysconfdir:/usr/local/etc
    #### OUTPUT SOUND DETAILS CARD 0 ####
    closed
    #### OUTPUT SOUND DETAILS CARD 1 ####

    Vielen Dank im Voraus für eure Unterstützung.

    Mit freundlichen Grüßen
    Patrick Jonas

    13. Dezember 2022 at 11:13 #52520

    Hallo Patrick,

    du scheinst erstmal alles richtig gemacht zu haben, die Debug Infos sehen auch normal aus. Hast du dich an unsere Anleitung im Wiki gehalten? Falls ja, sollte Bluetooth ohne Probleme funktionieren. Ich habe das Ganze auch gerade nochmal mit unserem Beta-Image erfolgreich getestet.

    Hast du Squeezelite und ggf. auch den Server nach der Installation vom Bluetooth Plugin neu gestartet? Könntest du zum Testen den Server auch auf dem Pi installieren, der mit der Soundbar verbunden ist und darüber die Wiedergabe starten?

    14. Dezember 2022 at 21:09 #52525

    Guten Abend Mario,

    meine letzte Antwort von gestern wird merkwürdigerweise nicht angzeigt.

    Genau ich habe mich an die Anleitung gehalten. Das Plugin auch über den Download-Link hinzugefügt und Bluetooth installiert. Squeezebox Server habe ich auf dem PI installiert. Hier ebenfalls kein Ton zu hören der PI mit dem AMP2 lässt sich aber ansprechen und spielt Ton.

    Ich habe als Test dann auch noch auf dem anderen PI welcher den AMP2 hat, das BT-Plugin installiert. Alles nach Anleitung dann auch umgestellt. Erbebnis ist das Selbe.

    Vielleicht relevante Informationen:

    Squeezebox Server Nightly Version 8.4
    Über die Spotify App kann ich den PI mit dem Bluetooth Setup auswählen, aber ebenfalls kein Ton. Daher würde ich hier erstmal den LMS ausschließen und eher auf den Audioplayer oder irgendeine interne Einstellung tippen. Lässt sich hier etwas über die Kommandozeile prüfen? Wenn ich mich recht erinnere hatte jemand etwas ähnliches geschrieben.

    Bose App: Hier sehe ich auch das die verbundene Bluetooth-Quelle gerade streamt und der Status ist durch den Play/Pause Button erkennbar.
    Auch in der Alexa-App sehe ich das der alte DOT mit dem PI verbunden ist.

    VG
    Patrick

    15. Dezember 2022 at 13:16 #52527

    Hi Patrick,

    hast du das Bluetooth Plugin von unserer Pluginseite installiert oder einfach das Bluetooth Plugin aus der Liste der inaktiven Plugins in die Liste der aktiven verschoben? Es besteht die Möglichkeit, dass die Version auf unserer Pluginseite nicht die aktuellste ist und es deswegen zu Fehlern kommt. Bitte versuche folgendes: Brenne das aktuellste Max2Play Buster Image auf eine SD-Karte, starte den Pi, verschiebe das BT-Plugin in die aktiven Plugins und speichere die Pluginkonfiguration, installiere Bluetooth und starte dann das Gerät neu. Verbinde deinen BT-Lautsprecher und ändere die Soundausgabe in Squeezelite zu bluetooth. Versuche dann die Wiedergabe über den Sqeezebox Server zu starten.

    18. Dezember 2022 at 3:20 #52537

    Guten Morgen,

    ich habe jetzt noch ein paar Stunden ausprobiert aber ohne positiven Ergebnis. Beide PIs habe ich jetzt noch einmal komplett aufgesetzt und dabei deine Schritte befolgt, dabei auch die neuste Buster Image verwendet. Bluetooth ist und bleibt auch verbunden, Player spielt aber kein Ton ist zu hören. Den AMP2 habe ich jetzt auf den Neuen PI getan. Das funktioniert alles wie zuvor.

    Vielleicht auch noch eine nützliche Info, ein PI hat die REV 1.4 und der Neue die REV 1.5.

    Gibt es irgendwelche Preconditions die ich vielleicht übersehen habe?
    Über die Raspberry Einstellungen habe ich unten auch schon den Knopf gedrückt zum updaten der Packages.

    Hat Bluetooth einen eigenen Mixer? Über Klinke hatte ich ja Ton.

    VG
    Patrick

    • This reply was modified 1 month, 1 week ago by  PaJo.
    20. Dezember 2022 at 14:47 #52547

    Hi Patrick,

    an der Version des Pi sollte es eigentlich nicht liegen. Und wenn du bereits mehrere BT Lautsprecher erfolgreich verbunden hast und bei allen kein Ton kommt, dann solltest du auch grundsätzlich alles richtig gemacht haben. Hast du testweise auch mal die Option -B aus den erweiterten Optionen entfernt? Vielleicht gibt es da einen Bug.
    Die Packages brauchst du nicht aktualisieren. Das führt tendenziell eher zu Fehlern, als wenn du unser Standard Image verwendest.

    Ich kontaktiere nochmal unseren Entwickler, vielleicht hat er ja eine Idee. Eigentlich sollte die Bluetooth-Lautstärke auch über den alsamixer gesteuert werden können. Allerdings wurde mir das bei meinem Testgerät nicht angezeigt.

    Du könntest trotzdem mal probieren per SSH oder unser Remote Control Plugin auf den Pi zuzugreifen und alsamixer in der Konsole einzugeben. Dann per F6 das Gerät zu „bluetooth“ wechseln (falls dir das angezeigt wird).

    20. Dezember 2022 at 18:45 #52548

    Hi Mario,

    die Option -B hatte ich schon rausgenommen und jetzt auch noch einmal. Ich nutze das Plugin von euch, aber bluetooth wird nicht angezeigt, auch nicht wenn ich über „enter device name“ es versuche.

    Ich sehe mit F6 nur diese Optionen

    Sound Card
    – (default)
    0 bcm2835 Headphones
    enter device name…

    VG
    Patrick

    22. Dezember 2022 at 16:55 #52549

    Da das Problem bei keinem unserer Testgeräte reproduzierbar ist und auch sonst kein Nutzer bislang diese Probleme hatte, kann ich dir nur eingeschränkt helfen. Ich könnte mir noch vorstellen dass irgendein Codec nicht unterstützt wird oder bei dem Lautsprecher selbst eine Einstellung vorgenommen werden müsste. Das können wir allerdings nicht debuggen.

    23. Dezember 2022 at 12:07 #52553

    Moin,

    meine Antwort ist leider verschwunden. Hat das mit der Downtime zu tun?
    Dann noch einmal….

    Ich habe es jetzt geschafft mit der Beta und selber ein paar Einstellungen von der Bluealsa GitHub-Seite zwei BT Lautsprecher mit Ton zu verbinden.
    Es laufen jetzt der Echo Dot und die Jabra Elite 85h Kopfhörer.

    Allerdings kann ich mir nicht vorstellen das es am Codec oder an den unterstützten BT Profilen liegt.
    Bose unterstützt leider nur SBC aber aus meiner Sicht sollte das funktionieren, denn der Echo Dot kann eben auch nur SBC und das läuft. Daher kann das daran nicht liegen.

    Was genau zum Erfolg geführt hat kann ich nicht sagen. Mit apt-get update/upgrade/autoremove hat der schon eine Weile gearbeitet.
    Vielleicht habe ich nach Weihnachten noch einmal Lust dazu den entscheidenen Schritt herauszufinden, aber wahrscheinlich nicht. Der PI wird dann im nächsten Raum eingesetzt. Für die Soundbar habe ich eine funktionierende Alternative gefunden. Die Soundbar lässt sich über Ethernet anschließen und unterstützt Airplay. Beim LMS habe ich jetzt die AirPlay Bridge laufen und das funktioniert wunderbar.

    Erstmal vielen Dank für die Unterstützung und ein Frohes Fest und einen Guten Rutsch an das ganze M2P-Team.

    VG
    Patrick

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.

Register here