Bitte um Anleitung wie man die NAS Platte einbindet für Logitech Server

Max2Play Home 2016 (en) Forums Max2Play as Squeezebox (Player / Server) Bitte um Anleitung wie man die NAS Platte einbindet für Logitech Server

This topic contains 6 replies, has 2 voices, and was last updated by  ogeifel premium 6 months, 1 week ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • 1. April 2021 at 9:47 #51067

    Sehr geehrte Damen und Herren,

    da ich kein Englisch kann, und dies hier eine Deutsche Firma ist, gehe ich davon aus das man auch in Deutsch schreiben kann.

    Auf meinem Synology läuft der Logitech Server nicht mehr. Und wird nicht mehr unterstützt. Daher habe ich in mühevoller Arbeit die SD Karte mit der neuen Version von Max2Play beschrieben, da ein Update nicht funktionierte, und dann dort den Logitech Server installiert.
    Dort konnte ich schonmal die Radiosender installieren.

    Aber ich kann meine NAS Festplatte nicht sehen. Im Internet habe ich raus gefunden das man die NAS Platte irgendwie „Mounten“ muß. Was auch immer das ist.

    Da gibt es ja so einen Punkt mit Mount in Ihrer Software.

    Aber wie geht das jetzt? Was muß ich exakt, wie und wo einstellen das das funktioniert?
    Ich benötige bitte eine exakte Anleitung dafür. Und bitte nichts in Englisch. Das versteht ich nicht.

    Bitte um Hilfe.

    Mit freundlichem Gruß
    Oliver Gottfried

    1. April 2021 at 13:37 #51068

    Hallo Oliver,

    Wenn der Ordner auf deinem NAS für das Netzwerk freigegeben ist, musst du nur noch ein paar Einstellungen in Max2Play vornehmen, um über den Server auf die Dateien zugreifen zu können. Zunächst im „Dateisystem Mount“ Plugin:

    1. Um den Ordner hinzuzufügen, musst du unter dem ersten Menüpunkt „Dateisystem – Verbinde Netzwerk Pfad (Samba or NFS)“ einen Mountpoint anlegen.
    2. Gib dazu im ersten Textfeld die IP-Adresse deines NAS und den Ordnernamen deiner Freigabe in dieser Form an: //192.168.1.100/share „share“ ist hier ein Beispiel für den Ordnernamen. Wenn du zum Beispiel einen Ordner auf deinem NAS hast, der „Musik“ heißt, müsste hier „/Musik“ stehen. Achte aber darauf, dass es sich hier um eine Pfadangabe handelt. Einen Unterordner müsstest du nach diesem Schema angeben: „/Oberordner/Unterordner/UnterUnterOrdner“. Falls die Freigabe später nicht klappen sollte, kannst du dir auch über den blauen Button „Netzwerk Geräte anzeigen“ alle Freigaben im Heimnetz anzeigen lassen und auswählen.
    3. Im zweiten Textfeld muss nun der Ordnerpfad im Dateisystem deines Raspberry Pi angegeben werden, über den du am Ende auf deine Musik zugreifen möchtest. Dieser muss entweder im Verzeichnis /mnt oder /media liegen. Nutze also am besten einfach den vorgegebenen Pfad /mnt/share
    4. Im nächsten Textfeld trägst du cifs ein.
    5. Im letzten Feld muss folgendes stehen: user=name,password=pass,iocharset=utf8,_netdev wobei du „name“ mit dem Benutzernamen und „pass“ mit dem Passwort für deinen NAS-Login ersetzt.
    6. Klicke jetzt auf Speichern. Nun sollte der Mountpoint erfolgreich hinzugefügt sein.
    7. Gehe nun zur Squeezebox Server Oberfläche.
    8. Klicke unten rechts auf Einstellungen. Gib im Feld „Medienordner“ den Pfad ein, den du in Schritt 3 verwendet hast. (also z.B. „/mnt/share“)
    9. Klicke nun unten rechts auf Übernehmen.
    10. Falls der Server nun nicht schon von selbst den Ordner nach Medien durchsucht, kannst du die Durchsuchung mit einem Klick auf „Durchsuchung starten“ beginnen.
    11. Nach der Durchsuchung sollte deine Musik vom Server erkannt worden sein. Über den Menüpunkt „Eigene Musik“ in der Squeezebox Server Oberfläche solltest du jetzt auf deine Musik zugreifen können.

    1. April 2021 at 14:44 #51069

    Hallo MarioM,

    herzlichen Dank für Deine Hilfe. Leider funktioniert jetzt, mal wieder, nichts mehr nachdem ich gestern bevor ich aufgehört habe den Schreibschutz aktiviert habe. Den Schreibschutz habe ich VOR dem eintragen natürlich wieder entfernt. Aber wie zuvor auch schon stürzt die Software beim Neustart komplett ab.

    Zum einen steht jetzt noch irgendwas in diesem Mount was ich nicht eingetragen habe. Und löschen lässt der Eintrag sich auch nicht. Dann stürzt alles ab und ich muß den Strom ziehen.
    Und zum anderen komme ich jetzt plötzlich nicht mehr auf die Weboberfläche von dem Logitech Server drauf. Gestern war das kein Problem.

    Hab gestern fast 2 Stunden damit verbracht die SD Karte irgendwie zu resetten und auf normal zu formatieren da Ihre Software ja keine Ahnung was bei dem Brennen damit macht. Und jetzt schon wieder so ein Mist.

    Hat jetzt 6 Jahre gehalten und nun nur Probleme. Naja immer wenn ich was eingestellt hatte war das Problem ja mit dem Schreibschutz und neustarten ja von anfang an. Aber ich muß das ja machen weil ich den Strom abschalte der ganzen Anlage wenn die nicht benutzt wird.

    Haben Sie eine Idee was ich jetzt machen kann das es funktioniert? Oder muß ich wieder Stundenlang alles neu machen?

    Gruß
    Oliver Gottfried

    P.S.: Leider kann ich kein Bild hier einfügen. Sonst hätte ich Ihnen den Eintrag gezeigt.
    Da steht #, use, dphys, swap on off

    • This reply was modified 6 months, 2 weeks ago by  ogeifel.
    6. April 2021 at 15:29 #51081

    Hallo Oliver,

    Es tut uns sehr leid, dass Ihnen Max2Play so lange Probleme gemacht hat. Unser Schreibschutz Plugin hat in der Vergangenheit schon mehrfach zu ähnlichen Problemen geführt: Immer dann, wenn Dienste, wie etwa der Squeezebox Server, zwingend notwendige Schreibprozesse initiieren und der Schreibschutz diese verhindert. Ich würde Ihnen daher empfehlen vorübergehen auf das Plugin zu verzichten und zu schauen, ob es damit besser läuft. Um die SD-Karte nicht zu beschädigen wäre es darüber hinaus gut, wenn Sie den Pi vor dem Trennen des Stroms über das Max2Play Webinterface oder einen SSH-Befehl herunterfahren.
    Um möglichst schnell und unkompliziert ein frisches Max2Play Image auf die SD-Karte zu brennen, schließen Sie die SD-Karte über einen USB Kartenleser an den PC an, formatieren Sie die SD-Karte und brennen dann mit einem Brennprogramm wie balenaEtcher das aktuelle Buster Image auf die Karte.

    7. April 2021 at 7:45 #51090

    Hallo MarioM,

    danke für Ihre Antwort. Aber das ist natürlich blöd. Ich kann den Max2Play nicht herunterfahren da ich dann jedesmal einen PC anmachen müßte um dann darauf zuzugreifen um Herunterzufahren. Das ist vollkommen Sinnfrei da das Gerät halt an der Anlage angeschlossen ist und keine Verbindung zu einem PC hat.
    Ich steuere das Gerät bisher mit dem Handy als Player. Und von einem SSH kenne ich nichts.
    Bisher lief der Logitech Server ja auf dem NAS. Aber da wird er nicht mehr unterstützt und läuft nicht mehr. Daher wollte ich den Server auf dem Max2Play nutzen.

    Also müßte ich jetzt schon wieder alles neu machen damit ich den einrichten kann? Umständlich wieder die SD Karte löschen, und nein Formatieren reicht nicht! Das sollte Sie selbst ja wohl wissen. Ich kann die nicht mit Ihrem Programm neu brennen da ich vorher kompliziert alle „Partitionen“ löschen muß damit das funktioniert. Erst dann kann ich das neu brennen. Das dauert aber alles ewig. Anders geht das einfach nicht. Sonst wird die SD Karte gar nicht mehr erkannt und es wird noch komplizierter.
    Dann muß ich wieder umständlich ein LAN Kabel anschließen und wieder umständlich das Ding dazu bekommen sich mit dem WLAN zu verbinden.
    Das ist, mit allem Respekt gesagt, Bockmist. Einfach extrem umständlich für jemanden wie mich der so gut wie keine Ahnung von dieser Materie hat. Darum war ich froh das das jetzt Jahrelang lief ohne diesen hantier.

    So aber was ist den jetzt wenn ich alles eingestellt habe? Also Es läuft jetzt wieder. Diesmal MIT Logitech Server. Kann ich dann den Schreibschutz aktivieren? Oder geht das nicht da der Server, jedesmal wenn er auf dem NAS Musik neu findet, diese neu schreiben muß?

    Ich bin, wie Sie merken, genervt von diesem Problem. Kann jetzt seit Tagen keine Musik mehr vom NAS oder aus dem Internet hören deswegen. Und so einfach ist es nicht alles immer neu zu machen wie ich bereits sagte.

    Desweiteren ist mir jetzt, bei diesem Problem aufgefallen das Sie meine Lizenz anscheinend geändert haben. 2015 habe ich eine Lebenslange Lizenz gekauft. Dies war auch so im Max2Play zu sehen. Nun aber steht das die Lizenz 2025 abläuft. Klasse sache. Davon wurde mir nie was berichtet. Und das war beim Kauf anders. Aber richtig ist das nicht!

    Wäre toll wenn Sie mir helfen und die Fragen noch beantworten. Wenn nicht dann muß ich mir was anders suchen. Bin sauer.

    7. April 2021 at 17:29 #51101

    Hallo Oliver,

    wir verstehen Ihre Unzufriedenheit und versuchen natürlich, Ihnen bestmöglich zu helfen. Ich bin auch sicher, dass wir eine Lösung finden werden.

    Zunächst was das Herunterfahren angeht: Sofern Ihr Max2Play-Gerät mit dem Internet verbunden ist, können Sie mit jedem Gerät im gleichen Netzwerk darauf zugreifen, etwa mit einem PC oder mit Ihrem Handy. Sie können so also auch die Max2Play Weboberfläche über das Smartphone aufrufen und das Gerät herunterfahren (Reiter Einstellungen/Reboot –> Button „Herunterfahren“). Ansonsten gibt es auch die Möglichkeit Max2Play-Geräte über einen physischen Schalter oder einen SSH-Befehl auszuschalten. Max2Play Plugins dazu finden Sie hier:

    Power-Button Plugin: https://www.max2play.com/portfolio/plugin-power-button/
    Remote-Control Plugin: https://www.max2play.com/portfolio/plugin-remote-control-2/

    Ansonsten finden Sie weitere Informationen zur Montage von Schaltern am Raspberry Pi online in Magazinen wie PC-Welt oder heise. Dort finden Sie auch Anleitungen, wie Sie per SSH auf den Pi zugreifen können.

    Sofern Ihr System aktuell fehlerfrei läuft, würde ich Ihnen empfehlen den Schreibschutz nicht wieder zu aktivieren, da ansonsten nicht garantiert werden kann, dass der Squeezebox Server ordnungsgemäß funktioniert. Es gibt generell verschiedene Nutzungsszenarien von Max2Play, sodass manche unserer Plugins, wie etwa der Schreibschutz, nicht für jeden Anwendungsfall geeignet sind. Da wir uns im Do-it-Yourself-Audio-Bereich befinden und viele unserer Kunden individuelle Lösungen suchen, können wir nicht jeden Schritt begleiten. Daher versuchen wir unseren Kunden in erster Linie Hilfestellungen zu geben, das Problem selbst zu lösen.

    Falls weiterhin Probleme, die wahrscheinlich durch den Schreibschutz verursacht werden, auftauchen sollten, würde ich sehr dazu raten, die SD-Karte frisch zu formatieren. Ich fürchte, dass das System in diesem Fall so beschädigt ist, dass es ohne einen kompletten Neustart nicht mehr richtig funktioniert. Sie können im Vorfeld auch ein Backup Ihres Systems mit unserem Imageburner Plugin anlegen, damit Sie im Zweifelsfall keine Einstellungen verlieren.
    Ich hoffe ich kann Ihnen den Formatierungsprozess hiermit noch etwas erleichtern: Um die Partitionen auf der SD-Karte (an einem Windows PC) zu löschen, Drücken Sie die Tasten Windowstaste und R, um das „Ausführen“-Fenster zu öffnen. Geben Sie dort anschließend „diskmgmt.msc“ ein und Klicken Sie auf OK. Scrollen Sie dann im Fenster Datenträgerverwaltung nach unten zu Ihrer SD-Karte. Mit Rechtsklick und „Volume löschen“ können sie die einzelnen Partitionen (sollten insgesamt 3 sein) löschen. Anschließend sollten Sie das Image wieder auf die SD-Karte brennen können.

    Bezüglich Ihrer Premium-Lizenz:
    Selbstverständlich bleibt Ihnen die volle Laufzeit Ihrer Lizenz erhalten. Bitte schreiben Sie uns diesbezüglich eine Mail an [email protected], damit wir das lösen können.

    8. April 2021 at 12:24 #51106

    Hallo,

    jetzt habe ich alles wieder neu gemacht.

    Und jetzt funktioniert der Mount nicht.

    ount error(2): No such file or directory Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
    Hinzufügen nicht möglich! Bitte Anleitung beachten!

    Hat ja vor einigen Tagen mit EXAKT denselben einstellungen geklappt. Dafür war ja alles andere hinüber nachdem ich den Schreibschutz genutzt hatte.
    Aber ich hab es jetzt Satt.
    Ich habe keine Zeit und keine Lust jedesmal 3-4 Stunden hier an Ihrer Software rumzufummeln das es klappt. SD Karte neu beschreiben was leider aufgrund geringer Kenntnisse im schnitt eine Stunde bei mir dauert. Das beinhaltet ja auch 10m lankabel einstecken und mit der Fritzbox verbinden um irgendwann mal eine Verbindung mit dem Wlan zu bekommen. Funktioniert in der Regel aber erst nach 3 Versuchen mit immer wieder Stromziehen etc. da Ihre Software sonst nichts findet. Und dann noch alles andere rumfummeln was aber, wie man gerade sieht, vorne und hinten nicht klappt. Und das obwohl teile davon ja bereits funktioniert haben.

    Bin kein Computerheini der davon Ahnung hat. Angeblich ist es alles ja so einfach mit Max2play. Aber das ist es nur wenn mal Studierter im Bereich mit PCs ist.

    Nur das Geld habe ich also damals zum Fenster rausgeworfen. Muß mir also jetzt was anderes suchen was funktioniert damit ich wieder Musik hören kann. Einfach klasse.

    Alles gute

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.

Register here