Bei Kodi kein Ton

This topic contains 7 replies, has 2 voices, and was last updated by  Heiner Moderator 4 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • 9. Juli 2018 at 16:41 #36499

    Hallo,
    benutze seit gestern Max2PLay auf dem RasberryPi 3B als Premium Version in Verbindung mit einem HifiBerry Dac+..,
    soweit bisher ganz gut, nur beim Kodi klappt es nicht mit dem HifiBerry Dac+, lediglich nur HDMI,Analog lassen sich auwählen,
    am Anfang auch Pulse.nach dem Update nun auch dies nichtmehr.
    was könnte die Ursache sein?..in der Config.txt ist auch – dtoverlay=hifiberry-dacplus aufgeführt…,
    ohne Kodi denke ich ist das ganze Paket nichts wert,da kein HD Video und TV ….für Tipps wäre ich dankbar..
    achso ,die benutze die letzte Image m2p_stretch_rpi_245.img.zip..
    MFG Wolf

    11. Juli 2018 at 16:01 #36538

    Hallo Wolf,

    Danke für die Anfrage.

    In den Raspberry Einstellungen kannst du die eingebaute Soundkarte des Pi deaktivieren. Nach einem Neustart ist die HiFiBerry Karte dann auf dem 2. Platz. Irgendwie gibt Kodi lediglich die ersten beiden Audio-Optionen aus, so sollte die HiFiBerry-Karte dann auch dazu gehören.

    11. Juli 2018 at 17:03 #36541

    Hallo,danke für die Anwort,
    doch leider funktioniert es immer noch nicht mh
    hatte unter Raspberry Einstellung bei diese Einstellung ein Häckchen gesetzt..

    Disable Build-In-Audio Disable Build-In-Audio (remove HDMI/Headphone Jack and put any other connected audiocard on position 0). This may be neccessary to get the HifiBerry AMP+ working.

    bliebe damit nur HDMI, Analog und HDMI und Analog über, was musst unter >> Wähle Audio Ausgang für Raspberry PI << ausgewählt sein?,
    Unter Libreelec bekomme ich die Auswahl ua mit Alsa:Default(snd_rpi_hifiberry_dacplus angezeigt und hier bei M2P wenn Option an: Alsa:Default (bcm2835 ALSA bcm2835 ALSA) ,aber kein Ton..was mache ich falsch?

    13. Juli 2018 at 11:22 #36567

    Hallo Wolf,

    bcm ist die eingebaute Soundkarte. Kannst noch einen erneuten Reboot versuchen? Eigentlich sollte danach die Hifiberry Karte gesetzt sein. Du kannst auch im Audioplayer in der debug info nachsehen, ob dies der Fall ist.

    13. Juli 2018 at 14:28 #36569

    Hallo Heiner,
    danke für die Antwort,
    der Debug sieht momentan so aus:

    #### SQUEEZELITE VERSION ####
    Squeezelite Max2Play v1.0.3 based on v1.8.7-999, Copyright 2012-2015 Adrian Smith, 2015-2017 Ralph Irving.

    #### SQUEEZELITE BUILDOPTIONS ####
    Build options: LINUX ALSA EVENTFD RESAMPLE FFMPEG VISEXPORT IR GPIO DSD CONTROLSBS ALSASYNC BLUETOOTHSYNC

    #### AUDIOPLAYER CONFIG ####
    ### Configuration of Audioplayers
    SQUEEZELITE_PARAMETER=-o sysdefault:CARD=sndrpihifiberry -a 80:4::
    SQUEEZESLAVE_PARAMETER=-n plugequal
    SHAIRPORT_PARAMETER=-d default:CARD=sndrpihifiberry
    USE_USB_DAC=1
    USE_EQUALIZER=1
    SYSTEM_USER=pi
    YMPD_PARAMETER=–webport 8081
    GMEDIARENDERER_ALSA_DEVICE=default:CARD=sndrpihifiberry
    LMSIP=192.168.100.26
    MULTISHAIRPORT_PLAYERCOUNT=2
    MULTISQUEEZE_PLAYERCOUNT=2
    MULTISQUEEZE_NAME_0=Max2Play_0
    MULTISQUEEZE_PARAMETER_0=-o default:CARD=sndrpihifiberry -a 80:4::
    MULTISQUEEZE_NAME_1=Max2Play_1
    MULTISQUEEZE_PARAMETER_1=-o sysdefault:CARD=sndrpihifiberry -a 80:4::
    MULTISHAIRPORT_NAME_0=Max2Play_0
    MULTISHAIRPORT_PARAMETER_0=-d default:CARD=sndrpihifiberry
    MULTISHAIRPORT_NAME_1=Max2Play_1
    MULTISHAIRPORT_PARAMETER_1=-d default:CARD=sndrpihifiberry

    #### SQUEEZELITE -l ####
    Output devices:
    null – Discard all samples (playback) or generate zero samples (capture)
    equalUSB
    plugequalUSB – Equalizer for USB
    dmixerUSB – DMixer for USB
    plugdmixerUSB
    equal
    plugequal – Equalizer for plughw:0,0
    headphonesplug
    bs2b
    headphones
    default:CARD=ALSA – bcm2835 ALSA, bcm2835 ALSA – Default Audio Device
    sysdefault:CARD=ALSA – bcm2835 ALSA, bcm2835 ALSA – Default Audio Device
    dmix:CARD=ALSA,DEV=0 – bcm2835 ALSA, bcm2835 ALSA – Direct sample mixing device
    dmix:CARD=ALSA,DEV=1 – bcm2835 ALSA, bcm2835 IEC958/HDMI – Direct sample mixing device
    dsnoop:CARD=ALSA,DEV=0 – bcm2835 ALSA, bcm2835 ALSA – Direct sample snooping device
    dsnoop:CARD=ALSA,DEV=1 – bcm2835 ALSA, bcm2835 IEC958/HDMI – Direct sample snooping device
    hw:CARD=ALSA,DEV=0 – bcm2835 ALSA, bcm2835 ALSA – Direct hardware device without any conversions
    hw:CARD=ALSA,DEV=1 – bcm2835 ALSA, bcm2835 IEC958/HDMI – Direct hardware device without any conversions
    plughw:CARD=ALSA,DEV=0 – bcm2835 ALSA, bcm2835 ALSA – Hardware device with all software conversions
    plughw:CARD=ALSA,DEV=1 – bcm2835 ALSA, bcm2835 IEC958/HDMI – Hardware device with all software conversions
    default:CARD=sndrpihifiberry – snd_rpi_hifiberry_dacplus, – Default Audio Device
    sysdefault:CARD=sndrpihifiberry – snd_rpi_hifiberry_dacplus, – Default Audio Device
    dmix:CARD=sndrpihifiberry,DEV=0 – snd_rpi_hifiberry_dacplus, – Direct sample mixing device
    dsnoop:CARD=sndrpihifiberry,DEV=0 – snd_rpi_hifiberry_dacplus, – Direct sample snooping device
    hw:CARD=sndrpihifiberry,DEV=0 – snd_rpi_hifiberry_dacplus, – Direct hardware device without any conversions
    plughw:CARD=sndrpihifiberry,DEV=0 – snd_rpi_hifiberry_dacplus, – Hardware device with all software conversions

    #### SHAIRPORT (SYNC) VERSION ####
    3.1.1-OpenSSL-Avahi-ALSA-soxr-sysconfdir:/usr/local/etc

    #### OUTPUT SOUND DETAILS CARD 0 ####
    closed

    #### OUTPUT SOUND DETAILS CARD 1 ####
    access: MMAP_INTERLEAVED
    format: S32_LE
    subformat: STD
    channels: 2
    rate: 44100 (44100/1)
    period_size: 882
    buffer_size: 3528

    #### SOUNDDEVICES IN USE ####
    USER PID ACCESS COMMAND
    /dev/snd/controlC0: pi 1144 F…. lxpanel
    /dev/snd/pcmC1D0p: pi 377 F…m squeezelite

    mit dem Logitech Media Server zb. haben ich Ton, aber mit Kodi nicht
    was stimmt da nicht?, schon mehr mals neu Aufgesetzt
    Danke MFG Wolf

    13. Juli 2018 at 16:16 #36579

    Der output bedeutet, dass die eingebaute karte nicht deaktiviert ist. Bitte versuch einmal, den Haken bei disable build in audio rauszunehmen, neuzustarten und ihn erneut zu setzen und neuzustarten.

    Ich habs hier nochmal getestet um sicherzugehen und es sollte eigentlich funktionieren. Geh außerdem sicher, dass du dein System auf Version 2.46 updatest.

    13. Juli 2018 at 19:05 #36586

    Hallo, danke für den Hinweis..
    Punkte nachgegangen..Debug sieht jetzt so aus:

    #### SQUEEZELITE VERSION ####
    Squeezelite Max2Play v1.0.3 based on v1.8.7-999, Copyright 2012-2015 Adrian Smith, 2015-2017 Ralph Irving.

    #### SQUEEZELITE BUILDOPTIONS ####
    Build options: LINUX ALSA EVENTFD RESAMPLE FFMPEG VISEXPORT IR GPIO DSD CONTROLSBS ALSASYNC BLUETOOTHSYNC

    #### AUDIOPLAYER CONFIG ####
    ### Configuration of Audioplayers
    SQUEEZELITE_PARAMETER=-o sysdefault:CARD=sndrpihifiberry -a 80:4::
    SQUEEZESLAVE_PARAMETER=-n plugequal
    SHAIRPORT_PARAMETER=-d default:CARD=sndrpihifiberry
    USE_USB_DAC=1
    USE_EQUALIZER=1
    SYSTEM_USER=pi
    YMPD_PARAMETER=–webport 8081
    GMEDIARENDERER_ALSA_DEVICE=default:CARD=sndrpihifiberry
    LMSIP=192.168.100.26
    MULTISHAIRPORT_PLAYERCOUNT=2
    MULTISQUEEZE_PLAYERCOUNT=2
    MULTISQUEEZE_NAME_0=Max2Play_0
    MULTISQUEEZE_PARAMETER_0=-o default:CARD=sndrpihifiberry -a 80:4::
    MULTISQUEEZE_NAME_1=Max2Play_1
    MULTISQUEEZE_PARAMETER_1=-o sysdefault:CARD=sndrpihifiberry -a 80:4::
    MULTISHAIRPORT_NAME_0=Max2Play_0
    MULTISHAIRPORT_PARAMETER_0=-d default:CARD=sndrpihifiberry
    MULTISHAIRPORT_NAME_1=Max2Play_1
    MULTISHAIRPORT_PARAMETER_1=-d default:CARD=sndrpihifiberry

    #### SQUEEZELITE -l ####
    Output devices:
    null – Discard all samples (playback) or generate zero samples (capture)
    equalUSB
    plugequalUSB – Equalizer for USB
    dmixerUSB – DMixer for USB
    plugdmixerUSB
    equal
    plugequal – Equalizer for plughw:0,0
    headphonesplug
    bs2b
    headphones
    default:CARD=sndrpihifiberry – snd_rpi_hifiberry_dacplus, – Default Audio Device
    sysdefault:CARD=sndrpihifiberry – snd_rpi_hifiberry_dacplus, – Default Audio Device
    dmix:CARD=sndrpihifiberry,DEV=0 – snd_rpi_hifiberry_dacplus, – Direct sample mixing device
    dsnoop:CARD=sndrpihifiberry,DEV=0 – snd_rpi_hifiberry_dacplus, – Direct sample snooping device
    hw:CARD=sndrpihifiberry,DEV=0 – snd_rpi_hifiberry_dacplus, – Direct hardware device without any conversions
    plughw:CARD=sndrpihifiberry,DEV=0 – snd_rpi_hifiberry_dacplus, – Hardware device with all software conversions

    #### SHAIRPORT (SYNC) VERSION ####
    3.1.1-OpenSSL-Avahi-ALSA-soxr-sysconfdir:/usr/local/etc

    #### OUTPUT SOUND DETAILS CARD 0 ####
    access: MMAP_INTERLEAVED
    format: S32_LE
    subformat: STD
    channels: 2
    rate: 44100 (44100/1)
    period_size: 882
    buffer_size: 3528

    #### OUTPUT SOUND DETAILS CARD 1 ####

    unter Kodi leider kein HifiBerry, nur HDMI und Analog

    17. Juli 2018 at 9:16 #36635

    nun sollte eigentlich die auswahl für hifiberry mit reinrutschen. stelle mit einmal kodi in den autostart, entferne alle anderen autostarts und starte den Pi neu.

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.

Register here