Auxiliary output randomly stops working

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Auxiliary output randomly stops working

This topic contains 29 replies, has 3 voices, and was last updated by  Heiner Moderator 2 months ago.

Viewing 30 posts - 1 through 30 (of 30 total)
  • 25. Dezember 2018 at 19:48 #42941

    Hi,
    I currently have a Max2Play and Squeezebox/Squeezelite setup running on a Raspberry Pi Model 3B+.
    There are two squeezelite instances – one for an auxiliary output and one for a USB sound card. The Raspberry Pi is connected through the integrated WiFi chip.

    The auxiliary output will suddenly stop working at a random time without me changing any settings. This means that only the USB sound card will play audio. I’ve tried looking at and tweaking the settings and nothing works. I tried a clean reinstall. Again, the auxiliary output worked for around 3-5 days and then it stopped again.

    I have no idea why this happens. Please could you provide some help.

    Debug information
    Audioplayer Debug
    Squeezebox Server Debug
    Raspberry Settings Debug

    Thanks,
    Josh

    3. Januar 2019 at 11:37 #43050

    Hi Josh,

    Thanks for the detailed logs.

    By auxiliary you mean the built-in audio jack?
    Can you look at the Health Checker when playback drops? Is there a performance spike?

    Do you use WiFi for your BT-setup, too? The BT and WiFi on 3B+ share the same small chip for operations so this might be a source of issue for your BT playback.

    3. Januar 2019 at 15:15 #43081

    Hi Heiner,
    Happy New Year

    Yes, I meant the built-in audio jack. Since my last message, however, it started working again and has been working for the past week. If I do encounter this again, I will follow your instructions of looking at the Health Checker.

    Yes, I do use WiFi to connect to my LAN. I don’t think that this is a problem because using Bluetooth without going through Squeezebox does work fine.

    Thanks,
    Josh

    18. Januar 2019 at 23:27 #43881

    Hi,
    Sorry to bump this thread however this issue has started occurring again. I’ve tried systematically changing the settings in Max2Play but nothing seems to work.
    Is there a way to reinstall all the audio drivers without reinstalling all of Max2Play again?

    Also, please could you remove the [SOLVED] tag on this thread.

    Thanks,
    Josh

    21. Januar 2019 at 13:30 #43946

    Hi Josh,

    What do you mean by changing the settings? The audio drivers cannot be reinstalled.

    Did you try deactivating BT or using ethernet yet?

    31. Januar 2019 at 19:25 #44308

    Hi Heiner,
    Sorry for the late reply – I accidentally stopped email notifications so I didn’t receive your reply.
    I tried changing the Squeezebox/Squeezelite player audio sources and Raspberry Pi settings however these do not do anything.
    Is there any other way to fix the audio problem without formatting everything and starting again? This seems to be a recurring problem and it is not ideal to have to reinstall the entire system every time it stops working.

    I’ve now basically given up on BT as it is not working with Squeezebox at all (even though it does work natively). I am not using ethernet as it is impractical to get a cable from the router to the Pi. Despite this, I do not think that these would affect the audio output.

    Thanks,
    Joshua Heng

    1. Februar 2019 at 11:11 #44311

    Hi Joshua,

    I’m sure there is a solution without reformatting. Resetting is a feature we only install for specific things since can cause other issues. With the USB card drivers it just wouldn’t make sense.

    If you like to experiment with different features of Max2Play, it’s a good step to make a backup of your existing image’s setup for future projects.

    I’m also not sure what exactly your current situation is. Your players‘ playback does not work at all or it stops after a few days?
    If the former is the case, a new image would be your best bet, also just to make sure there is no hardware defect.
    If the latter is the case, you need to look at performance in the Health Checker and try to tweak aspects of your setup that might decrease performance (WiFi, USB powered hub to make sure the USB DAC is not receiving insufficient power, power supply in general for 3B+ should have 3A especially with USB connected, etc.)

    1. Februar 2019 at 19:09 #44315

    Hi Heiner,
    The issue that I am having is that my squeezelite player called ‚mainroom‘ is not working. It uses the default auxillary 3.5mm output jack however there is no output coming out of it. This happened previously, and was working again after a complete reinstall/new image. Around 5 days after the new image, however, it stopped working again and has not been working ever since. I am reluctant to install a new image again as if this is a consistent issue it will become impractical.
    The performance in the Health Checker is normally less than 0.65 and the power supply is a proper 3A raspberry pi power supply. If power was an issue, I would have thought that the USB soundcard would not be working instead.

    My other squeezelite player ‚desk‘ which runs of a USB sound card works as intended.

    Thanks,
    Josh

    Health Checker
    Internet: Connected
    CPU Load: 0.60
    SD Card Usage: 14%
    Temp CPU: 51.5
    Power Supply: OK

    Multisqueeze Configuration

    • This reply was modified 2 months, 2 weeks ago by  JoshHeng.
    4. Februar 2019 at 13:01 #44332

    Hi Josh,

    Try removing the -C parameter from your audio jack output player.

    So the device keeps working and the USB card is also running on the same device and does also not stop working?
    It’s only the audio jack output on a device that’s otherwise working fine?

    5. Februar 2019 at 9:12 #44350

    Hi,
    I tried removing the C parameter and it still doesn’t work.
    I’ve also tried changing the order of multisqueeze players (ie the ‘mainroom’ player before the ‘desk’ player), however this doesn’t work too.
    Yes; the device is working fine, including its USB sound card, apart from the audio jack.

    Thanks, Josh

    5. Februar 2019 at 11:39 #44352

    Have you selected anything in the Raspberry Settings? Please try the option „force headphone jack“ there.

    5. Februar 2019 at 18:09 #44387

    Hi,
    I’ve already tried that and looked at/changed other settings in that menu but it still does not work.

    Thanks,
    Josh

    6. Februar 2019 at 10:06 #44388

    Try disabling build in audio in the Raspberry Settings, rebooting, enabling it again and rebooting again.

    If that still does not change anything, try removing the USB sound card if possible to see if this changes anything about the audio jack issue.

    7. Februar 2019 at 0:52 #44396

    Hi Heiner,
    I’ve tried the steps that you recommended but the audio jack still doesn’t seem to work.

    Thanks,
    Josh

    7. Februar 2019 at 23:25 #44417

    Hi Heiner,
    I’ve got two Raspberry Pis and I just swapped the one running Max2Play (ie the sound card, audio jack and SD card).
    The audio jack still doesn’t work, so it must be a software problem instead of a hardware problem (unless I have two broken Pis)

    14. Februar 2019 at 4:22 #44457

    Hi Josh

    I might be able to help if we work together!!

    I have looked at your enclosed debug files and I can see that you haven’t done a update lately

    If you go into the raspberry settings tap and scroll down to „Kernel and Package Updates and Upgrades“

    next: Reboot your PI

    If you haven’t installed the plugin: Remote Control do it and set it up

    I need to know the status of two programs

    After you have locked in with your user/password type:

    sudo systemctl status shairport

    look for the line „Active:“ and let me know what it says here after.

    Do the same thing with:

    sudo systemctl status Squeezelite

    looking forward to your answer

    Peter

    15. Februar 2019 at 0:52 #44459

    Hi Peter,
    Thanks for helping me.

    I updated the kernel and packages but it still isn’t working.
    I also just SSHed directly instead of using the remote control plugin. This is what I got (which doesn’t seem right):

    sudo systemctl status shairport
    ● shairport.service - LSB: Script to start shairport
       Loaded: loaded (/etc/init.d/shairport; generated; vendor preset: enabled)
       Active: inactive (dead)
         Docs: man:systemd-sysv-generator(8)
    sudo systemctl status squeezelite
    ● squeezelite.service - LSB: Script to start squeezelite
       Loaded: loaded (/etc/init.d/squeezelite; generated; vendor preset: enabled)
       Active: inactive (dead)
         Docs: man:systemd-sysv-generator(8)

    If it helps, this is the result of sudo systemctl status:
    Link

    I’ll also attach the updated debug files:
    Multisqueeze
    Squeezebox
    Raspberry Settings
    Audioplayer
    Settings

    Thanks for the help again,
    Josh

    15. Februar 2019 at 8:25 #44460

    Hi Josh

    There is no overlap in your settings and boot config is also ok, I can’t see if you have marked jack instead of HDMI but you have told Heiner that you did.

    Normally when we talk about software errors its more black or white (either it works or it doesn’t) It is more likely some outer interference ….. like your power supply (we are all hav’ing that problem sooner or later) I wood suggest that the next thing to try is the minimalistic approach. uninstall bluetooth and unplug your usb sound card. If you have other usb / GPIO devices pluged in remove them too.

    maybe if load all on one PI and nothing on the other … does that make a difference ???

    Most 5v plugs are more likely 4.6-4.75v wich is too low for the PI.

    Let me know the result of your test, I will try to think of any other possible solution.

    Peter

    16. Februar 2019 at 0:55 #44466

    Hi Peter,

    I tried using different power supplies
    I removed all unneeded plugins such as Bluetooth and RPi Camera
    I also removed my USB sound card and tried that.
    None of these methods worked.

    I believe that it is a software issue because I have tried multiple Raspberry Pis and power supplies, and the problem persists. This happened to me before and I could only solve it through a complete reset of the image (with the hardware the same), but the problem came back after around 1/2 weeks. I just don’t know that the issue is, or how to fix it without resetting the image again.

    Thanks,
    Josh

    16. Februar 2019 at 4:08 #44468

    Okay

    There is nothing wrong with the basic settings

    We can take a look at the log for hardware to see if there is any error message:

    Open Remote Control plugin and type:

    dmesg

    The last thing I know of that we can do… making the audio jack output the default output and/or secure that it stays that way

    I need the readout of those two commands:

    cat /proc/asound/cards

    and

    aplay -l

    This will show us in which ordre the sound cards are loaded there after we can set up a new file to make sure we that always get the same order!!

    • This reply was modified 2 months ago by  Cassio299.
    18. Februar 2019 at 1:37 #44486

    Hi Peter,
    Sorry for the late reply.

    Dmesg Response
    cat /proc/asound/cards
    aplay -l

    Thanks,
    Josh

    18. Februar 2019 at 9:09 #44487

    Hi Josh

    Your boot up file (Dmesg file looks ok) you do however have a hang on boot (just a delay):
    [ 4.297395] random: crng init done
    [ 4.297411] random: 7 urandom warning(s) missed due to ratelimiting

    this can be avoided by installing:

    sudo apt update
    sudo apt install haveged
    sudo systemctl enable haveged

    If you want!!!

    You should also expand your SD card if you haven’t already done so (to avoid future hang ups)

    You do so in the settings/reboot tab click on „expand filesystem“ then Reboot

    The following settings are important for your device to work as intented:

    Audioplayer tab
    turn off Squeezelite
    turn off Shairport

    Bluetooth tab
    Sound Device: Alsa – hw:0.1 HDMI (because you are using the 3,5mm jack wich needs the Alsa – hw:0.0 driver to run)
    (if you have set it to hw:0.0 unload bluetooth speaker change the setting and click save)

    Multisqueeze tab
    Your cards readout said that card 0 was the Alsa driver and card 1 was the USB DAC (this is the normal standard so nothing was changed here)

    Set the instances according to that

    Instance 0 : sound card: default bcm2835 ALSA……..card = ALSA (your 3,5mmm jack)
    Instance 1 : sound card: default – USB AUDIO DAC, or front – USB Audio DAC
    Instance 2 : sound card: Your Bluetooth Device (if you have a bluetooth audio speaker)

    Set Audio Output on Raspberry PI: Force Headphone Jack

    Let me know if this did anything !!

    Peter

    • This reply was modified 2 months ago by  Cassio299.
    18. Februar 2019 at 11:12 #44499

    Hi Peter,
    I tried following your steps but it hasn’t fixed the issue

    I disabled the autostart of Squeezelite and Shairport in the AudioPlayer tab, however they still seem to start and run.

    Thanks,
    Josh

    18. Februar 2019 at 13:47 #44505

    Hi Josh

    Thats weird … in AudioPlayer tab try this: Squeezeligt: stop Squeezeligt then unmarked auto startup then click save next to it
    do it the same way for Shairport.

    reboot

    and go back and check.

    Have you checked bluetooth settings that you have picked the 2nd from top ALSA HDMI ?

    Peter

    19. Februar 2019 at 2:05 #44518

    Hi Peter,
    Squeezelite and Shairport
    I cannot stop squeezelite and shairport (Trying to stop … could NOT stop process – try kill instead) and sometimes kill does not work. When I do manage to kill the processes, once I reload the page they have started again. The checkboxes are unticked.

    Bluetooth Settings
    Bluetooth just streams directly to the Squeezebox server so there is no option. Bluetooth also doesn’t work this way, but that’s another matter.

    Thanks,
    Josh

    19. Februar 2019 at 8:40 #44519

    Hi Josh

    Okay lets take a different aproche before those PI’s will be unwillingly flying out of the window!!.

    I think, there must be something odd going on in the settings department…

    Let us recap, there might be something we have overlooked.

    1. On the ‚Mainroom‘ Raspberry Pi 3+ you have Squeezelite, Bluetooth and Multi-squeeze running. You are streaming sound from your USB soundcard and a device connected to the 3.5mm audio jack.You own a 3a 5v power supply wich you are using with your ‚Mainroom‘ Raspberry Pi+

    Your ‚Mainroom‘ Pi 3+, was working fine until suddenly the audio jack stoped working.It started working again After a software reinstall. The audio jack worked for aprox. 5 days before it stoped working again.

    At the end of January the audio jack still doesn’t work, and you have almost given up on bluetooth to work also. However you do not uninstall the plugin.

    2. February: Your installation has changed you are no longer streaming/playing from one Raspberry pi 3+ ‚Mainroom‘ with a USB card and a 3,5mm audio device. The second device is called ‚desk‘ player. The second player also have a defect audio jack. You tried with the same SD card and sound cards with the same result and therefore think that the problem is the software.

    3. On the 18th you send me your Pi’s boot report (Demsg) from a Raspberry Pi called ‚Soundsystem‘ properly with new installed software and clearly not the same as the Pi called ‚Mainroom‘. Maybe a third PI??.

    A finally one of the first thing I asked you to do was telling me the status of the settings of Squeezelite and Shairport in the Audioplayer tab. On the 15th. you told me that the status was: Active: inactive (dead). also not running.

    On the 18th you wrote: I disabled the autostart of Squeezelite and Shairport in the AudioPlayer tab, however they still seem to start and run and the 19th you wrote: I cannot stop squeezelite and shairport (Trying to stop … could NOT stop process – try kill instead) and sometimes kill does not work. When I do manage to kill the processes, once I reload the page they have started again. The checkboxes are unticked.

    I now know that there are only one person who can solve the mystery of the sudden death of the auxiliary output!!!

    And that person needs to find out who, how and what in the chase of the unstoppable process!! first.

    Until then I wish you a happy reinstalling!!

    Peter

    19. Februar 2019 at 16:49 #44528

    Hi Peter,
    1. On the ‚Mainroom‘ Raspberry Pi 3+ you have Squeezelite, Bluetooth and Multi-squeeze running. You are streaming sound from your USB soundcard and a device connected to the 3.5mm audio jack.You own a 3a 5v power supply wich you are using with your ‚Mainroom‘ Raspberry Pi+
    I have one Raspberry Pi 3+ running Max2Play with Squeezebox Server, Multi-Squeeze and Bluetooth. I also recently installed an OpenHAB server on it as well, but that is a completely separate process. The Pi is now called „Smartroom“ and is powered through a proper 5V 2.5A/3A power supply. It is connected to one amplifier through the 3.5mm audio jack, and is also connected to another amplifier through a USB soundcard.

    Your ‚Mainroom‘ Pi 3+, was working fine until suddenly the audio jack stoped working.It started working again After a software reinstall. The audio jack worked for aprox. 5 days before it stoped working again.
    Yes, and I needed to completely format and reflash the SD card. I really don’t want to do this again if possible.

    At the end of January the audio jack still doesn’t work, and you have almost given up on bluetooth to work also. However you do not uninstall the plugin.
    Yes, the audio jack doesn’t work. Bluetooth doesn’t work when going through Squeezebox, so I uninstalled it for a while but the audio jack didn’t start working again. I later reinstalled it.

    2. February: Your installation has changed you are no longer streaming/playing from one Raspberry pi 3+ ‚Mainroom‘ with a USB card and a 3,5mm audio device. The second device is called ‚desk‘ player. The second player also have a defect audio jack. You tried with the same SD card and sound cards with the same result and therefore think that the problem is the software.
    No, I am still using the single Raspberry Pi with multisqueeze (which allows multiple players). I have tried using a different Pi, power supplies and soundcards however these have the same result, so yes, I do think that the problem is the software.

    3. On the 18th you send me your Pi’s boot report (Demsg) from a Raspberry Pi called ‚Soundsystem‘ properly with new installed software and clearly not the same as the Pi called ‚Mainroom‘. Maybe a third PI??.
    The single Pi called „SoundSystem“ is the same Pi I used all along. „Mainroom“ and „Desk“ are just names of the Multisqueeze players.

    A finally one of the first thing I asked you to do was telling me the status of the settings of Squeezelite and Shairport in the Audioplayer tab. On the 15th. you told me that the status was: Active: inactive (dead). also not running.

    On the 18th you wrote: I disabled the autostart of Squeezelite and Shairport in the AudioPlayer tab, however they still seem to start and run and the 19th you wrote: I cannot stop squeezelite and shairport (Trying to stop … could NOT stop process – try kill instead) and sometimes kill does not work. When I do manage to kill the processes, once I reload the page they have started again. The checkboxes are unticked.
    Yes, that is correct. I still don’t really understand what the statuses meant when I sent them to you.

    I now know that there are only one person who can solve the mystery of the sudden death of the auxiliary output!!!

    And that person needs to find out who, how and what in the chase of the unstoppable process!! first.
    I don’t really know what you mean

    Until then I wish you a happy reinstalling!!
    If possible, I really don’t want to reinstall everything as it will take me a long time to get everything reconfigured. I can reinstall individual software but ideally I don’t want to get a new image.

    Thanks

    20. Februar 2019 at 7:10 #44531

    Hi Josh

    Im sorry, but Im not able to help you.

    Peter

    20. Februar 2019 at 15:14 #44533

    Hi Peter,
    Thanks for all the help. I’ll just wait for Heiner to get back to me.

    Thanks,
    Josh

    21. Februar 2019 at 17:04 #44538

    Hi Josh,

    At this point I understand your main issue is the audio jack not working? I’d recommend trying to burn a fresh image on a separate sd card (if you have not yet, just use the one from the Pi that’s working fine) and checking if the playback still doesn’t work. If this is the case, your audio jack port might just be faulty.

    However, behaviour like the audioplayers not being able to be properly shut down and somehow autostarting despite it being unticked indicate that your system might also be impeded by further issues stemming from your customization.

    My general recommendation would really be to burn a fresh image. As mentioned you can create a backup of your current one through various channels (burner software, our burner plugin, etc.)

Viewing 30 posts - 1 through 30 (of 30 total)

You must be logged in to reply to this topic.

Register here