[SOLVED] Ausgabe stottert bei Internet-Radio

Max2Play Home 2016 (en) Forums Max2Play as Squeezebox (Player / Server) [SOLVED] Ausgabe stottert bei Internet-Radio

This topic contains 9 replies, has 3 voices, and was last updated by  beginner premium 10 months, 3 weeks ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • 4. November 2017 at 17:13 #32283

    Hallo,
    Ich verwende Squeezelite player v1.8.4-726 mit dem Squeezebox Server v7.9.0. Die Wiedergabe von eigener Musik funktioniert problemlos. Bei Internet-Radio gibt es aber alle paar Minuten kleine Sprünge im Takt, d.h. es wird ein halber Takt „verschluckt“, die Wiedergabe ist für vielleicht eine halbe Sekunde doppelt so schnell, danach wieder normal.

    Was kann ich dagegen tun?

    Danke im Voraus!

    6. November 2017 at 13:03 #32306

    Hallo beginner,

    Die erste Variable, die ich untersuchen würde, wäre die Internetverbindung. Wenn möglich, und falls noch nicht bereits im Einsatz, versuche bitte einmal das Gerät über LAN-Kabel laufen zu lassen um sicherzustellen, dass es nicht an einer schwachen WLAN-Verbindung liegt.

    Außerdem kannst du noch Hardware Lautstärke Regelung aktivieren: https://www.max2play.com/en/wiki/optimizing-squeezelites-volume-control/

    6. November 2017 at 21:41 #32315

    Hallo Heiner,

    Danke für Deine rasche Antwort. Der Raspi ist bereits via LAN-Kabel angebunden und die Audio Karte ist eine externe USB-Soundkarte behringer U-Control UCA222. Somit kann ich die Hardware Lautstärke Regelung gemäss Anleitung nicht verwenden.

    Welches sind die nächsten Schritte? – Danke im Voraus

    7. November 2017 at 11:50 #32321

    – Nutze einen anderen Internetstream, um die Quelle als Fehler auszuschließen (Spotify, etc. falls vorhanden).
    – Versuche eine Wiedergabe über ein anderes Gerät via DLNA (BubbleUPnP, AllConnect, etc.) um ein Netzwerkproblem auszuschließen.
    – Beachte dieses Wiki: https://www.max2play.com/en/wiki/getting-high-sound-quality/
    – Du kannst außerdem mal einen lokalen Radiosender ausprobieren, um sicherzugehen dass der Radiosender oder dessen Übertragung nicht fehlerhaft sein könnte

    12. November 2017 at 14:18 #32425

    Hallo Heiner,

    Danke für Deine Hinweise. Ich bin leider noch nicht viel schlauer. Ein Netzwerkproblem kann ich mit grosser Wahrscheinlichkeit ausschliessen, denn das Problem

      tritt bei unterschiedlichen Quellen und bei verschiedenen Sendern für Internet-Radios auf
      tritt bei unterschiedlichen Formaten (aac und mp3) auf
      tritt NICHT auf bei Einsatz einen Logitech-UE Gerätes im selben Netz und denselben Sendern / Formaten
      tritt NICHT auf beim Abspielen von lokal auf einer USB-Disk gespeicherter Musik

    Der Player wird zuerst teilweise ca. einen halben Takt lang laaangsamer, um dann den nächsten Takt ensprechend schneller abzuspielen. Die Stromversorgung ist separat für einen USB-Hub und für den Raspberry – wie empfohlen. An den Kabeln kann es kaum liegen, denn sonst müsste das Problem auch bei der eigenen Musik auftreten. Könnte ich den lokalen Buffer für den Player bei Internet-Radios evtl. erhöhen?

    • This reply was modified 11 months, 1 week ago by  beginner.
    • This reply was modified 11 months, 1 week ago by  beginner.
    • This reply was modified 11 months, 1 week ago by  beginner.
    14. November 2017 at 10:04 #32471

    Hallo Beginner,

    Du kannst noch versuchen, den Parameter für Bufferrate manuell anzupassen:

    -b <stream>:<output>Specify internal Stream and Output buffer sizes in Kbytes in den Kommandozeilenoptionen von Squeezelite.

    Hier findest du zudem noch die anderen Parameter um manuelle Konfigurationen in Squeezelite vorzunehmen: https://www.max2play.com/en/wiki/command-line-options-for-squeezelite/

    15. November 2017 at 22:05 #32498

    Hallo Heiner,

    Kannst Du mir bitte ein Beispiel für ein solches Kommando geben? Sobald ich den Startup-Parameter -b Zahl:Zahl setze, startet der Player nicht mehr.

    Danke im Voraus.

    15. November 2017 at 22:35 #32499

    Hallo,

    hat es was gebracht? Habe ja ähnliches Problem? Wie muss man die Zeile -b <stream>:<output> ausfüllen, also was muss man für <stream> und was für <output> angeben?

    24. November 2017 at 17:08 #32620

    Hi Leute,

    Entschuldigt die späte Rückmeldung. Ich war die letzte Woche im Urlaub und hole noch die etwas aufwendigeren Themen nach 😉

    Das ist vermutlich kein Buffer Problem – das Erhöhen des Buffers wird vermutlich nur die Zeit zwischen den Sprüngen vergrößern. Die Buffergröße wird bei uns standardmäßig im ALSA Parameter mit 80 definiert. In diesem Feld könnte man z.B. statt dem gesetzten 80:4::auch 120:4:: verwenden.

    Bei der externen USB-Soundkarte Behringer U-Control UCA222 solltest du noch mal die Squeezelite Kommandozeilen Einstellungen checken und ggf. -o hw:1 setzen (bei aktivierter integrierter Soundkarte) oder –o front:CARD=CODEC,DEV=0

    Squeezebox Server auf gleichem Gerät oder separat?
    Ist der Squeezelite-Player synchronisiert mit einem der UE Geräte? Falls ja, könnte das das Problem sein! -> Synchronisierung deaktivieren und testen

    Laufen sonstige Programme auf dem Pi? Ist es ein Pi3 und was sagt der CPU-Load auf der Einstellungsseite (Health Checker) im Webinterface wenn das Radio läuft?

    26. November 2017 at 17:01 #32643

    Hallo Heiner,

    Vielen Dank für Deine Hilfe. Nun funktioniert es! Ich bin erleichtert.

    Ich musste die integrierte Soundkarte aktivieren und als Startparameter „-o hw:1“ setzen. Seither habe ich keine Unregelmässigkeit im Takt mehr festgestellt.

    Zusatzinfo:
    Der Squeezebox Server ist auf demselben Gerät, es laufen aber sonst keine weiteren Programme. Der Raspberry ist aus Serie 2 und die CPU-Load ist im Bereich 0.4 bis 0.5. Eine aktive Synchronisation mit dem UE-Gerät hatte die Situation jeweils verbessert, nicht verschlechtert. Aber ich wollte nicht dauernd ein zweites Gerät eingeschaltet haben, nur damit der Takt einigermasse stimmt.

    Nochmals vielen Dank!

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.

Register here