Audio Drop Out via Bluetooth

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Audio Drop Out via Bluetooth

Tagged: 

This topic contains 8 replies, has 3 voices, and was last updated by  sf_max2play premium 3 months, 1 week ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • 24. October 2017 at 20:36 #32080

    Hi,

    I am running LMS on my Synology NAS. I have two clients connected to it, a Logitech Squeezebox Boom via WiFi, and a Raspberry Pi 3 via ethernet cable. The Raspberry Pi is paired to Bluetooth speakers.

    When listening to the Pi the audio always stops playing. Sometimes after just a couple minutes, sometimes closer to an hour. When this happens, the Bluetooth connection appears to be active (in the Bluetooth Max2Play window the device is green and I don’t hear the speakers beep like they do when a device is disconnected). Also, the LMS is still streaming audio (I can see the track is playing in my browser. When syncing the Pi audio with my Boom, audio continues playing on my Boom, which never loses connection).

    The same results happen when paired with my Logitech MX Sound speakers or my Riva Turbo X speakers.

    Restarting Squeezelite doesn’t solve the problem. Restarting the speakers doesn’t, either (they reconnect via Bluetooth, but are silent). The only solve is to reboot the Pi entirely.

    From the forums, I’ve tried the following recommendations:
    – Disabling Wifi
    – Using USB-DAC
    – Enabling Max USB-Current

    Any suggestions to fix this issue? Thank you.

    25. October 2017 at 10:50 #32092

    Hi sf,

    Unfortunately, this issue is not resolved, yet. We are working on a fix for the next version of Max2Play.
    Bluetooth connectivity is problematic as there are a huge variety of end devices used with varying technologies used. But we are looking into what might cause the issues on a general level and whether there are any measures to reduce the occurrence of dropouts.

    26. October 2017 at 5:32 #32116

    Hi Heiner,

    That’s too bad, but I appreciate your honesty! I bought Max2Play for this function specifically, so I’m hoping it will be fixed in the next round.

    Thanks for the response.

    27. October 2017 at 13:30 #32158

    Thanks for the feedback, we will try our best to find the ideal solution in the next version 🙂

    25. November 2017 at 23:10 #32638

    Same issue here.
    Worked with same hardware in previous version (2.41 and 2.42).
    Now I upgraded to 2.44 and have this issue. I will switch back temporarily…

    28. November 2017 at 14:07 #32669

    Can you reproduce the issue being gone in 2.41 or 2.42? If so, please share your debug info from the bluetooth plugin.

    9. January 2018 at 0:23 #33313

    Hi,

    I’m having much better Bluetooth streaming performance now than I had before. I updated the Pi 3 to latest everything and am running Max2Play 2.45. I also reset all the settings and am running it just as an audio player (no multisqueeze, or server). Those functions may work, but I don’t need them at the moment, so I’m not loading them.

    I played audio to a Bluetooth speaker for two hours straight today, with no issues. It also reconnects automatically to my Bluetooth speaker when I turn it on.

    So far, so good. I’ll post if there are anymore quirks. Thanks for continuing to improve the product.

    11. January 2018 at 11:00 #33353

    Hi sf,

    Thank you so much for these kind words 🙂

    Do you use the built-in BT module of the RPi3? If so, the low load you have on the system and or recent improvements to the BT plugin might let you play for over 3 hours despite just using built-in. Please let us know if you get the chance.

    12. January 2018 at 0:11 #33365

    I am using the built-in RP3 bluetooth. Today I let it run, and sometime around 3 hours in it seemed to stop working, at which point I needed to restart the speaker and the Pi to get it to go again.

    I’ve noticed that the synchronize function doesn’t work so well in the latest update, though. I have a Logitech Boom and the Max2Play Pi both connected to LMS running on a NAS. If I tell the Pi to sync to the Boom, the Boom will play, but the Pi will stop and everything will need to be reset. If I tell the Boom to sync to the Pi, it works fine, though there is a minor audio delay between the two, which I may be able to adjust for in the LMS settings. I also had an issue today where, during synchronized playback, I could stream a podcast fine, but if I played a track from my NAS, or via Spotty, music would play for a short period, before abruptly stopping, then starting over from the beginning.

    Not sure if the sync issue is related to Bluetooth or not. I’m happy to start a thread elsewhere if that’s preferable.

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.

Register here