Analogue Boost – How does it work?

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Analogue Boost – How does it work?

This topic contains 5 replies, has 2 voices, and was last updated by  Heiner Moderator 1 year, 2 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • 22. Juli 2019 at 13:35 #46443

    Hi,

    the search function didn’t give me a hint – but it must have already been discussed. I’m still wondering about the „Boost“ settings:
    There are three sliders to set the audio output level – Digital volume, Analogue playback boost and Analogue boost. They should be set to 100, 0 and 100 – but with that, my output level is too high, related to the other stereo hifi elements. Somewhat around 85% should be fine.

    I suppose the best way to lower the output is to set Analogue boost down (even if I don’t know what exactly it is) – but there are no values other than 100% accepted: Everything else sets the slider to 0%.

    I already had the problem in 2.47 – and thought it would be fixed. But it’s the same in M2P 2.50.

    What can I do with my Hifiberry hardware?

    23. Juli 2019 at 13:58 #46457

    Hi FZ,

    Do you use the hardware volume setting? This would allow your hardware to override the the Pi’s volume since software volume would impede on the ideal sound stream. Check if „hw:0“ or „hw:1“ is in the command line options of your Squeezelite, depending on your card’s position.

    23. Juli 2019 at 16:02 #46460

    Hi Heiner,

    thanks for your response! I don’t have a volume knob on my hifiberry, if you mean this by „hardware volume setting“. Just a raspi 3+ with a hifiberry card out of the box. My installed driver is „Hifi Berry DAC+ Pro (B+ / Pi 2/3)“.

    My volume thing arose with Bluetooth transmission of music right from my laptop – I didn’t use Squeezelite or the like. But if it matters: Squeezelite is running, options are:
    – Soundcard default -snd_rpi_hifiberry_dacplus
    – ALSA parameter 80:4::
    – commandline option -C 5
    I found another setting for direct streaming to the m2p soundcard „Bluetooth Speaker“ (which I don’t have, cause the Pi is plugged to the hifi tower) with these options:
    Sound Device: „sndrpihifiberry – hw:0:0 – Mixer Digital – Hifiberry DAC+ Pro HiFi pcm512x-hifi-0 []“

    Besides, I’ve got „Audio Ausgang für Raspberry Pi“ (RPI output port) set to „Standard, use HDMI, if plugged“ (which isn’t).

    My Squeezebox isn’t running on the Pi, but on my Syno NAS. But wasn’t used at this moment.

    F.Z.

    26. Juli 2019 at 13:00 #46502

    Hi FZ,

    It might be connected to the BT player then. Do you usually not use Squeezelite? You can add „hw:0“ to the command line options if you do use it.

    30. Juli 2019 at 23:08 #46574

    Thanks again!

    Honestly, I didn’t understand much of your answer.

    1. What do you mean by „it“ in the beginning of the sentence? What might be connected to the BT player? And what do you mean by BT player? At least, I don’t have a BT speaker linked, but a hifi set via audio out.

    2. Yes, I sometimes use Squeezelite to lean back and listen to the music I bought and have stored on my NAS. And sometimes, I lean forward and want to just test some music derived from Youtube or so – directly from my phone or laptop.

    3. If I can add „hw:0“ to the commandline options of squeezlite: How exactly do I manage this? I’m of the sort who buy a micro processor equipped with an operating system, but are not able to conduct a machine via a terminal. What do I put between the existing „-C 5“ and the „hw:0“? A blank, a comma or what?

    Friedo

    31. Juli 2019 at 14:13 #46582

    So hardware volume setting/control directly syncs the connected hardware’s volume adjustment with the DAC and gets rid of any software volume control which takes away from the quality of the output. „hw:0“ is this setting which says do hardware volume control with the card on slot 0 (1 if you have the build-in audio active, 0 if you don’t). This is a Squeezelite-specific setting. Here’s our wiki on it
    Different parameters are divided by a simple blank “ “ in the command line options. Here you can have a look at the other ones if you want to tweak your playback any further

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

Register here