AMPACHE install on raspberry pi brokes M2P web UI

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI AMPACHE install on raspberry pi brokes M2P web UI

This topic contains 1 reply, has 2 voices, and was last updated by  flysurfer premium 8 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • 1. April 2016 at 16:46 #19575

    Hi there,

    thanks for your work first of all. I have purchased premium license to support you…

    I want to install ampache web gui for MPD player…but…even when install script say install is successfully finished, it is not. ampache doesnt work and whts more install brokes apache2 configuration and max2play UI doesn’t work after that…

    this is log from apache restart script:
    ==> /var/log/apache2/error.log <==
    apache2: Could not reliably determine the server’s fully qualified domain name, using 127.0.0.1 for ServerName
    [Wed Jan 06 16:34:36 2016] [notice] Apache/2.2.22 (Debian) PHP/5.4.45-0+deb7u2 configured — resuming normal operations
    [Wed Jan 06 16:35:11 2016] [notice] Graceful restart requested, doing restart
    Warning:
    DocumentRoot [/var/www/ampache] does not exist
    apache2: apr_sockaddr_info_get() failed for max2play
    apache2: Could not reliably determine the server’s fully qualified domain name, using 127.0.0.1 for ServerName
    (2)No such file or directory: apache2: could not open error log file /var/www/ampache/error.log.
    Unable to open logs
    (2)No such file or directory: apache2: could not open error log file /var/www/ampache/error.log.
    Unable to open logs

    When I create missing directory for ampache, apache can be started and max2play UI starts to work… but ampache is not installed(according to UI) and cannot be accessed(as the ampache dir is empty).

    I tried this twice with empty fresh image of maxplay with the same result.

    Could you please repair install script?

    Raspberry PI – m2p_default_226_wps.img

    thanks a lot
    Kind regards
    Jan

    6. April 2016 at 18:17 #19680

    Hi Jan,

    could you try the latest Max2Play Image based on Debian Jessie (for RPi 2/3) from our Download Page and do the following steps:
    – install MPD-Addon with Installer for MPD and AMPACHE on Settings/Reboot Page (http://shop.max2play.com/media/downloadable/beta/ampache.tar)
    – update to latest Beta of Max2Play on Settings/Reboot Page
    – install Ampache by clicking “install” on MPD Player Page

    Now you should be able to access the Ampache Webinterface. Activate “Create Database User” on first step of configuration and set a Password for the ampache User and create the Config-File (use “max2play” as root password for the database) -> finished.

    • This reply was modified 8 months ago by  flysurfer.
Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.

Register here