AMP2 error: "Usage: amixer [command]"

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI AMP2 error: "Usage: amixer [command]"

This topic contains 3 replies, has 2 voices, and was last updated by  thomascologne premium 2 days, 4 hours ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • 31. August 2019 at 11:44 #46948

    Hello everyone,

    at first I need to mention that english is not my favorite language but I try to explain my problem as good as possible.

    I am a newbie with RP´s and the hifiberry modules. A couple days ago I could set up one RP with a DAC+ and later the same RP with the AMP2 module, just for testing. Everything worked fine.
    After that I ordered a couple RP´s 4 and tried to set up the AMP2 at first (with img v250), without success. Then I went back to the RP 3B+ and got the same results or errors.
    Set Up and installation works well (see below my steps) but the error message is always the same. I am working on that since 2,5 days now and have no more ideas what I am doing wrong.

    The error message is as follows:
    After choosing the Hifi Berry AMP2 in Raspberry settings > save > reboot I tried to set Digital Volume to 100 and Analogue Boost to 100. After „save“ I get a huge yellow „popup“ wich says:

    Usage: amixer [command]
    Available options:
    -h,--help this help
    ...
    ...
    Updated Alsa settings

    In the last couple days I tried several things, all without success. And now I am pretty much helpless and need some support.

    My set up was as follows (with 3B+)
    flashed SD card with m2p_stretch_rpi_v249.img
    mount AMP2 with external power supply

    According to the link https://www.hifiberry.com/build/documentation/configuring-linux-3-18-x/ I set up the /boot/config.txt according to this one:

    # Enable audio (loads snd_bcm2835)
    dtoverlay=hifiberry-dacplus
    gpu_mem=128
    
    disable_overscan=1

    After this adjustment I got the following:

    [email protected]:~ $ amixer
    amixer: Mixer attach default error: No such file or directory

    The curios thing is that the DAC+ is available as a soundcard after installation.
    But not the AMP2 sound card.

    I also tried:

    sudo apt-get update
    sudo apt-get upgrade
    and updated the kernel through the max2play platform

    What else can I try or is there something general wrong in the set up?
    Could it be that the AMP2 has a damage?

    Thanks in advance and greetings from Cologne

    edit:
    general question: Is there an LED mounted on the AMP2 which needs to be on after power supply? On the DAC+ is one. But I am not sure if a LED is on the AMP2. Because nothing is on.

    • This topic was modified 2 weeks, 3 days ago by  thomascologne.
    2. September 2019 at 10:59 #46957

    Hello Thomas,

    Thank you for the detailed post. You can also write in German if that’s more convenient for you 😉

    Have you tried the HiFiBerry Plugin yet? Please set „none“ in Raspberry Settings sound card selection and save and reboot.

    Then use the HiFiBerry Plugin to select the AMP2 and reboot.

    Check the debug info in Audioplayer to see if the hifiberry card was recognized.

    The AMP2 does not have an activity LED.

    10. September 2019 at 0:01 #47053

    Thanks for the response. I figured out that the AMP2 seems to be down. I ordered a new one for testing and it worked directly, with the same settings. And after installation there is an LED in green.
    My guess, the other one is bad.

    But now I have another issue.
    The current configuration is as follows:
    1x Server on Synology with Logitech Media Server 7.7.6
    2x Client RP4 (one with DAC+, the second one with AMP2)

    In the LMS I just can choose two players, instead of 4 adjusted players (multisqueeze plugin and 2 player per RP). I think there is something wrong with the MAC-adresses, because host and IP are different.
    What can I do to change the MAC adresses??
    I tried -m <mac adress> already but not sure which adress I have to type there. I tried several, but couldn´t start the player witt this command.

    RP1
    hostname: AMP2
    IP: 192.168.178.42
    MAC from LAN: DC:A6:32:12:F4:41
    AMP2 MAC-Adress of player:   b8:26:eb:c1:71:f0
    jack MAC-Adress of player:   b8:25:eb:c1:71:f0
    RP2
    hostname: DAC 
    IP: 192.168.178.41
    MAC from LAN: DC:A6:32:12:F3:BC
    Dac MAC-Adress of player:    b8:26:eb:c1:71:f0
    jack  MAC-Adress of player:  b8:25:eb:c1:71:f0
    15. September 2019 at 19:11 #47087

    Does anyone have an idea to set up 2x RP with 2x multisqueeze?
    The curious thing is if I have RP2 on multisqueeze (with 2 players) and RP1 with just one audioplayer (without multisqueeze) than it works.
    With the above mentioned set up the RP1 get´s the mac dc:a6:32:12:f4:41 and is listed in the LMS.

    But soon as I switch back to multi for the RP1 too, the LMS is switching between these both mac address.
    I also tried to flash both RP´s new, without success.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Register here