[SOLVED] Amp2 – Bluetooth Streaming No Sound

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI [SOLVED] Amp2 – Bluetooth Streaming No Sound

This topic contains 8 replies, has 2 voices, and was last updated by  Heiner Moderator 2 years, 8 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • 7. Mai 2018 at 21:54 #35567

    Hi All,

    Many thanks for the superb product with max2play! Love it and works so far with one exception and I hope that someone could help or point me in the right direction…

    I have one speaker fully set-up without issues with an Hifiberry DAC light and external amp… no issues (squeezlite & bluetooth streaming) but does not look great.

    So got second set as follows:

    Set-Up
    – rPi 3
    – installed Hifiberry Amp2
    – chose Amp2 at first installation
    – added USB External Bluetooth dongle (as on-board was as bad as in many posts described)
    – installed bluetooth
    – turned off all audioplayers except Squeezlite
    – disabled on-board bluetooth
    – disabled on-board audio
    – connected phone (Galaxy S7 & Galaxy A5) – both can connect without issues
    – Note: Speaker attached is a „8 ohm – center speaker“ i.e. only connected to one speaker output of the amp2
    – RPi is powered with the suggested 18V power adapter

    Tested
    – Squeezlite plays music perfectly fine (both phones)
    – tried to use bluetooth streaming but no sound from either phone
    – took off amp2 and played music via audio jack and internal soundchip (works fine for squeezlite & bluetooth streaming) = should not be the dongle…

    – Wiped the card, started from scratch but no change… reading plenty of posts here but so far no luck…

    Question is whether there is any particular known problem with the bluetooth streaming via amp2? Any settings that cause conflict or which i have to particularly look at?

    Set-up looks identical to the one of the working speaker build previously…

    So anything that I could look at to figure this out?

    Many thanks in advance for any help!
    Best
    Aylon

    Debug Info:
    #### Bluetooth Installation ####

    #### Bluetooth Dongle ####
    hci0: Type: Primary Bus: USB
    BD Address: 5C:F3:70:77:40:7E ACL MTU: 1021:8 SCO MTU: 64:1
    UP RUNNING PSCAN
    RX bytes:334218 acl:609 sco:0 events:113 errors:0
    TX bytes:5523 acl:69 sco:0 commands:61 errors:0

    #### DEVICE Galaxy A5 (2016) ####
    [88:AD:D2:1C:C1:04]
    Name: Galaxy A5 (2016)
    Alias: Galaxy A5 (2016) [rw]
    Address: 88:AD:D2:1C:C1:04
    Icon: phone
    Class: 0x5a020c
    Paired: 1
    Trusted: 1 [rw]
    Blocked: 0 [rw]
    Connected: 0
    UUIDs: [OBEXObjectPush, AudioSource, AVRemoteControlTarget, AdvancedAudioDistribution, HeadsetAudioGateway, PANU, NAP, HandsfreeAudioGateway, 0000112d-0000-1000-8000-00805f9b34fb, PhoneBookAccess, 00001132-0000-1000-8000-00805f9b34fb, PnPInformation, 00001800-0000-1000-8000-00805f9b34fb, 00001801-0000-1000-8000-00805f9b34fb]

    #### DEVICE Samsung Galaxy S7 edge ####
    [8C:1A:BF:A9:E5:E9]
    Name: Samsung Galaxy S7 edge
    Alias: Samsung Galaxy S7 edge [rw]
    Address: 8C:1A:BF:A9:E5:E9
    Icon: phone
    Class: 0x5a020c
    Paired: 1
    Trusted: 1 [rw]
    Blocked: 0 [rw]
    Connected: 1
    UUIDs: [OBEXObjectPush, AudioSource, AVRemoteControlTarget, AdvancedAudioDistribution, HeadsetAudioGateway, PANU, NAP, HandsfreeAudioGateway, 0000112d-0000-1000-8000-00805f9b34fb, PhoneBookAccess, 00001132-0000-1000-8000-00805f9b34fb, PnPInformation, 00001800-0000-1000-8000-00805f9b34fb, 00001801-0000-1000-8000-00805f9b34fb]

    #### BLUEALSA RUNNING ####
    2

    8. Mai 2018 at 11:53 #35579

    Try adding „-C 5“ to the command line options of your Squeezelite to make sure it does not block the sound card for other playback.

    8. Mai 2018 at 13:49 #35591

    Hi Heiner,

    Many thanks for the reply but the flag is already set in my previous testing.

    So this seems not to cause the issues.

    Apologies for not mentioning it.

    Many thanks
    Aylon

    8. Mai 2018 at 15:09 #35596

    If you have shairport running please remove it and see if the problem persists.

    Also, please copy the debug info from your Audioplayer plugin here as well.

    8. Mai 2018 at 23:30 #35608

    Strangely did my previous reply just disappear … hence here the details again.

    Shairport & DNLA were both already disabled.

    From the DEBUG I wonder if the following is simply incorrect as I disabled on-board sound?

    BLUEALSA_PLAY_AUDIOCARD=hw:1,0

    should actually be

    BLUEALSA_PLAY_AUDIOCARD=hw:0,0

    If so, how do I change this value as I have only one option on the bluetooth streaming section and this one is chosen:

    sndrpihifiberry – hw:0:0 – Mixer Digital – HiFiBerry DAC+ HiFi pcm512x-hifi-0 []

    Full DEBUG output below and again many thanks for your help!

    #### SQUEEZELITE VERSION ####
    Squeezelite Max2Play v1.0.2 based on v1.8.4-726, Copyright 2012-2015 Adrian Smith, 2015-2016 Ralph Irving.

    #### SQUEEZELITE BUILDOPTIONS ####
    Build options: LINUX ALSA EVENTFD RESAMPLE FFMPEG VISEXPORT IR GPIO DSD CONTROLSBS ALSASYNC BLUETOOTHSYNC

    #### AUDIOPLAYER CONFIG ####
    ### Configuration of Audioplayers
    SQUEEZELITE_PARAMETER=-o sysdefault:CARD=sndrpihifiberry -a 80:4:: -o hw:0 -V Digital -C 5
    SQUEEZESLAVE_PARAMETER=-n plugequal
    SHAIRPORT_PARAMETER=-d default:CARD=sndrpihifiberry -t hardware -m hw:1 -c Digital
    USE_USB_DAC=0
    USE_EQUALIZER=0
    SYSTEM_USER=pi
    YMPD_PARAMETER=–webport 8081
    BLUEALSA_PLAY_AUDIOCARD=hw:1,0
    BLUEALSA_PLAY_MIXER=Digital

    #### SQUEEZELITE -l ####
    Output devices:
    null – Discard all samples (playback) or generate zero samples (capture)
    equal
    plugequal – Equalizer for plughw:0,0
    bluetooth – Your Bluetooth device 88:AD:D2:1C:C1:04
    default:CARD=sndrpihifiberry – snd_rpi_hifiberry_dacplus, – Default Audio Device
    sysdefault:CARD=sndrpihifiberry – snd_rpi_hifiberry_dacplus, – Default Audio Device
    dmix:CARD=sndrpihifiberry,DEV=0 – snd_rpi_hifiberry_dacplus, – Direct sample mixing device
    dsnoop:CARD=sndrpihifiberry,DEV=0 – snd_rpi_hifiberry_dacplus, – Direct sample snooping device
    hw:CARD=sndrpihifiberry,DEV=0 – snd_rpi_hifiberry_dacplus, – Direct hardware device without any conversions
    plughw:CARD=sndrpihifiberry,DEV=0 – snd_rpi_hifiberry_dacplus, – Hardware device with all software conversions

    #### SHAIRPORT (SYNC) VERSION ####
    3.1.1-OpenSSL-Avahi-ALSA-soxr-sysconfdir:/usr/local/etc

    #### OUTPUT SOUND DETAILS CARD 0 ####
    closed

    #### OUTPUT SOUND DETAILS CARD 1 ####

    9. Mai 2018 at 13:31 #35620

    Hi Aylon,

    You can try removing the disable tick in Raspberry Settings and rebooting.

    9. Mai 2018 at 23:51 #35641

    Hi Heiner,

    Thanks again but that unfortunately did not change it.

    Tried following:
    – enabled on-board sound & changes sqeezlite audioplayer [SL] to hw:0 = music from SL works fine but no sound via BT streaming
    – added the dmix option = SL works fine but no sound via BT
    – tried all three soundcard options on BT site = no soud via BT

    last I upgraded kernel + updated all packages but still the Problem persists? I do not get any sound via BT streaming option?

    anything else maybe to test or see what might be the case? I can SSH into the RPi if that would add any value with the right commands?

    Thanks again
    Aylon

    10. Mai 2018 at 20:48 #35648

    Hi Heiner,

    Used the fathersday to start from scratch again and this time with another RPi i still had flying around. While at first I had the same issue with the bluetooth streaming it is now working.

    Seems as if the bluetooth streaming uses always the device #1 even if the on board sound is disabled and the AMP2 being at device #0 position.

    However, my AMP2 somehow did not play via squeezlite first when on-board sound is not disabled and the card is #1. So I disabled on-board sound change hw:1 to hw:0 with the audioplayer and it played well. Bluetooth however not at this time. I the enabled on-board sound again and magically both, bluetooth and audioplayer worked well.

    Strange but at the moment it is solved for now.

    Many thanks,
    Aylon

    14. Mai 2018 at 15:00 #35673

    Thanks for updating and letting me know. 🙂

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.

Register here