Allo Piano 2.1 sub volume

This topic contains 20 replies, has 7 voices, and was last updated by  Jaikumar 2 months ago.

Viewing 21 posts - 1 through 21 (of 21 total)
  • 2. April 2017 at 15:48 #27951

    Hi

    I can’t control my sub volume with SW. Im using Squeezelite and the app Ipeng. Sub volume is max all the time.
    Ipeng controls main speakers correct.
    HW setup: Raspberry PI3, Kali, Piano 2.1 Max2play SW version 2.41
    Squeezeserver running on NAS.
    Could anyone support here ?

    //Linus

    10. April 2017 at 22:26 #28087

    Anyone else that has a Solution ti Control sub volume out on allo piano2.1 ?

    12. April 2017 at 13:22 #28155

    Hi Lanny501

    Please make sure that you installed the custom kernel after you installed the Allo plugin, since the Subwoofer on Allo Piano needs a custom kernel to work properly.

    Regards,
    Mohammad Mbydeen

    12. April 2017 at 16:18 #28184

    I have been trying to install the Allo 2.1 custom kernel, on the Allo version of Max2Play. When I run the install, I get the messages copied below, which I find rather confusing. The installation *seems* to be successful, but after a restart I get the same message as previously: “Important: The PianoDAC with Subwoofer and the Allo Boss need a custom Kernel to run! Click here to install custom Kernel now!”
    ===
    Important: The PianoDAC with Subwoofer and the Allo Boss need a custom Kernel to run! Click here to install custom Kernel now!
    Kernel Update started
    Installation started – This Messages refreshes every 3 seconds to show current installation status. When finished this message disappears.
    2011-01-01 18:17:14|
    Finished – Reboot needed! Click here to Reboot Now

    Important: The PianoDAC with Subwoofer and the Allo Boss need a custom Kernel to run! Click here to install custom Kernel now!
    Boot config parameters changed
    Please restart your device! To restart now just click here.
    Important: The PianoDAC with Subwoofer needs a custom Kernel to run! Click here to install custom Kernel now!

    12. April 2017 at 16:59 #28185

    Now all sorts of problems! Switching to the default Allo settings (Dac 2.1; not sure how or when they had switched to 2.0), I get sound from the subwoofer but nothing from the other speakers. Switching back to 2.0, now Max2Play hangs on reboot. Guess I’ll have to burn the image again and start over. 🙁

    12. April 2017 at 19:52 #28189

    Get the same as you Martin.
    Could anyone confirm if possible to remote controll sub out together with main on piano2.1 ?

    Linus

    12. April 2017 at 21:22 #28190

    There seem to be some oddities about the way Max2Play handles the Allo DAC Piano 2.1. (I should add that I’m running this DAC on the Allo Sparky, not on the Raspberry Pi.)

    The version of Max2Play that is downloaded from the Allo site is 2.41. With this version:
    1. Selecting the Piano 2.1 DAC from the drop down menu makes available the various sliders to control the DAC.
    2. There is no mention of a special driver or kernel being needed.
    3. However, the slider control for the subwoofer (“Settings for Subwoofer Mode (2.0, 2.1, 2.2), Default 2.1”) are set to 2.0, even though it is stated that 2.1 is the default.
    4. There is no sound from the subwoofer.

    After upgrading to Max2Play 2.42:
    1. Messages start to appear that a custom Kernel is needed for the Piano 2.1.
    2. However, these messages refer to the wrong DAC (the Boss, not the Piano 2.1). Consequently, I have ignored them. [I have screen shots of all this]
    3. The slider control for the subwoofer is still set to 2.0 instead of 2.1.
    4. After clicking the button to “restore the defaults” for these sliders, the slider control is now set to 2.1, and there is indeed now sound from all three speakers.
    5. However, the speakers don’t seem very balanced, and I haven’t yet figured out how to actually change the volume etc. ‘on the fly.’ I’m starting to think that playback has to be stopped and started again before changed settings take effect.

    Does anyone know how to check which kernel/driver has actually been installed?

    Martin

    13. April 2017 at 11:17 #28197

    Dear Martin

    Please note that we do not provide technical support for Allo Sparky at moment, therefore we do not guarantee the behaviour of Max2Play on it.

    Best Regards,
    Mohammad Mbydeen

    13. April 2017 at 13:42 #28222

    That seems quite disingenuous, Mohammad. You provide a version of Max2Play that runs on the Sparky (sparky_sd_vana_1_3_200317). This identifies itself as “Version 2.41, Allo Sparky”. It upgrades to “Version 2.42, Allo Sparky.”

    In addition, on the Max2Play website you announced in December 2016, “We are happy to announce a new Max2Play Partner today: Allo. With the Piano Dac 2.1 by Allo, we are now, for the first time, supporting a sound card that also supports a subwoofer… The sound card is compatible with both the Raspberry Pi and the Allo-developed Sparky-Board…. Thus, we recommend the Kali Reclocker in combination with the Piano DAC 2.1 in our Shop. This combination works, as usual with Max2Play, directly out-of-the-box…”

    Where on you webpages do you state that you do not guarantee the behaviour of Max2Play on the Sparky?

    Martin

    16. April 2017 at 3:24 #28267

    Lanny501, I’ve reinstalled with Max2Play 2.41, which does not offer, or call for, a custom kernel. I am currently avoiding 2.42 because I’ve found that with that version:
    1. the message to install the custom kernel reappears each time after I have attempted the install
    2. the sound quality is notably poorer

    With 2.41 I had to set the subwoofer mode to 2.1. However, like you, I’m finding that when I adjust the volume (I use both iPeng and Squeezepad) the subwoofer volume is unchanged.

    Perhaps someone at Max2Play Headquarters can tell us whether the custom kernel is in fact installed by 2.42, and why the sound might be poorer with that installation.

    Anyone else out there using the Piano 2.1?

    Martin

    18. April 2017 at 5:57 #28301

    Still no solution for controlling sub out with ipeng on piano 2.1….
    Problem is that sub out is a fixed volume. This is ofcourse not working solution.
    Max2play could you test this and recomend solution or update SW to include this.
    The custom kernel is not doing the trick for me either 🙁

    19. April 2017 at 0:33 #28337

    I was able to install the Allo Plugin (<https://www.max2play.com/en/portfolio/plugin-allo/&gt😉 into the Sparky version of Max2Play version 2.41.

    The sliders that were then visible no longer included the subwoofer volume (Like this image: <https://www.max2play.com/?galleries=plugin-allo-en&gt;), which made me hopeful that there was now a single system volume that could be controlled through iPeng or similar.

    However, after this installation the squeezelite player would no longer run, so I was unable to test this possibility.

    Martin

    26. April 2017 at 12:51 #28531

    Although I’m using Max2play on all devices, I installed Volumio for my Vana player to use it in first 2.0 and now 2.2 mode. It uses the shared volume from my max2play server device. I would also like to have a working version of Max2play to have all players in one webpage and also set de eq via webinterface.

    30. May 2017 at 11:45 #29115

    Hi guys,

    Sorry about the wait.

    @ Martin: Sorry about the confusion. We’ll add a disclaimer regarding the Sparky board. Please contact Allo for support for this board and its software.

    @Lanny: We will look into this, sorry about the delayed response. Does the Piano run fine otherwise? Please share your setup in more detail and update Max2Play if you have not yet.

    @frederik: Thanks for the input. Please contact Allo on the Vana Player support.

    9. August 2017 at 13:08 #30513

    The Piano runs fine in a setup with the Kali and Raspberry PI. This is connected to active speakers ELAC and 2 sub from Sunfire. Still I would like to use the Piano 2.1 with the separate sub out to get the max out of the setup. Although without shared volume wit the main this is not possible. Max2Play are you looking into fixing this ? Anyone else that has solved this ?
    Thanks for a great software and easy setup 🙂

    9. August 2017 at 15:56 #30524

    Hi guys,

    There is an update! We now allow separate volume control. Just follow these steps:
    – Beta-Update Max2Play under Settings/Reboot
    – Do a Kernel Upgrade in the Raspberry Settings menu (button at the bottom of the page)
    – The Kernel should now be Kernel 4.9.41 (you can check in Settings/Reboot in the Debug Info)
    – The beta updated Allo Plugin menu now has a “Master” element to adjust the volume
    – If you want to connect it to Squeezelite, you have to replace the -V Digital with -V Master in the commando line options of Squeezelite

    22. August 2017 at 13:40 #30794

    Hi All
    Piano and Kali runs fine But !
    If you set Master at 50% and Sub to 30% ok sub is damping ok, if you then change the volume in mediaplayer then the sub out follow the master volume again.
    it should hold the difference at 20% between Master and sub out.

    best regards
    Natravn

    23. August 2017 at 11:55 #30839

    Master volume changes both digital & sub volumes equally. It will not maintain any ratio b/w the two volumes.

    23. August 2017 at 15:29 #30842

    is it somthing that is doable in a config or is it hardcoded in the kernel module ?

    23. August 2017 at 15:34 #30843

    if you have a pair of bokshelf spk. and a 12″ subwofer, then the sub if tooo LOUD then it woud be nize to dampen the sub output

    24. August 2017 at 5:55 #30848

    It is not configurable. This option will be considered for future improvement.

Viewing 21 posts - 1 through 21 (of 21 total)

You must be logged in to reply to this topic.

Register here