Airtunes Drops in and out

Max2Play Home Forums Max2Play on Raspberry PI Airtunes Drops in and out


Viewing 14 posts - 1 through 14 (of 14 total)
  • 17. November 2021 at 23:10 #51794

    I’m trying to use Airtunes to play Sirius/XM through my RPi 3 network using Squeezelite and Shairport. After much effort, I got it working by putting the Squeezelite URL into Shairport. But, the audio stream starts and stops, and eventually audio stops and must be restarted on my iphone. I’ve tried other apps (such as podcasts) with the same result – audio stops and starts and eventually it all dies.

    Anyone have any ideas on what’s going on?

    Much appreciated!

    18. November 2021 at 14:41 #51796

    Also, should have mentioned, WiFi signal is very strong (and on a commercial grade WiFi system), and well within bluetooth range. I’m stuck… would sure appreciate any pointers to making this a solid connection!

    19. November 2021 at 13:42 #51799

    Hi Dave,

    You don’t really need Squeezelite to stream Airplay. Shairport should be sufficient for that. The best thing to do is to try removing Squeezelite from the autostart and stop it so that the two don’t get in each other’s way.
    Apart from that, you could also try using plugins for the Squeezebox server to get Airplay to work. Here you can find more information about the possibilities:

    19. November 2021 at 15:49 #51803

    Hi MarioM,

    Thanks much for responding!

    First, yes, Squeezelite is not required to stream Airplay via Shareport. However, everything else I use this system for requires Shareport. I can’t stream radio, play local media, etc., without Squeezelite. So, yes, the issue appears to be an incompatibility between Squeezelite and Shareport, but stopping Squeezelite every time I want to use Airplay is just not a good solution.

    I’ve gone through the link you sent pretty carefully, and I’ve had to insert the IP address of the Squeezelite server into Shairport to even get this far.

    I’ve tried using the Shairtunes 2 (fork) as well. I’m using the Shareport_Helper-armv6f as the helper binary since (as I understand it) the Broadcom BCM2837 processor in my RPi3b is an Arm processor derivative.

    In any case, with Shareport stopped, the Shairtunes 2 (fork) plugin installed, and Airplay running, I get the same issue; Airplay breaks up. Playing a song… is impossible… listening to a podcast via Airtunes is … irritating, because of the audio gaps.

    I have had some good discussion with Phillipe G. on this. He’s been exceptionally responsive and very helpful on trying to help me. His recommendation was that Shairtunes should not be required; Shairport should work.

    I’ve also tried using Airplay Bridge. However, after installation of the plugin, attempting to get to the Settings tab … Airplay Bridge never responds.

    So I remain stuck. I much appreciate any input you can provide.

    Thanks again!

    23. November 2021 at 18:04 #51806

    Hi Dave,

    I have tested the automatic switch of Squeezelite and Shairport again and could not reproduce your problem. Instead, however, I came across another one: If I start playback via Squeezelite while a stream via Shairport is running, the Shairport stream does not stop but continues to run and the two streams overlap. The same applies vice versa.
    I will discuss the whole thing again with our developer and hopefully be able to offer you a solution afterwards.

    23. November 2021 at 20:52 #51808

    Thanks so much!

    For clarity, here are the specifics on my setup:

    RPi „Pool“ – M2P v2.53, RPi is a Pi 3 Model B v1.2. It’s using a HiFiBerry output card.

    I’m running Logitech Media Server V7.9.1 on this RPi.

    I believe both of these are up to date.

    There are two other RPis in the M2P network. Neither is running LMS. Both are running M2P v2.53.

    The iphone is also up to date (iPhone 13), and it’s within about 2 meters of the RPi. It plays all other bluetooth devices without any dropouts (music or podcasts).

    Thanks again!

    25. November 2021 at 16:36 #51813

    I tested the whole thing again with your setup (and an iPhone 7). It worked for me that Airplay interrupts the playback of Squeezelite. And this is exactly what should happen when you enter the server IP in the advanced settings of Shairport. If you stream music via Squeezelite and then connect the player via Airplay and start playback, the Squeezelite stream is interrupted by Airplay. If you then stop Airplay again, Squeezelite playback should resume. However, it is not possible to interrupt Airplay playback with Squeezelite.

    When exactly do the dropouts occur? When you change the playback source? Or generally when you stream via Airplay? Are there any error messages in the server log file? You can find the log under Settings/Information.

    7. Dezember 2021 at 1:19 #51834

    Hi Mario,

    First, and most importantly, thanks again for your very kind support. I really do appreciate it. You went over the top by doing testing specifically for me … much (MUCH) appreciated.

    I was able to put time into the issue this weekend, and I found and fixed the issue. As I’m sure you suspected, the problem was that I’m an idiot. After exhaustively trying everything else, I chose to select the „update squeezeplay“ button. After updating, and rebooting, I now have a reliable airplay connection.

    I’m betting that you never hear the rest of the story for many of the issues you deal with. Mine was just that simple, and confirms that I’m a dummy. I should have tried that first… I really just never noticed the check box for updating until I’d pulled out all of my hair.

    Again, thanks so much – I really appreciate your support!

    7. Dezember 2021 at 12:53 #51837

    No problem 🙂 I’m glad you found a solution. And I didn’t come up with the solution either, so thank you for sharing it with us.

    16. Dezember 2021 at 17:39 #51848

    Mario, may I ask an additional question?

    My bluetooth link is working fine after I pulled my head out of … well, you know…

    But I do have one question that I haven’t been able to find an answer to.

    I’ve got a three player setup in my system, using three RPis. I can link to one of the three players and use the airtunes link to play music, etc., from my iphone.

      How can I play Airtunes through all three linked players after linking to the first?

    Thanks so much – I really appreciate your help!


    21. Dezember 2021 at 14:48 #51858

    Hi Dave,

    I am not an iPhone user, so I can probably only help you to a limited extent. Normally, you should be able to set which Airplay player you want to connect to when playing music. You should also be able to select multiple players at the same time. With iTunes on the PC, this is possible with checkboxes. There should be something similar on the iPhone. You could try searching Google for „How to AirPlay to multiple devices on iPhone“.

    27. Dezember 2021 at 17:28 #51864

    Thanks. After doing some work on it, it would seem that the Airplay implemented in Max2Play is the original (Airplay 1) system… in 2018 Apple introduced Airplay 2, which allows for multiple players. The system as it stands doesn’t allow streaming to more than one player at a time from my iPhone 13 Pro running IOS 15.2 (the most recent version of both iphone and IOS available). I get a check when selecting the player … no circle to fill (which as I understand it I should see with Airplay 2).

    I’m running LMS 8.2.0 on my RPi. The firmware on my players is, however, Max2Play v1.0.3 based on v1.8.7-999. I don’t see a way to update that if that’s in fact the problem.

    You have been very kind … do you have any suggestions?


    4. Januar 2022 at 15:54 #51875

    Hi Dave,

    That could be the reason. In this case, you could try to update Shairport on your own (we do not currently offer this). You would have to follow these instructions:
    Unfortunately, we cannot give you any guarantee that the whole thing will work. It is also explicitly mentioned that this is a limited version of Airplay 2.

    4. Januar 2022 at 16:24 #51880

    Thank you sir. I’ll give it a try, and I understand the limitations as you’ve described them. I again want to express my appreciation… it’s a great system, and you’ve been very kind (and patient) in helping me out.


Viewing 14 posts - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.

Register here