Airplay to Digi+ I2S to DDDAC gives only static noise

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Airplay to Digi+ I2S to DDDAC gives only static noise

This topic contains 4 replies, has 2 voices, and was last updated by  Heiner Moderator 2 years, 2 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • 1. Mai 2019 at 18:30 #45197

    Hi!
    I am using mx2play with HiFiberry plugin trying to stream music with Airplay to a Raspberry Pi 3 B+ with an Allo isolator and HiFiberry Digi+ Pro. The Digi+ Pro is connected to a DDDAC 1794 via I2S.
    As soon as I start to play a file I get static like noise without any hint of music. When I stop replay the noise just continues until I kill Shairport. I tried all the options in the „Erweiterte Optionen“ dropdown menu in Audioplayer/Status:Shairport
    Squeezelite is turned off.
    Does anyone have an idea what could be going on?

    #### SQUEEZELITE VERSION ####
    Squeezelite Max2Play v1.0.2 based on v1.8.4-726, Copyright 2012-2015 Adrian Smith, 2015-2016 Ralph Irving.

    #### SQUEEZELITE BUILDOPTIONS ####
    Build options: LINUX ALSA EVENTFD RESAMPLE FFMPEG VISEXPORT IR GPIO DSD CONTROLSBS ALSASYNC BLUETOOTHSYNC

    #### AUDIOPLAYER CONFIG ####
    ### Configuration of Audioplayers
    SQUEEZELITE_PARAMETER=-o sysdefault:CARD=sndrpihifiberry -a 80:4::
    SQUEEZESLAVE_PARAMETER=-n plugequal
    SHAIRPORT_PARAMETER=-d plug:equal
    USE_USB_DAC=0
    USE_EQUALIZER=0
    SYSTEM_USER=pi
    YMPD_PARAMETER=–webport 8081

    #### SQUEEZELITE -l ####
    Output devices:
    null – Discard all samples (playback) or generate zero samples (capture)
    equal
    plugequal – Equalizer for plughw:0,0
    default:CARD=sndrpihifiberry – snd_rpi_hifiberry_digi, – Default Audio Device
    sysdefault:CARD=sndrpihifiberry – snd_rpi_hifiberry_digi, – Default Audio Device
    iec958:CARD=sndrpihifiberry,DEV=0 – snd_rpi_hifiberry_digi, – IEC958 (S/PDIF) Digital Audio Output
    dmix:CARD=sndrpihifiberry,DEV=0 – snd_rpi_hifiberry_digi, – Direct sample mixing device
    dsnoop:CARD=sndrpihifiberry,DEV=0 – snd_rpi_hifiberry_digi, – Direct sample snooping device
    hw:CARD=sndrpihifiberry,DEV=0 – snd_rpi_hifiberry_digi, – Direct hardware device without any conversions
    plughw:CARD=sndrpihifiberry,DEV=0 – snd_rpi_hifiberry_digi, – Hardware device with all software conversions

    #### SHAIRPORT (SYNC) VERSION ####
    3.1.1-OpenSSL-Avahi-ALSA-soxr-sysconfdir:/usr/local/etc

    #### OUTPUT SOUND DETAILS CARD 0 ####
    closed

    #### OUTPUT SOUND DETAILS CARD 1 ####

    1. Mai 2019 at 20:53 #45198

    I changed to the basic „simple airplay“ and was able to play a youtube video. Lots of crackling, but the sound of the video was audible.
    Then I switched on iTunes and tried to play a song. This made the laptop switch to internal speakers. Trying to choose max2play as output device didn’t work and gave me the error message that max2play is busy and I need to choose another airplay device.

    2. Mai 2019 at 13:45 #45206

    Hello Rauschen,

    Which selection did you try for sound card in Shairport? Please make sure it’s default or sysdefault.

    2. Mai 2019 at 21:47 #45221

    The standard was sysdefault. I tried all others as well without any change.

    3. Mai 2019 at 10:27 #45232

    Did you deactivate the built-in audio? If so, please check the command line options of shairport and paste them here.

    Please try running the Digi+ Pro directly on the Pi to rule out the Isolator as a possible source of error.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.

Register here